goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97649
Top-Poster: Johannes_B (5052)

Wir begrüßen unseren neuesten Benutzer Dominik95.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Abstand Überschrift-Text kleiner als Absatzabstand

 

Evilamblonyx
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 25.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.03.2019, 18:17     Titel: Abstand Überschrift-Text kleiner als Absatzabstand
  Antworten mit Zitat      
Hallo,
ich muss den Abstand zwischen Überschrift und dem folgenden Text kleiner machen als dern Abstand nach einem Absatz im Text.
Im Minimalbeispiel passt der Abstand des Absatzes im Text mit der Zeile:
\setlength{\parskip}{12pt}
Aber dann ist der Abstand der Überschrift zum Text zu groß. Ohne die Zeile passt er.

Code • Öffne in Overleaf

\documentclass[12pt,paper=a4,
headings=small,
openany,
oneside,
]{scrbook}

%Abstände nach Überschriften
\RedeclareSectionCommand[
  beforeskip=18pt,
  afterskip=12pt,
]{chapter}
\RedeclareSectionCommand[
  beforeskip=18pt,
  afterskip=6pt
]{section}
\RedeclareSectionCommand[
  beforeskip=18pt,
  afterskip=6pt
]{subsection}
\RedeclareSectionCommand[
  beforeskip=1pt,
  afterskip=1pt
]{paragraph}

%%%%
%Hier kommt die fragliche Zeile. Ohne sie passt der Abstand der Überschriften zum Text, mit ihr der Abstand der Absätze im Text
\setlength{\parskip}{12pt}  
%%%%

\begin{document}
\chapter{Hallo}
Hier kommt gleich ein Absatz

TextTextTextTextTextTextTextTextText

\section{HalloHallo}
TextTextTextTextTextTextTextTextTextTextTextText

\subsection{HalloHallo}
TextTextTextTextTextTextTextTextTextTextTextTextT

\paragraph*{hallohallo}
TextTextTextTextTextTextTextTextTextTextTextText

\end{document}
 


Mir ist das Problem im Prinzip klar. Dardurch das ich einen Wert für \parskip setze, wird er auch nach der Überschrift eingefügt. Aber wie kann ich das verhindern?
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3884
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.03.2019, 20:13     Titel:
  Antworten mit Zitat      
Wenn du ein aktuelles KOMA hast, kannst du afterskip sogar negative Werte geben. Du musst dann nur auch den runin-Schalter setzen:

Code • Öffne in Overleaf
\RedeclareSectionCommand[
  beforeskip=18pt,
  afterskip=-6pt,
  runin=false,
]{section}

_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.03.2019, 21:30     Titel: Re: Abstand Überschrift-Text kleiner als Absatzabstand
  Antworten mit Zitat      
Evilamblonyx hat Folgendes geschrieben:
\setlength{\parskip}{12pt}

Sollte man bei einer KOMA-Script-Klasse übrigens besser nicht verwenden. Stattdessen besser Option parskip verwenden. Notfalls kann man feinere Einstellungen als die Option bietet mit \setparsizes erreichen.

Evilamblonyx
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 25.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.03.2019, 22:30     Titel:
  Antworten mit Zitat      
u_fischer hat Folgendes geschrieben:
Wenn du ein aktuelles KOMA hast, kannst du afterskip sogar negative Werte geben. Du musst dann nur auch den runin-Schalter setzen:

Code • Öffne in Overleaf
\RedeclareSectionCommand[
  beforeskip=18pt,
  afterskip=-6pt,
  runin=false,
]{section}


Vielen dank für die Antwort. In meiner Umgebung (Texmaker) und auch in Overleaf bekomme ich mit der Option den Fehler:
! Package scrbase Error: unknown option ` runin=false '.
Vermutlich passt also die KOMA Version nicht. Wo kann ich sehen welche ich habe und die aktualisieren?

In Overleaf

@Gast: Leider ist der genaue Abstand von der Uni vorgegeben.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.03.2019, 23:57     Titel:
  Antworten mit Zitat      
Evilamblonyx hat Folgendes geschrieben:
Vermutlich passt also die KOMA Version nicht. Wo kann ich sehen welche ich habe und die aktualisieren?


https://texwelt.de/wissen/fragen/569#Version

Evilamblonyx
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 25.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 12.03.2019, 00:58     Titel:
  Antworten mit Zitat      
Super, hat funktioniert. Version ermittelt - war eine alte - und dann das Paket neu installiert. Jetzt klappt alles wie es soll.

Vielen dank für eure schnelle Unterstützung.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 12.03.2019, 08:41     Titel:
  Antworten mit Zitat      
Evilamblonyx hat Folgendes geschrieben:
@Gast: Leider ist der genaue Abstand von der Uni vorgegeben.


Wie gesagt, sollte man auch in dem Fall nicht \parskip selbst setzen, sondern ggf. \setparsizes verwenden. Näheres ist der KOMA-Script-Anleitung oder dem KOMA-Script-Buch zu entnehmen.

markusv
Forum-Meister
Forum-Meister

Beiträge: 710
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: Kubuntu 18.04 LTS + TeXLive 2018
     Beitrag Verfasst am: 12.03.2019, 08:56     Titel:
  Antworten mit Zitat      
Evilamblonyx hat Folgendes geschrieben:
@Gast: Leider ist der genaue Abstand von der Uni vorgegeben.
Als nice to know: Beachte, dass 1pt nicht gleich 1pt ist. In Word und LaTeX unterscheiden sich diese geringfügig. 1pt in Word entspricht 1bp (bigpoint) in LaTeX. Wenn es deine Uni da schon so genau nimmt, ist es vielleicht sogar von Bedeutung. Obwohl ich nicht glaube, dass sich jemand an die Arbeit setzt und misst, was diese peniblen Vorgaben meist ad absurdum führt Rolling Eyes
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Evilamblonyx
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 25.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 12.03.2019, 15:32     Titel:
  Antworten mit Zitat      
@ Gast:
Dank für den Hinweis. Ich habe mir die Dokumentation angeschaut. Und lustigerweise steht das KOMA Buch neben mir im Regal. Aber das mit dem \setparsizes hab ich wohl überlesen. Ich hab das in mein Dokument wie von dir vorgeschlagen übernommen.

@markusv:
Vielen Dank für den Hinweis! Ich hab mich schon gewundert, warum das trotzdem nicht genau gepasst hat. Jetzt sieht es echt super aus.
Teilweise werden wohl Abschlussarbeiten auf eine "richtig" formatierte Beispielseite gelegt, und dann mit Durchlicht geschaut ob die Absätze usw. gleich groß sind. Kommt immer drauf an wie gewogen einem da alle sind, und ob vielleicht gerade ein Kollege einem Betreuer ans Bein pinkeln will.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de