goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97614
Top-Poster: Johannes_B (5052)

Wir begrüßen unseren neuesten Benutzer Elkaweh.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Zitation im Fließtext anpassen

 

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.03.2019, 17:42     Titel: Zitation im Fließtext anpassen
  Antworten mit Zitat      
Hallo zusammen,

Ich habe Probleme mit der Zitation der Quellen im Text.

Ich würde gerne den Zitationsstil wie folgt haben. Im Text sollte die Quelle am Ende eines Absatzes (ich verwende hierzu immer den Befehl \cite{BibTex key}) in folgender Form: [Nachname, Jahreszahl] bzw. [Nachname, Jahreszahl; Nachname, Jahreszahl] falls mehr als eine Quelle angegeben ist, ändern.
Im Literaturverzeichnis sollen die Quellen alphabetisch geordnet werden und dann natürlich alle Namen angezeigt werden (das funktioniert auch bereits!!).

Mein Vorgehen bislang:
Literaturquellen in Citavi eingepflegt: Nachname, Vorname and Nachname, Vorname falls wiederum mehr als eine Quelle.
Ich habe mir dann die passende Zitationsweise im Citavi ausgewählt und mir die .bib-Datei exportiert.

Im Latex habe ich den Code bislang (Auszug) so geschrieben:

\usepackage[backend=biber,
citestyle=authoryear-ibid,
bibstyle=authoryear,
hyperref=auto,
isbn=false,
doi=false,
maxcitenames=1
sorting=nyt,
natbib=true,
abbreviate=false,
dashed=false,
maxnames=10,
minnames=1]{biblatex}
...

\printbibliography

Mein Problem ist es jetzt, dass die Zitation am Ende der Absätze noch nicht meinem Wunschstil entspricht.
Bislang werden die Quellen, z.B. bei 2 Quellen mit 2 Autoren, in Form: Name, Vorname and Name, Vorname, Jahreszahl; Name, Vorname and Name, Vorname, Jahreszahl
angezeigt.

Wie schaffe ich es, die gewünschte Form zu erreichen?! Eine Veränderung der maxnames und minnames hat leider mein Problem nicht behoben.
Vielen Dank für eure Hilfe.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.03.2019, 18:09     Titel:
  Antworten mit Zitat      

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.03.2019, 18:22     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
\DeclareNameAlias{sortname}{family-given}

würde tippen. Allerdings habe ich das nicht getestet. Wenn Du gerne Antworten hättest, die getestet wurden und auf Deine Einstellungen abgestimmt sind, dann zeig uns bitte ein vollständiges InfoMinimalbeispiel, das mit \documentclass beginnt, die relevanten Pakete lädt und relevante Einstellungen in der Präambel vornimmt und dann in einem kurzen \begin{document}...\end{document} mit ein paar relevanten Beispielzitaten etc. endet.

Was ich Dir jetzt schon sagen kann ist, dass citestyle=authoryear-ibid, bibstyle=authoryear, sorting=nyt, äquivalent zum kürzeren style=authoryear-ibid, ist. Ich empfehle, bibstyle und citestyle zusammen via style zu setzen, wenn keine Stilmischungen gewünscht sind. Ferner würde ich sorting weglassen, wenn die genutzte Option der Voreinstellung des Stils entspricht, das reduziert das Risiko, beim Stilwechsel mit einer unpassenden Sortierung zurückzubleiben. hyperref=auto, ist die Voreinstellung und muss daher nicht extra angegeben werden (ist aber meiner Meinung nach besser als das häufig genutzte hyperref=true, das nicht so mächtig ist, wie es klingt).

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.03.2019, 19:33     Titel:
  Antworten mit Zitat      
Das ist mein Minimalbeispiel. Ich habe die Anregungen schon eingearbeitet. Änderungen am Ergebnis ergaben sich dadurch leider noch nicht. Danke schon mal

Code • Öffne in Overleaf

\documentclass[
12pt,                      % Schriftgroesse 12pt
a4paper,                   % Layout fuer Din A4
ngerman,                   % neue deutsche Rechtschreibung nach der Reform
oneside,                   % Layout fuer einseitigen Druck
headinclude,               % Kopfzeile wird Seiten-Layouts mit beruecksichtigt
headsepline,               % horizontale Linie unter Kolumnentitel
plainheadsepline,          % horizontale Linie auch beim plain-Style
BCOR=12mm,                 % Korrektur fuer die Bindung
DIV=18,                    % DIV-Wert fuer die Erstellung des Satzspiegels, siehe scrguided statt Absatzeinzug
openany,                   % Kapitel können auf geraden und ungeraden Seiten beginnen
bibliography=totoc,        % Literaturverz. wird ins Inhaltsverzeichnis eingetragen
toc=listof,                % Abbildungs- Tabellen- und sonstige verzeichnisse mit ins Inhaltsverzeichnis
numbers=noenddot,          % Kapitelnummern immer ohne Punkt
captions=tableheading,     % korrekte Abstaende bei TabellenUEBERschriften
parskip                 % Absätze werden nicht eingerückt  
]{scrbook}[2001/07/30]     % scrbook-Version mind. 2.8j von 2001/07/30

\usepackage[T1]{fontenc}                       % T1-kodierte Schriften, korrekte Trennmuster fuer Worte mit Umlauten
\usepackage[utf8]{inputenc}                    % Input-Encodung: utf8 fuer Windows
\usepackage{lmodern}                           % Verwendung der Schriftart Latin Modern
\usepackage[ngerman]{babel}                    % neue Rechtschreibung
\usepackage[babel,german=quotes]{csquotes}     % deutsche Anführungszeichen
\usepackage{ae}                                % Für PDF-Erstellung
\usepackage[
format=hang,
font={footnotesize, sf},
labelfont={bf},
textfont={it},
margin=1cm,
aboveskip=5pt,
belowskip=-20pt,
]{caption,subfig}                          % mehrzeilige Captions ausrichten; subfig: Untergrafiken
\usepackage[centertags]{amsmath}               % AMS-Mathematik, centertags zentriert Nummer bei split
\usepackage{amssymb}                           % zusätzliche Symbole
%\usepackage{gensymb}                          % zur Verwendung des Grad-Symbols
\usepackage{trfsigns}                       % für bestimmte Symbole
\usepackage{graphicx}                          % zum Einbinden von Grafiken
\usepackage[svgnames,table,hyperref]{xcolor}
\usepackage{float}                             % u.a. genaue Platzierung von Gleitobjekten mit H
\usepackage{epsfig}                            % eps Format für Grafiken
\usepackage[pdftex,pstarrows]{pict2e}
\usepackage{array}
\usepackage{listings}                     % Code-Einbindungsumgebung
\usepackage{courier}                           % verwende Courier statt cmtt als

%ab hier wird es wichtig!!
\usepackage[backend=biber,
style=authoryear-ibid,
isbn=false,
doi=false,
maxcitenames=1
sorting=nyt,
natbib=true,
abbreviate=false,
dashed=false, % alle Verzeichniseinträge desselben Autors mit Namen beginnen, nicht nur den ersten
maxnames=1,
minnames=1]{biblatex}

\addbibresource{Bibliothek2.bib}

\DefineBibliographyStrings{ngerman}{andothers={et\addabbrvspace al\adddot}}
\ExecuteBibliographyOptions{maxcitenames=1,mincitenames=1}
\renewcommand*{\mkbibnamefamily}[1]{\textsc{#1}}
\DeclareFieldFormat[online]{title}{\emph{#1}}
\DeclareFieldFormat[online]{url}{Verf\"ugbar unter: \url{#1}}
\DeclareFieldFormat[online]{urldate}{(zuletzt gepr\"uft am: {#1})}
\DeclareFieldFormat[article]{number}{Heft {#1}}
 
\pdfoutput=1              
\usepackage[pdftex,  % muss letztes Package sein!
pdftitle={Titel der Arbeit},%
pdfauthor={Vorname Nachname},%
pdfsubject={Themen},%
pdfkeywords={ ... },%
pdfstartview={FitH},%
pdfstartpage={5},%
bookmarks,%
raiselinks,%
pageanchor,%
hyperindex,%
colorlinks,%
citecolor=black!60!black,%
linkcolor=black!70!black,%
urlcolor=magenta!70!black,%
filecolor=magenta!70!black,%
menucolor=orange!70!black,%
]{hyperref}  

\begin{document}
   
Die Wahrnehmung hängt auch vom Verhältnis zwischen Konstruktionsband und sichtbaren Fläche der Widerlager ab, die maßgeblich durch die Böschungssituation beeinflusst wird. \cite{Geiler.2014, Geier.2017, Haveresch.2009, Haveresch.2014}  

\printbibliography
   
\end{document}
 


Bibliothek2.bib
 Beschreibung:

Download
 Dateiname:  Bibliothek2.bib
 Dateigröße:  24.89 KB
 Heruntergeladen:  50 mal
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1658
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 05.03.2019, 20:07     Titel:
  Antworten mit Zitat      
Lies bitte den Abschnitt zu dem in der Präambel geladenen Paket ae in l2tabu.

Ich finde es übersichtlich, die sprachabhängigen Beschriftungen und die Formatierung der Ausgabe zu trennen. Beispiel:

Code • Öffne in Overleaf
\DefineBibliographyStrings{german}{
   andothers={et\addabbrvspace al\adddot
},
   urlseen={zuletzt geprüft am}
}
\DeclareFieldFormat[online]{urldate}{\mkbibparens{\bibstring{urlseen}\addcolon\space#1}}
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.03.2019, 07:55     Titel:
  Antworten mit Zitat      
Ich habe die Präambel mal auf das für uns Wesentliche reduziert und die Klasse article genommen, damit das Literaturverzeichnis nicht auf einer neuen Seite beginnt, das macht es übersichtlicher.

Ferner habe ich Deinen biblatex-Code nach Bartmans Vorschlägen umgearbeitet. Das \ExecuteBibliographyOptions{maxcitenames=1,mincitenames=1} war wegen der Voreinstellungen beim Laden des Paketes redundant und fällt daher weg.

Ich habe mir nur die vier zitierten Quellen angesehen, da die .bib-Datei doch recht lang ist, aber schon dort zeigen sich Probleme. Einzig und allein der Eintrag Geiler.2014 hat ein korrektes author-Feld. Alle anderen sind inkorrekt: Die Doppelten Klammern unterbinden das Parsen des Namens vollständig und führen dazu, dass biblatex denkt, es handele sich um eine Person mit sehr langem Nachnamen. Das Semikolon als Trennzeichen ist falsch: In der Eingabe ist immer ein and notwendig, egal wie die gewünschte Ausgabe ist.

Die Einträge sind aber auch sonst eher weniger hübsch. So ist einer der großen Vorteile von biblatex und Biber, dass sie mit UTF-8 umgehen können, wenn man dann wieder zu der ASCII-Makro-Methode {\ss} und {\"u} statt ß und ü übergeht, hat man da nichts gewonnen. Das Kerning ist noch immer dahin.

Im publisher-Feld sind Klammern häufig überflüssig (man braucht sie eigentlich nur, wenn der Name ein and enthält). Das institution-Feld wir bei @book nicht gelesen und es ist wenig sinnvoll darin, den publisher zu duplizieren. Das Feld pagination={pages}, entspricht der Voreinstellung, ist also eigentlich unnötig.

Wenn das korrigiert ist, funktioniert auch die Sache mit sortname.

Code • Öffne in Overleaf
\documentclass[ngerman]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage{babel}
\usepackage[autostyle]{csquotes}

\usepackage[backend=biber,
  style=authoryear-ibid,
  isbn=false,
  doi=false,
  sorting=nyt,
  natbib=true,
  abbreviate=false,
  dashed=false,
  maxbibnames=999,
  maxcitenames=2,
  minnames=1
]{biblatex}

\NewBibliographyString{journum}
\DefineBibliographyStrings{german}{
  andothers={et\addabbrvspace al\adddot
},
  urlseen = {zuletzt geprüft am},
  urlfrom = {verfügbar unter},
  journum = {Heft},
}

\renewcommand*{\mkbibnamefamily}[1]{\textsc{#1}}
\DeclareNameAlias{sortname}{family-given}

\DeclareFieldFormat[online]{title}{\mkbibemph{#1}}
\DeclareFieldFormat[online]{url}{\bibstring{urlfrom}\addcolon\space\url{#1}}
\DeclareFieldFormat[online]{urldate}{\mkbibparens{\bibstring{urlseen}\space#1}}
\DeclareFieldFormat[article]{number}{\bibstring{journum}~#1}

\usepackage{hyperref}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@book{Geier.2017,
 author    = {Geier, Roman and Graubner, Carl-Alexander and Kohoutek, Jaroslav and Angelmaier, Volkhard
},
 year      = {2017},
 title     = {Integrale Brücken: Entwurf, Berechnung, Ausführung, Monitoring},
 address   = {Berlin},
 publisher = {Ernst \& Sohn},
 isbn      = {978-3-433-60646-9},
}
@book{Geissler.2014,
 author    = {Geißler, Karsten
},
 year      = {2014},
 title     = {Handbuch Brückenbau: Entwurf, Konstruktion, Berechnung, Bewertung und Ertüchtigung},
 address   = {Berlin},
 publisher = {Ernst \& Sohn},
 isbn      = {978-3-433-60345-1},
}
@article{Haveresch.2009,
 author  = {Haveresch, Karlheiz and Maurer, Reinhard
},
 year    = {2009},
 title   = {Entwurf, Bemessung und Konstruktion von Betonbrücken},
 pages   = {125--244},
 volume  = {2010},
 number  = {1},
 journal = {Betonkalender}
}
@article{Haveresch.2014,
 author  = {Haveresch, Karlheiz and Maurer, Reinhard
},
 year    = {2014},
 title   = {Entwurf, Bemessung und Konstruktion von Betonbrücken},
 pages   = {679--818},
 volume  = {2015},
 number  = {1},
 journal = {Betonkalender}
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}
Die Wahrnehmung hängt auch vom Verhältnis zwischen Konstruktionsband und sichtbaren Fläche der Widerlager ab, die maßgeblich durch die Böschungssituation beeinflusst wird. \cite{Geissler.2014, Geier.2017, Haveresch.2009, Haveresch.2014}

\printbibliography
\end{document}

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.03.2019, 12:22     Titel:
  Antworten mit Zitat      
Ich habe jetzt meine bib-Datei (anbei) so umgearbeitet, dass lediglich eine {} bei den Autoren und bei allen anderen Angaben ist. Zudem habe ich alle Dateien jetzt als "book" ausgeben lassen.

Zudem habe ich die letzten Anregungen auch in mein Dokument eingearbeitet.

Die Zitation im Text erfolgt bereits für Bücher mit einem Autor in der richtigen Form: Nachname, Jahreszahl; Nachname, Jahreszahl
Leider werden bei mehreren Autoren noch alle Autoren mit einem dazwischenliegenden "and" angezeigt, was auch bei der Anzeige im Literaturverzeichnis noch der Fall ist. Hier wäre mir die Variante Nachname et al., Jahreszahl am liebsten.

Meine tex.datei sagt mir, dass er die Befehlen \adddot und \url nicht erkennt. Dies dürfte ja für die richtige Anzeigeform mit Nachname et al., Jahreszahl auch noch ein Problem darstellen.

Danke für eure Hilfe Smile

Bibliothek.bib
 Beschreibung:

Download
 Dateiname:  Bibliothek.bib
 Dateigröße:  24.35 KB
 Heruntergeladen:  46 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.03.2019, 19:36     Titel:
  Antworten mit Zitat      
Soweit ich sehen kann, sind auch in der aktualisierten .bib-Datei noch falsch formatierte author-Felder, z.B. Bieger.1995, Bulicek.2010, Geier.2017, ... Da sollten die Klammern noch weg.

Zitat:
Zudem habe ich alle Dateien jetzt als "book" ausgeben lassen.

Wieso das denn? Wenn Du Einträge, die keine Bücher sind, wie z.B. Schuller.2004 als @book exportierst, dann ist die Ausgabe eher nicht zufriedenstellend. Das würde ich sofort wieder rückgängig machen.

Zu der Sache mit dem "et al." in Zitaten: Zur Zeit bekommst Du "Autor1, Jahr" bei einem Autor, "Autor1 und Autor2, Jahr" bei zwei und "Autor1 et al., Jahr" bei drei oder mehr. Ich halte es für Kokolores aus dem Zwei-Autoren-Fall "Autor 1 et al., Jahr" zu machen (schließlich ist "et al." normalerweise plural). Aber wenn es sein muss, dann musst Du halt maxcitenames=1 setzen. Eventuell kommt Dir dann irgendwann die uniquelist- oder die uniquename-Option dazwischen. Was Du da für Möglichkeiten hast, kannst Du der biblatex-Dokumentation unter diesen Schlagwörtern entnehmen.

Zitat:
Meine tex.datei sagt mir, dass er die Befehlen \adddot und \url nicht erkennt.

Ob das ein Problem ist, kommt darauf an, wer genau sagt, dass er die Befehle nicht kennt. Wenn Dein Editor die Befehle hervorhebt, weil er sie nicht kennt ist das noch kein Beinbruch. Der Editor weiß nämlich im Allgemeinen gar nicht genau, was TeX nachher mit den Befehlen macht, wo sie herkommen und wie sie definiert sind, er geht meist stumpf eine Liste mit ihm bekannten Befehlen ab und kann eventuell bestimmte Konstrukte in der Präambel nach Befehlsdefinitionen parsen. Wenn allerdings TeX beim Kompilieren eine Fehlermeldung a la undefined control sequence heraus posaunt, dann haben wir ein Problem. Das kann ich mir aber zumindest in dem Minimalbeispiel kaum vorstellen.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de