goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97626
Top-Poster: Johannes_B (5052)

Wir begrüßen unseren neuesten Benutzer timmetimtimme.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

LuaLaTeX, babel und Punctuationspace

 

Nescio_Nomen
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 01.03.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.03.2019, 09:14     Titel: LuaLaTeX, babel und Punctuationspace
  Antworten mit Zitat      
Das Paket babel mit der option german scheint den von mir mit fontspec (zur Anschauung überdimensioniert) gewählten Punctuationspace zu "unterdrücken".

Kommentiere ich die babel-Zeile, zeigt sich der Effekt von PunctuationSpace=10.0, ich verliere aber natürlich alle babel-Funktionen.
Entkommentiere ich die babel-Zeile, so verschwindet der gewählte Punctuationspace.

Kann das jemand reproduzieren?
Ich bin fontspec- und LuaLaTeX-Neuling. Was mache ich falsch?
LuaTeX, Version 1.07.0 (TeX Live 2018).

Minimalbeispiel:
Code • Öffne in Overleaf

\documentclass{article}
   
 \nonfrenchspacing
 \usepackage[german]{babel}  % entkommentiert -->  gewählter Punctuationspace "verschwindet";  
 \usepackage{fontspec}    
 \setmainfont[PunctuationSpace=10.0]{Latin Modern Roman}
 
\begin{document}
 Donau"=Dampfschiffahrts"=Kapitäns"=Patents"=Anwärter"=Prüfung ist
auffallend sinnlos und wertbeständig? Hallo! Ich bin ein kleiner Blindtext. Und zwar schon so lange ich denken kann. Es war nicht leicht zu verstehen, was es bedeutet, ein blinder Text zu sein: Man macht keinen Sinn. Wirklich keinen Sinn. Man wird z.\,B.\ zusammenhangslos eingeschoben und rumgedreht etc.
Invoking babel with option german seems to interfere with PunctuationSpace command?  
\end{document}
 


babelOn.png
 Beschreibung:

Download
 Dateiname:  babelOn.png
 Dateigröße:  116.72 KB
 Heruntergeladen:  68 mal
babelOff.png
 Beschreibung:

Download
 Dateiname:  babelOff.png
 Dateigröße:  123.48 KB
 Heruntergeladen:  62 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.03.2019, 10:14     Titel:
  Antworten mit Zitat      
babel schaltet bei der Umschaltung auf Deutsch automatisch auf \fenchspacing, weil es nun einmal eine Eigenschaft der Deutschen Typografie ist, keinen zusätzlichen Abstand nach Punkten etc. zu machen. Wenn du das ändern willst, – was normalerweise nicht zu empfehlen ist –, musst du \nonfrenchspacing nach der Aktivierung der Sprache ausführen. Das müsste man nach jeder Sprachumschaltung tun. Wenn es allgemein gelten soll, kann man das mit \let\bbl@frenchspacing\relax erreichen:
Code • Öffne in Overleaf
\documentclass{article}
   
\usepackage[german]{babel}
\usepackage{fontspec}
\makeatletter
\let\bbl@frenchspacing\relax
\makeatother
\setmainfont[PunctuationSpace=10.0]{Latin Modern Roman}
 
\begin{document}
Donau"=Dampfschiffahrts"=Kapitäns"=Patents"=Anwärter"=Prüfung ist
auffallend sinnlos und wertbeständig? Hallo! Ich bin ein kleiner Blindtext. Und zwar schon so lange ich denken kann. Es war nicht leicht zu verstehen, was es bedeutet, ein blinder Text zu sein: Man macht keinen Sinn. Wirklich keinen Sinn. Man wird z.\,B.\ zusammenhangslos eingeschoben und rumgedreht etc.
Invoking babel with option german seems to interfere with PunctuationSpace command?  
\end{document}

Nescio_Nomen
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 01.03.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.03.2019, 14:36     Titel:
  Antworten mit Zitat      
Danke für die prompte und hilfreiche Antwort! Der Code-Schnipsel hat mein Problem gelöst

[Ich wußte weder, daß frenchspacing in babel implementiert ist (peinlich!), noch daß es den Status einer deutschen ortho(typo)graphischen Regel hat.
Der Hintergrund für meine Frage war, daß ich in einem Dokument mit WordSpace die Wortzwischenräume leicht verringerte, was dazu führte, daß nun die Satzzwischenräume merklich enger als die Wortzwischenräume waren. Dem wollte ich mit PunctuationSpace gegensteuern. Das Problem ist fontspezifisch und mir noch unerklärlich.]
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de