goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 96186
Top-Poster: Johannes_B (5038)

Wir begrüßen unseren neuesten Benutzer Timres.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Seiten ober und Unterzeile nicht wie gewünscht

 

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 16
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 16:06     Titel: Seiten ober und Unterzeile nicht wie gewünscht
  Antworten mit Zitat      
Hallo zusammen,

ich hatte das Problem, dass mir geraten wurde von fancyhdr auf scrlayer-scrpage umzusteigen. Das habe ich gemacht und habe aber nun das Problem, dass die Kopf- und Fußzeile weder wirklich vorhanden war, noch die Seitennummerierung gepasst hat. Die Seitenzahl war immer nur auf den Seiten der \chapter, die dafür auch korrekt war, aber für alle folgenden nicht. (auch im Inhaltverzeichnis trotz \thispagestyle{empty})

Als ich dann ein minimalbeispiel vorbereitet habe, hat es mit der nummerierung funktioniert (warum auch immer) aber mit der Kopf und Fußzeile immer noch nicht. In diesem Fall würde ich mich erstmal auf ersteres Problem beschränken:

Mit dem minimalbeispiel habe ich zwar eine Kopfzeile, aber die ist für alle seiten "Inhaltsverzeichnis". Ich hätte gerne Oben und unten eine durchgehende Linie die die Zeilen trennt und jeweil in der Kopfzeile das große Kapitel und falls vorhanden das momentane Unterkapitel.
Wäre super wenn jemand dafür einen rat weiß!

Code • Öffne in Overleaf
%
\documentclass[a4paper,12pt,titlepage]{scrreprt}

\usepackage[ngerman]{babel}
\usepackage{setspace}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[backend=bibtex,style=authoryear,  autocite=inline]{biblatex}


\usepackage[automark]{scrlayer-scrpage}

\chead{\headmark}
\cfoot*{\pagemark}
\pagestyle{scrheadings}
\setlength{\parindent}{0pt}



\begin{document}

\newpage
\tableofcontents
\thispagestyle{empty}
\newpage
\pagenumbering{arabic}
\section{kapitel 1}
\newpage
\subsection{kapkapitel 1}
\newpage
\section{Kapitel 2}
\subsection{Stand der Technik}

\end{document}
%
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1526
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 04.02.2019, 16:15     Titel:
  Antworten mit Zitat      
Hast Du schon eine LaTeX-Einführung gelesen? Ich frage, weil Du \section-Befehle für Kapitel benutzt.

Lesetipp für \parindent
Private Nachricht senden Benutzer-Profile anzeigen

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 16
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 16:34     Titel:
  Antworten mit Zitat      
ja ich habe schon etwas Erfahrung in Latex. Ich habe das vielleicht etwas falsch beschrieben. Ich habe aus meiner Meta Datei verschiedene Kapitel mit \input{Kapitel...} eingefügt. Um das Beispiel überschaubar zu halten, habe ich die Chapter in diesem fall mit \sections ersetzt um es in einer Datei zu behalten.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 16:50     Titel:
  Antworten mit Zitat      
Es ging Bartman wohl darum, vorzuschlagen \chapter statt \section zu nehmen, da das \newpage vor dem \section so aussah als wolltest Du, dass die \sections auf einer neuen Seite anfangen. Ferner ist \chapter (wenn wir \part ignorieren) bei scrreprt/report die höchste Gliederungsebene, daher bekommst Du hier im Beispiel jetzt "Kapitelnummern" der Form "0.1", das ist auch ein bisschen fishy. Es ist mir nicht ganz klar, ob das einfach nur im Minimalbeispiel etwas falsch gelaufen ist, oder ob das auch in Deinem echten Dokument so aussieht.

Es ist übrigens sehr gut, für ein Minimalbeispiel solche Dinge wie \input loszuwerden, wenn es irgendwie möglich ist. Nur sollten dadurch keine Missverständnisse entstehen. Sieht denn das kompilierte Ergebnis des Beispiels so ähnlich aus wie Dein eigenes Dokument und ist die Code-Strutur ähnlich oder ist da etwas fundamental anders?

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 16:51     Titel:
  Antworten mit Zitat      
Auch, wenn man mit einer Datei arbeitet, sollte die oberste Ebene bei scrreprt \chapter sein. Anderenfalls passt das auch nicht zu Option automark. Außerdem sollte es nicht verwundern, dass \thispageststyle{empty} eine Seite ohne Kopf- und Fußzeile produziert. Das ist ja gerade der Sinn von Seitenstil empty. Und zu \setlength{\parindent}{0pt} solltest Du unbedingt https://komascript.de/faq_parindent lesen.

Optionen a4paper und titlepage sind übrigens bei scrreprt Voreinstellung und damit überflüssig.

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 16
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 17:06     Titel:
  Antworten mit Zitat      
okay, also vielleicht waren die Beispiele mit \section für scrreprt etwas doof, das wusste ich nicht. ich will eigentlich keine nummerierung bei dem Inhalteverzeichnis, deswegen steh da ja \thispagestyle{empty}. Mich wundert es eher, dass es in meinem großen Dokument trotzdem da ist. Das die Gliederung mit 0.1 ist, habe ich ehrlich gesagt auch nicht direkt verstanden aber das ist ja dann auch geklärt.

Das komische ist, dass das Dokument von meinem Minimalbeispiel ziemlich anders aussieht als mein normales und ich weiß auch nicht ganz warum.

Ich habe eigentlich eine präambel mit den ganzen sachen drin und in die ich mit \input 6 Kapitel eingefasst habe.
In den TeX Datein der Kapitel habe ich jeweils \chapter, \sections und subsections. Mein Inhaltsverzeichnis hat die nummer 1 was nicht sein sollte, und ab der 2 Seite meines Inhaltsverzeichnis ist es leer.
Mein erstes Kapitel \input{Kapitel/Einleitung} hat die Nummer 3 mein zweites Kapitel die nummer 5 und so weiter und alles was dazwischen liegt ist nicht nummeriert. Zusätzlich habe ich keine Kopf- und Fußzeile und das mit dem a4paper und titlepage wusste ich nicht, ferner wusste ich das mit dem \parindent nicht aber danke für die Info. habe es gelöscht und hat nichts verändert.

Ich weiß, dass das immer verwirrender und schwieriger wird mir zu helfen, ich weiß aber ehrlich gesagt auch nicht gerade wie ich es einfacher machen kann. Ich bin kein Profi in Latex, habe über 2 jahre immer nur Protokolle mit Overleaf geschrieben und muss jetzt meine Bachelorarbeit damit schreiben, was sich schon etwas mehr Unterscheidet von so einem kleinen Protokoll. Confused

Update:
Die Seitenzahlen zwischen den Kapiteln sind da aber Kursiv, die auf den Seiten der Kapitel nicht.
Kopfzeile ist auf den Seiten wo kein Chapter anfängt auch, hätte ich aber lieber durchgehend und mit Liniedie das trennt plus link- und rechtsbündig. Seitenzahl ist nicht auf der zweiten Seite des Inhaltsverzeichnis, aber auf der ersten schon (Einleitung fängt trotzdem mit 1 an). Ich habe \thispagestyle{empty} vor und nach \tableofcontents gepackt, hat aber nichts gebracht.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 17:34     Titel:
  Antworten mit Zitat      
InfoMinimalbeispiel

Ohne ein solches, das Dein Problem (und bitte immer nur eines je Frage auf einmal, dann kannst Du ggf. auch im passenden Forum fragen) wirklich zeigt, wird es schwer Dir zu helfen.

Ich beschränke mich daher auf ein Problem: \thispagestyle{empty} nach \tableofcontents ändert frühestens den Seitenstil der letzten Seite des Inhaltsverzeichnisses. Soll der Seitenstil der ersten Seite des Inhaltsverzeichnisses geändert werden, geht das am besten mit Hilfe von \AfterTOCHead. Ich bin fast sicher, dass es dafür sogar min. ein Beispiel im Forum gibt. Hier ein weiteres:
Code • Öffne in Overleaf
\documentclass{scrreprt}

\usepackage{blindtext}% siehe Minimalbeispiel-Anleitung
\pagestyle{headings}

\AfterTOCHead[toc]{%
  \thispagestyle{empty}% für die erste Seite
  \pagestyle{empty}% für alle weiteren Seiten des Inhaltsverzeichnisses
}
\AfterStartingTOC[toc]{%
  \thispagestyle{empty}% ruhig mal ohne probieren und die letzte Seite des
                       % Inhaltsverzeihnisses anschauen
}

\begin{document}
\tableofcontents
\blinddocument\blinddocument\blinddocument\blinddocument
\blinddocument\blinddocument\blinddocument\blinddocument
\blinddocument\blinddocument\blinddocument\blinddocument
\blinddocument\blinddocument\blinddocument\blinddocument
\end{document}

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 16
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.02.2019, 10:21     Titel:
  Antworten mit Zitat      
Das funktioniert auf jeden Fall danke!

Gemäß dem Titel, wollte ich mich auch auf das Problem mit der Ober- und Unterzeile beschränken. Ich kann dafür aber auch ein neues Thema auf machen dafür.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de