goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98860
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer LatexGast.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Zitierstil mit biblatex nicht wie gewünscht

 

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 28
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 12:54     Titel: Zitierstil mit biblatex nicht wie gewünscht
  Antworten mit Zitat      
Hallo zusammen,

für meine Bachelorarbeit benötige ich den folgenden zitierstil: blablablaatext (Schmidt 2004: 102). Ich weiß leider zu wenig über citierstile und habe bis jetzt auch noch nichts gefunden was auf meinen Zitierstil passt. ich benutze bibtex und mein bisheriger zitierstil ist: \citep[S.10]{AuthorJahr.} . Die Ausgabe ist: (Author, Jahr, S.10).

Ich arbeite mit Citavi und würe gerne dabei bleiben. die Seitenzahl habe ich bis jetzt manuell eingegeben.

hier meine packages:

Code • Öffne in Overleaf
%
\documentclass[a4paper,12pt,titlepage]{scrreprt}


%-------------------------------
%Packages

\usepackage[ngerman]{babel}
\usepackage{setspace}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{graphicx}
\usepackage{textcomp}
\graphicspath{{Bilder/}}
\usepackage{textgreek}   %girechische Buchstaben im Text ohne Mathmode
\usepackage{paralist}   %für Compactitem
\usepackage{fancyhdr}   %Ober, Unterzeile
\usepackage{color}
\usepackage{hyperref}   %Zitation glaube ich

\usepackage[backend=bibtex,style=authoryear,natbib=true]{biblatex}

\usepackage[left=2.5cm, right=2cm, bottom= 4cm]{geometry}

\usepackage[autostyle=true]{csquotes} % Required to generate language-dependent quotes in the bibliography

\bibliography{Literatur}
\begin{document}
.
.
.
\printbibliography
\appendix
\end{document}
%


wäre super wenn mir jemand helfen kann. :/
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 13:12     Titel:
  Antworten mit Zitat      
Wenn Du die natbib-Kompatibilitätsoption weglässt, dann verschwindet das ungewollte Komma zwischen Autor und Jahr von allein. Statt \citep würde ich \autocite empfehlen (oder von mir aus \parencite, wenn man \autocite nicht mag; die natbib-Namen würde ich vermeiden wollen).

Den Doppelpunkt bekommst Du, wenn Du \postnotedelim umdefinierst.

Das "S." bei der Seitenzahl solltest Du nicht selbst angeben, das macht biblatex automatisch für Dich oder lässt es wie hier eben weg.
Das "S." wird unterdrückt, indem postnote und verwandte Formate umdefiniert werden. Wenn Du wegen \mknormrange einen Fehler bekommst, nutzt Du noch eine veraltete biblatex-Version. Mach dann entweder ein Update oder schreib #1 statt \mknormrange{#1}.

Code • Öffne in Overleaf
\documentclass[a4paper,12pt,titlepage]{scrreprt}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[autostyle=true]{csquotes}
\usepackage[backend=bibtex, style=authoryear, autocite=inline]{biblatex}
\usepackage{hyperref}

\renewcommand*{\postnotedelim}{\addcolon\space}

\DeclareFieldFormat{postnote}{\mknormrange{#1}}
\DeclareFieldFormat{volcitepages}{\mknormrange{#1}}
\DeclareFieldFormat{multipostnote}{\mknormrange{#1}}


\addbibresource{biblatex-examples.bib}

\begin{document}
Lorem ipsum \autocite[380]{sigfridsson}.

Dolor sit amet \autocite[12-56]{nussbaum}.

\printbibliography
\end{document}


Ich empfehle wärmstens, von BibTeX zu Biber zu wechseln (also backend=biber und dann Biber statt BibTeX laufen lassen https://texwelt.de/wissen/fragen/19.....ch-biber-in-meinem-editor).

Ferner sollte hyperref eigentlich fast immer das letzte geladene Paket sein. fancyhdr und KOMA-Klassen sind auch keine sehr guten Freunde, nutze bei KOMA-Klassen lieber scrlayer-scrpage.

Für zukünftige Fragen sei angemerkt, dass es für Helferinnen und Helfer etwas angenehmer ist, wenn Du Deine Pakete und Einstellungen in einem InfoMinimalbeispiel zeigst (vergleiche Deinen Code mit meinem, insbesondere, wenn Du den Code in einem neuen, leeren Order laufen lässt). Viel hat hier nicht gefehlt und die Frage war auch mit dem gezeigten Code verständlich, aber ein Minimalbeispiel ist immer ein Zeichen des guten Willens und ermöglicht einen schnelleren Einstieg in die Fragestellung und Hilfe, es ist häufig essentiell, da wir so sichergehen, dass alle über dasselbe reden.

WolfLuca
Forum-Anfänger
Forum-Anfänger

Beiträge: 28
Anmeldedatum: 22.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 13:59     Titel:
  Antworten mit Zitat      
Wow. Ich bin immer wieder begeistert, wie schnell und gut die Antworten in diesem Forum sind.

Vielen Dank! das hat auf anhieb geklappt. Ich wollte eigentlich von Anfang an Biber benutzen. Ich benutze aber Texmaker (auch die neuste Version) und immer wenn ich das auf Biber umstelle kommt diese Fehlermeldung:


Process started

INFO - This is Biber 2.11 INFO - Logfile is '0BAmain.blg' INFO - Reading '0BAmain.bcf' ERROR - Error: Found biblatex control file version 3.5, expected version 3.4. This means that your biber (2.11) and biblatex (3.12) versions are incompatible. See compat matrix in biblatex or biber PDF documentation. INFO - ERRORS: 1

Process exited with error(s)


Ich habe dazu auch noch keine Lösung gefunden. Wahrscheinlich habe ich mich bis jetzt auch zu wenig damit befasst. Ich Ich will auch nicht unbedingt auf ein anderes TeX-Programm umsteigen, da ich schon mitten in meiner Arbeit stecke.

Und zu dem Minimalbeispiel: Sorry und das werde ich mir merken!
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.02.2019, 14:18     Titel:
  Antworten mit Zitat      
Die Meldung von Biber zeigt, dass Deine Version von biblatex und Biber nicht zusammenpassen. Ich würde darauf tippen, dass Du entweder MikTeX als Mehrbenutzersystem installiert hast und biblatex im Nutzer- und Biber im Admin-Baum liegt, in dem Fall sollte es helfen, MikTeX sowohl im Nutzer- als auch im Admin-Modus zu aktualisieren, oder dass biblatex ohne Update später als Biber installiert wurde, auch in dem Fall sollte ein beherztes Update helfen. Allerdings bringen Updates auch immer die Gefahr von Bugs und Inkompatibilitäten mit sich, wenn Du also ganz kurz vor Abgabe bist, solltest Du Dir das gut überlegen. Mit etwas Zeit in petto ist ein Update aber durchaus einen Versuch wert. Der Umstieg von BibTeX zu Biber selbst sollte eigentlich reibungslos gehen (nur an einigen Stellen ist Biber etwas strenger als BibTeX).

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de