goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98357
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer Loelle92.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Include bindet Kapitel nicht ein

 

Moritz_F
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 07.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.01.2019, 20:03     Titel: Include bindet Kapitel nicht ein
  Antworten mit Zitat      
Hallo,

folgendes Minimalbeispiel:

Code • Öffne in Overleaf

\documentclass[a4paper,11pt,numbers=noenddot,twoside]{scrreprt}  
% ========== Standard Packages ===================================================================================
  \usepackage[utf8]{inputenc}
  \usepackage[ngerman]{babel}
  \usepackage[T1]{fontenc}
  \usepackage{graphicx}
  \usepackage{subfigure}
  \graphicspath{{img/}}
  \usepackage{microtype}  

\begin{document}
\pagestyle{empty}
\include{03_abstrakt}
\include{Motivation}
\include{11_Kapitel 6}
\include{12_Ergebnisse}

\end{document}
 


Die Kapitel Motivation & 12_Ergebnisse werden mit \include richtig eingebunden.
Das Kapitel \include{11_Kapitel 6} wird überhaupt nicht angezeigt. Wieso ist das so?

Darf ich die "Kapitel" nicht als 11_Kapitel 6.tex speichern? Vielleicht wegen den Unterstrichen oder dem Wort "Kapitel" ?

Im Forum wurde genannt es mit \input{} einzufügen - möchte ich aber vermeiden.

Danke für Eure Hinweise Smile

Moritz
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2439
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 09.01.2019, 20:09     Titel:
  Antworten mit Zitat      
Verwende keine Leerzeichen in Dateinamen.
Private Nachricht senden Benutzer-Profile anzeigen

Moritz_F
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 07.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.01.2019, 20:54     Titel:
  Antworten mit Zitat      
Danke!
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1726
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 09.01.2019, 21:12     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
\begin{filecontents}{11_Kapitel_6.tex}
\blinddocument
\end{filecontents}

\documentclass[numbers=noenddot, twoside]{scrreprt}
%\usepackage[utf8]{inputenc} bei aktueller TeX-Distribution verzichtbar
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}% https://texwelt.de/wissen/fragen/5537
\usepackage{lmodern}% Alternativen unter http://www.tug.dk/FontCatalogue/
%\usepackage{graphicx}
%\usepackage{subfigure}% letzter Absatz des Textes unter https://www.ctan.org/pkg/subfigure
\usepackage{microtype}
\usepackage{blindtext}

%\graphicspath{{img/}}

\begin{document}
\include{11_Kapitel_6}
\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Meister
Forum-Meister

Beiträge: 717
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: Kubuntu 18.04 LTS + TeXLive 2018
     Beitrag Verfasst am: 10.01.2019, 08:21     Titel: Re: Include bindet Kapitel nicht ein
  Antworten mit Zitat      
Moritz_F hat Folgendes geschrieben:
Im Forum wurde genannt es mit \input{} einzufügen - möchte ich aber vermeiden.

Warum das? Das Einfügen via \input ist gleich dem direkten Einfügen der betreffenden Zeilen in das Hauptdokument. Was gibt es daran auszusetzen?
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2019, 08:39     Titel: Re: Include bindet Kapitel nicht ein
  Antworten mit Zitat      
markusv hat Folgendes geschrieben:
Moritz_F hat Folgendes geschrieben:
Im Forum wurde genannt es mit \input{} einzufügen - möchte ich aber vermeiden.

Warum das?

Ist eigentlich unerheblich. Auch mit \input machen Leerzeichen Probleme.

Das liegt daran, dass damals, als Knuth das TeX-Primitv \input entworfen hat, keine Leerzeichen in Dateinamen möglich waren und er es für eine gute Idee hielt, dass der Dateiname nicht als balanced text (also in geschweiften Klammern) verarbeitet wird, sondern einfach beim ersten Leerzeichen endet. Diese Vereinfachung hat sich keine zwanzig Jahre später gerächt. Allerdings befindet sich Knuth diesbezüglich in guter Gesellschaft. Leerzeichen bedürften auch zwanzig Jahre nach ihrer Einführung in Dateinamen noch einer besonderen Behandlung in vielen Programmiersprachen und führen immer mal wieder zu seltsamen Ergebnissen.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de