goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 95726
Top-Poster: Johannes_B (5030)

Wir begrüßen unseren neuesten Benutzer Dominik_MB.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Mehrere Indices

 

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.12.2018, 14:34     Titel:
  Antworten mit Zitat      
Soweit ich das sehen kann, macht der recht komplexe Code für die Indizierung in oscola.bbx die Annahme, dass Direktiven der EU-Kommission als @legislation und nicht als @report abgespeichert werden. Für die automatische Indexerkennung müsste EuropeanCommission.21.03.2018b also wie in oscola-examples.bib aussehen. Wenn Du bei @report bleiben möchtest, dann musst Du den Index im tabulate-Feld selbst angeben.

Code • Öffne in Overleaf
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[style=british]{csquotes}
\usepackage[backend=biber,style=oscola,ecli=yes,indexing=cite]{biblatex}
\addbibresource{\jobname.bib}

\usepackage[nonewpage]{imakeidx}

\makeindex[name=cases, title={CJEU Jurisprudence}, options=-s oscola, columns=1]
\makeindex[name=directives, title={EU directives}, options=-s oscola, columns=1]
 
\DeclareIndexAssociation{eucases}{cases}
\DeclareIndexAssociation{eudirs}{directives}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@jurisdiction{CJEU_34887_StichtingUitvoeringFinanciele,
  shorttitle  = {Stichting Uitvoering Financiële Acties
},
  pages       = {1737},
  pagination  = {page},
  number      = {348/87},
  ecli        = {ECLI:EU:C:1989:246},
  institution = {CJEU},
  date        = {1989},
  keywords    = {eu},
  title       = {Stichting Uitvoering Finaniële Acties v Staatssecretaris van Financiën},
  hyphenation = {dutch},
}
@legislation{EuropeanCommission.21.03.2018b,
  title      = {Proposal for a Council Directive laying down rules
                relating to the corporate taxation of a significant
                digital presence
},
  date       = {2018},
  origdate   = {2002-03-21},
  type       = {directive},
  number     = {COM(2018) 147 final},
  pagination = {article},
  keywords   = {eu},
}
@report{ECflobbel,
  title      = {Flobbel
},
  date       = {2012},
  origdate   = {2012-03-21},
  type       = {directive},
  number     = {COM(2012) 1},
  pagination = {article},
  tabulate   = {directives},
}
\end{filecontents}
   
\begin{document}
Netherlands \cite{CJEU_34887_StichtingUitvoeringFinanciele}

Lorem\footcite{EuropeanCommission.21.03.2018b}

ipsum\footcite{ECflobbel}

\printbibliography[nottype=jurisdiction]

\printindex[cases]
\printindex[directives]
\end{document}

framework2k10
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 05.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 10:20     Titel:
  Antworten mit Zitat      
Aha. Danke, sehr gute Antwort. Ne, dann werde ich das schon so machen, wie OSCOLA das will. Bin auch gerade erst am Anfang, muss also keine alten Einträge ändern.

Aber irgendwie will es immer noch nicht. Habe auch mal dein Beispiel bei mir reinkopiert. Da macht er gar keinen Index. Bei mir fügt er keinen zweiten hinzu. Irgendwie hat er ein Problem damit die .idx datei zu schreiben. woran kann das liegen? irgendwie klappt das makeindex nicht.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 11:07     Titel:
  Antworten mit Zitat      
Bei Verwendung von Option nonewpage führt imakeidx die Aufrufe von makeindex nicht selbst aus. Deshalb schreibt es auch in die log-Datei:
Zitat:
Package imakeidx Warning: Remember to run (pdf)latex again after calling
(imakeidx) `makeindex -s oscola cases.idx'.


Package imakeidx Warning: Remember to run (pdf)latex again after calling
(imakeidx) `makeindex -s oscola directives.idx'.

Wenn man die hier genannten Aufrufe von makeindex durchführt und wie hier erwähnt, erneut pdflatex laufen lässt (besser zweimal), dann funktioniert es.

Oder man lässt die Option weg, wenn das möglich ist.

framework2k10
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 05.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 11:12     Titel:
  Antworten mit Zitat      
ahhh. sehr gut, danke! hatte mit der option nonewpage was anderes assoziiert.
Private Nachricht senden Benutzer-Profile anzeigen

framework2k10
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 05.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 12:06     Titel:
  Antworten mit Zitat      
jetzt würde ich noch gerne eine separaten index für die tatsächlichen reports machen, da hab ich dann per tabulate denen einen extra key gegeben, aber das klappt nicht so recht. also so wie in deinem directive beispiel. makeindex nimmt das aber irgendwie nicht an, sagt dann für diesen index 0 entries accepted.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 13:03     Titel:
  Antworten mit Zitat      
Zeig uns doch bitte in einem Beispiel im Stile meines Beitrages vom 28.12.2018, 14:34 Uhr was Du probiert hast.

Bei mir funktioniert es mehr oder weniger so wie ich erwarten würde
Code • Öffne in Overleaf
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[english]{babel}
\usepackage[style=british]{csquotes}
\usepackage[backend=biber,style=oscola,ecli=yes,indexing=cite]{biblatex}
\addbibresource{\jobname.bib}

\usepackage[nonewpage]{imakeidx}

\makeindex[name=cases,      title={CJEU Jurisprudence}, options=-s oscola, columns=1]
\makeindex[name=directives, title={EU directives},      options=-s oscola, columns=1]
\makeindex[name=reports,    title={Reports I},            options=-s oscola, columns=1]
 
\DeclareIndexAssociation{eucases}{cases}
\DeclareIndexAssociation{eudirs}{directives}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@jurisdiction{CJEU_34887_StichtingUitvoeringFinanciele,
  shorttitle  = {Stichting Uitvoering Financiële Acties
},
  pages       = {1737},
  pagination  = {page},
  number      = {348/87},
  ecli        = {ECLI:EU:C:1989:246},
  institution = {CJEU},
  date        = {1989},
  keywords    = {eu},
  title       = {Stichting Uitvoering Finaniële Acties v Staatssecretaris van Financiën},
  hyphenation = {dutch},
}
@legislation{EuropeanCommission.21.03.2018b,
  title      = {Proposal for a Council Directive laying down rules
                relating to the corporate taxation of a significant
                digital presence
},
  date       = {2018},
  origdate   = {2002-03-21},
  type       = {directive},
  number     = {COM(2018) 147 final},
  pagination = {article},
  keywords   = {eu},
}
@report{elk,
  article    = {Anne Elk
},
  title      = {Echter Report},
  type       = {Real Reports},
  number     = {56},
  date       = {2012-03-21},
  tabulate   = {reports},
}
\end{filecontents}
   
\begin{document}
Netherlands \cite{CJEU_34887_StichtingUitvoeringFinanciele}

Lorem\footcite{EuropeanCommission.21.03.2018b}

ipsum\footcite{elk}

\printbibliography[nottype=jurisdiction]

\printindex[cases]
\printindex[directives]
\printindex[reports]

\printbibliography[type=report, title={Reports II}]
\end{document}

framework2k10
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 05.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 13:09     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf

\documentclass{article}


\usepackage[english]{babel} % Wörterbuch
\usepackage[utf8]{inputenc} % Umlaute I
\usepackage[T1]{fontenc} % Umlaute II


\usepackage[backend=biber,style=oscola,ecli=yes,indexing=cite]{biblatex}
\addbibresource{\jobname.bib}
\usepackage[style=british]{csquotes}


\usepackage{imakeidx}



\makeindex[name=cases, title={CJEU Jurisprudence}, options=-s oscola, columns=1]
\makeindex[name=directives, title={EU directives}, options=-s oscola, columns=1]
\makeindex[name=reports, title={Reports}, options=-s oscola, columns=1]
 
\DeclareIndexAssociation{eucases}{cases}
\DeclareIndexAssociation{eudirs}{directives}
\DeclareIndexAssociation{testeintrag}{reports}



\begin{filecontents}{\jobname.bib}
@report{OECDG20.2015,
   author = {OECD/G20
},
   date = {2015},
   title = {Addressing the Tax Challenges of the Digital Economy, Action 1 - 2015 Final Report: OECD/G20 Base Erosion and Profit Shifting Project},
   url = {http://dx.doi.org/10.1787/9789264241046-en},
   address = {Paris},
   editor = {{OECD Publishing}},
   urldate = {2018-12-19},
   tabulate = {testeintrag}
}

@legislation{EuropeanCommission.21.03.2018b,
   title = {Proposal for a
      Council Directive
      laying down rules relating to the corporate taxation of a significant digital presence
   
},
   date = {2018},
   origdate = {2002-03-21},
   type = {directive},
   number = {COM(2018) 147 final},
   pagination = {article},
   keywords = {eu},
   type = {directive}
}
@jurisdiction{CJEU_4109_CommissionvNetherlands,
   shorttitle = {Commission v Netherlands
},
   pages = {831},
   pagination = {page},
   number = {41/09},
   ecli = {ECLI:EU:C:2011:108},
   institution = {CJEU},
   date = {2011},
   keywords = {eu},
   title = {European Commission v Kingdom of the Netherlands},
   hyphenation = {Dutch}
}
\end{filecontents}
   
\begin{document}


CJEU Urteil\footcite{CJEU_4109_CommissionvNetherlands}

EU Dir \footcite{EuropeanCommission.21.03.2018}

Report\footcite{OECDG20.2015}





\printbibliography[nottype=jurisdiction, nottype=legislation]

\printindex[cases]
\printindex[directives]
\printindex[reports]


\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 13:40     Titel:
  Antworten mit Zitat      
Für selbst gebastelte Index-Typen ist \DeclareIndexAssociation nicht anwendbar. Das Beispiel funktioniert, wenn Du nicht den Umweg über tabulate = {testeintrag} und \DeclareIndexAssociation{testeintrag}{reports} gehst, sondern wie vorgeschlagen einfach gleich tabulate = {reports}, schreibst.

Code • Öffne in Overleaf
\documentclass[british]{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{babel}
\usepackage{csquotes}

\usepackage[backend=biber, style=oscola, ecli=yes, indexing=cite]{biblatex}

\usepackage{imakeidx}
\makeindex[name=cases,      title={CJEU Jurisprudence}, options=-s oscola, columns=1]
\makeindex[name=directives, title={EU directives},      options=-s oscola, columns=1]
\makeindex[name=reports,    title={Reports},            options=-s oscola, columns=1]
 
\DeclareIndexAssociation{eucases}{cases}
\DeclareIndexAssociation{eudirs}{directives}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@report{OECDG20.2015,
  author   = {OECD/G20
},
  date     = {2015},
  title    = {Addressing the Tax Challenges of the Digital Economy,
              Action 1 - 2015 Final Report:
              OECD/G20 Base Erosion and Profit Shifting Project
},
  doi      = {10.1787/9789264241046-en},
  address  = {Paris},
  editor   = {{OECD Publishing}},
  urldate  = {2018-12-19},
  tabulate = {reports},
}
@legislation{EuropeanCommission.21.03.2018b,
  title      = {Proposal for a Council Directive laying down rules
                relating to the corporate taxation of a
                significant digital presence
},
  date       = {2018},
  origdate   = {2002-03-21},
  type       = {directive},
  number     = {COM(2018) 147 final},
  pagination = {article},
  keywords   = {eu},
  type       = {directive}
}
@jurisdiction{CJEU_4109_CommissionvNetherlands,
  shorttitle  = {Commission v Netherlands
},
  pages       = {831},
  pagination  = {page},
  number      = {41/09},
  ecli        = {ECLI:EU:C:2011:108},
  institution = {CJEU},
  date        = {2011},
  keywords    = {eu},
  title       = {European Commission v Kingdom of the Netherlands},
  hyphenation = {dutch}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
CJEU Urteil\footcite{CJEU_4109_CommissionvNetherlands}

EU Dir\footcite{EuropeanCommission.21.03.2018b}

Report\footcite{OECDG20.2015}

\printbibliography[nottype=jurisdiction, nottype=legislation]

\printindex[cases]
\printindex[directives]
\printindex[reports]
\end{document}


Soweit ich es verstanden habe ist \DeclareIndexAssociation nur nötig, um die bereits voreingestellten (Pseudo-)Indextypen in echte Indices umzuleiten.

editor = {{OECD Publishing}}, scheint mir etwas merkwürdig, da wäre statt editor (Herausgeber) eventuell publisher (Verlag) passender. Wobei zu bedenken ist, dass der publisher normalerweise bei einem @report nicht gezeigt wird, stattdessen ist institution das Feld der Wahl (biblatex-oscola macht da eine Ausnahme und erlaubt auch pusblisher). Der einfache - als Gedankenstrich siehr übrigens fast immer etwas verloren aus, ein Halbgeviert- (--) oder Geviertstrich (---) sind da oft die bessere Wahl. date = {2018}, origdate = {2002-03-21}, scheint mir auch etwas merkwürdig, da die beiden Daten doch recht weit auseinander liegen.

Ich möchte Dich bitten, Deine Beispiele in Zukunft in einem leeren Order zu testen und vermeidbare Warnungen und Fehler zu beheben. So schreibst Du oben \footcite{EuropeanCommission.21.03.2018} gibst in der .bib-Datei aber nur EuropeanCommission.21.03.2018b mit. Natürlich kann man zumindest diesen Fehler recht schnell beheben und er hatte hier auch keinen großen Einfluss auf das Verständnis, aber immer wenn ein InfoMinimalbeispiel Fehler dieser Art enthält, beschleicht mich der Verdacht, dass das Beispiel nicht getestet wurde. Dann wird es problematisch, da dann gar nicht garantiert ist, dass das Beispiel das relevante Problem überhaupt zeigt. Im schlimmsten Fall reden wir dann stundenlang aneinander vorbei.

framework2k10
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 05.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.12.2018, 13:47     Titel:
  Antworten mit Zitat      
sehr gut, danke!

ja das datum ist ein tippfehler. ich bin parallel noch dabei citavi beizubringen, wie es mir die richtigen .bib dateien exportiert, da trag ich manchmal noch manuell was ein und dann kommt eben so ein datumsfehler raus
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite Zurück  1, 2



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de