goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98394
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer MrPaulus123.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

ebd. in Fußnote innerhalb einer Minipage

 

MistyMorning
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 22.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.12.2018, 18:33     Titel: ebd. in Fußnote innerhalb einer Minipage
  Antworten mit Zitat      
Hallo,

ich verwende für Definitionen eine Minipage. Zitiere ich innerhalb der Minipage erscheint die Fußnote am Ende dieser Minipage.
Wird vor der Minipage die gleiche Quelle zitiert, erscheint in der Fußnote der Minipage ebd. Das ist zum Teil sehr verwirrend, weil der Leser nicht genau weiß, wo ebd. ist, zumal die Minipage mit Kleinbuchstaben und die Hauptseite mit Nummern zitiert.
Im Folgenden mein Minimalbeispiel:
Code • Öffne in Overleaf

\documentclass[a4paper, 12pt]{scrreprt}
\usepackage[left=4cm, right=2cm, top=2cm, bottom=2cm]{geometry} %Seitenränder
\usepackage{setspace} %Zeilenabstand
\onehalfspacing %Zeilenabstand
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel} %Spracheinstellung: neue dt. Rechtschreibung
\usepackage[backend=biber,style=authortitle-ibid,autocite=footnote,labeldateparts=true,uniquename=full,uniquelist=true,ibidtracker=constrict,sorting=nty]{biblatex} %Literaturverzeichnis, reading
\usepackage[babel,german=guillemets]{csquotes} %Literaturverzeichnis
\addbibresource{lit.bib} %Literaturverzeichnis
\usepackage{chngcntr} %durchgehende Nummerierung der Fußnoten
\usepackage{graphicx} %Grafik
\usepackage[framemethod=tikz]{mdframed} %Definitionen


% Theorem
\mdtheorem[linecolor=darkgray,
frametitlefont=\sffamily\bfseries\color{white},
frametitlebackgroundcolor=darkgray
]{Definition}{Definition}[section]

\begin{document}
\subsection{Ultricies}
Lorem ipsum dolor sit amet, consectetuer adipiscing elit. Aenean commodo ligula eget dolor. Aenean massa. Cum sociis natoque penatibus et magnis dis parturient montes, nascetur ridiculus mus. Donec quam felis, ultricies nec, pellentesque eu, pretium quis, sem. Nulla consequat massa quis enim. Donec pede justo, fringilla vel, aliquet nec, vulputate eget, arcu. In enim justo, rhoncus ut, imperdiet a, venenatis vitae, justo. \autocite[vgl.][S. 1f]{dago2014} Nullam dictum felis eu pede mollis pretium. Integer tincidunt. Cras dapibus. Vivamus elementum semper nisi. Aenean vulputate eleifend tellus. Aenean leo ligula, porttitor eu, consequat vitae, eleifend ac, enim. \autocite[vgl.][]{don2006} Aliquam lorem ante, dapibus in, viverra quis, feugiat a, tellus. Phasellus viverra nulla ut metus varius laoreet. Quisque rutrum. Aenean imperdiet. \autocite[vgl.][S. 2]{dago2014}
\begin{Definition}
{\large\textbf{Ultricies}} \vspace{0.25cm} \\
Etiam ultricies nisi vel augue. Curabitur ullamcorper ultricies nisi. Nam eget dui. Etiam rhoncus. Maecenas tempus, tellus eget condimentum rhoncus, sem quam semper libero, sit amet adipiscing sem neque sed ipsum. \autocite[vgl.][S. 4]{dago2014} \\
Donec vitae sapien ut libero venenatis faucibus. Nullam quis ante. Etiam sit amet orci eget eros faucibus tincidunt. Duis leo. \autocite[vgl.][S. 14]{mik2018}
\vspace{0.25cm}
\end{Definition}
Sed fringilla mauris sit amet nibh. Donec sodales sagittis magna. Sed consequat, leo eget bibendum sodales, augue velit cursus nunc, quis gravida magna mi a libero. Fusce vulputate eleifend sapien. Vestibulum purus quam, scelerisque ut, mollis sed, nonummy id, metus. Nullam accumsan lorem in dui. \autocite[vgl.][]{mik2018} Cras ultricies mi eu turpis hendrerit fringilla. Vestibulum ante ipsum primis in faucibus orci luctus et ultrices posuere cubilia Curae; In ac dui quis mi consectetuer lacinia. Nam pretium turpis et arcu. \autocite[vgl.][]{gus2017}
\end{document}
 


Wie kann ich erreichen, dass die Zitation in der Minipage ganz für sich allein gesehen wird? Also, ohne, dass Bezug auf die Hauptseite genommen wird?

Danke für Eure Hilfe!

lit.bib
 Beschreibung:

Download
 Dateiname:  lit.bib
 Dateigröße:  516 Bytes
 Heruntergeladen:  106 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.12.2018, 20:48     Titel:
  Antworten mit Zitat      
Sehr schöne Frage. Es stellt sich heraus, dass die Antwort auf die Frage im Titel mit der minipage eine andere ist als die Antwort auf das analoge Problem für mdframed.

Das grundsätzliche Problem kann dadurch gelöst werden, dass zu Beginn der minipage/mdframed-Box \citereset ausgeführt wird. Mit dem Hook \@minipagerestore kann das für minipages automatisch geschehen, bei mdframed kann man die Option startinnercode verwenden, ich habe da auf die Schnelle in der Dokumentation keinen allgemeineren Hook gefunden.

Code • Öffne in Overleaf
\documentclass[a4paper, 12pt]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[backend=biber, style=authortitle-ibid, autocite=footnote, labeldateparts=true, uniquename=full, uniquelist=true, ibidtracker=constrict, sorting=nty]{biblatex}
\usepackage[babel,german=guillemets]{csquotes}
\addbibresource{biblatex-examples.bib}
\usepackage[framemethod=tikz]{mdframed}


\mdtheorem[linecolor=darkgray,
frametitlefont=\sffamily\bfseries\color{white},
frametitlebackgroundcolor=darkgray,
startinnercode={\citereset},
]{Definition}{Definition}[section]

% für minipage
\makeatletter
\appto\@minipagerestore{\citereset}
\makeatother

\begin{document}
Lorem\autocite[vgl.][1\psq]{sigfridsson} ipsum \autocite[vgl.][]{worman} dolor \autocite[vgl.][2]{sigfridsson}
\begin{Definition}
Lorem \autocite[vgl.][4]{sigfridsson} Ipsum \autocite[vgl.][14]{geer}
\end{Definition}
Dolor \autocite[vgl.][]{geer}.

Lorem\autocite[vgl.
][1\psq]{sigfridsson} ipsum \autocite[vgl.][]{worman} dolor \autocite[vgl.][2]{sigfridsson}

\noindent
\begin{minipage}{\textwidth}
Lorem \autocite[vgl.][4]{sigfridsson} Ipsum \autocite[vgl.][14]{geer}
\end{minipage}

Dolor \autocite[vgl.][]{geer}.
\begin{Definition}
Lorem \autocite[vgl.
][4]{sigfridsson} Ipsum \autocite[vgl.][14]{geer}
\end{Definition}
Amet \autocite[vgl.][]{geer}.
\end{document}


Man beachte, dass biblatex wie hier gezeigt das "S." vor der Seitenzahl selbst eingeben kann, daher kann es weggelassen werden. Statt f schreibt man dann \psq für ff \psqq.

MistyMorning
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 22.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.12.2018, 17:01     Titel:
  Antworten mit Zitat      
Erst einmal vielen Dank für die schnelle Antwort. Das mit dem "S." vor der Seitenzahl werde ich beherzen.

In meinen Versuchen hat es auch alles geklappt.


Danke für die Hilfe!!!
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1730
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 10.12.2018, 17:23     Titel:
  Antworten mit Zitat      
Wenn der Inhalt Deiner Definition-Umgebung wirklich so in Deiner TeX-Datei steht, dann möchte ich eine Änderung empfehlen:

Code • Öffne in Overleaf
\begin{Definition}
{\large\textbf{Ultricies}\par}% https://texwelt.de/wissen/fragen/1852
\vspace{0.25cm}
\noindent Etiam ultricies nisi vel augue. Curabitur ullamcorper ultricies nisi. Nam eget dui. Etiam rhoncus. Maecenas tempus, tellus eget condimentum rhoncus, sem quam semper libero, sit amet adipiscing sem neque sed ipsum. \autocite[vgl.][4]{dago2014} \\
Donec vitae sapien ut libero venenatis faucibus. Nullam quis ante. Etiam sit amet orci eget eros faucibus tincidunt. Duis leo. \autocite[vgl.][14]{mik2018}
\vspace{0.25cm}
\end{Definition}
Private Nachricht senden Benutzer-Profile anzeigen

MistyMorning
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 22.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.12.2018, 17:53     Titel:
  Antworten mit Zitat      
OK, was genau bewirkt das? Ich habe es ausprobiert, es bringt jedoch keine Änderung (oder ich habe sie übersehen).

Was mich allerdings noch ein wenig stört ist, dass die Minipages geteilt werden, wenn sie sich am Seitenende befinden. Zuerst dachte ich, dass Deine Lösung das vielleicht verhindert.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de