goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 95729
Top-Poster: Johannes_B (5030)

Wir begrüßen unseren neuesten Benutzer Librr.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Inproceeding funktioniert nicht

 

ClaudiaS
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 26.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 12:11     Titel: Inproceeding funktioniert nicht
  Antworten mit Zitat      
Hallo zusammen,

zur Zeit arbeite ich an einem Exposé und habe schon ein paar Erfahrungen mit Latex und JabRef gemacht. Allerdings verstehe ich nicht, warum ich bei meiner jetzigen Arbeit die folgende Fehlermeldung bekomme:

"! Package inputenc Error: Keyboard character used is undefined(inputenc) in inputencoding `utf8'.See the inputenc package documentation for explanation.Type H <return> for immediate help.... ...ibliography[title={Literaturverzeichnis}]"

Nach stundenlanger Fehlersuche habe ich herausgefunden, was ich in JabRef ändern muss, damit die Fehlermeldung nicht mehr auftaucht. Allerdings bin ich mit der Lösung nicht zufrieden. Hier mal ein Minimalbeispiel (ich hoffe, ich mache es richtig):



Code • Öffne in Overleaf
@InProceedings{herget2016musikinduziert,
  author    = {Herget, Ann-Kathrin
},
  title     = {Musikinduzierte Assoziationen. Wirkungen von Hintergrundmusik auf Emotionalisierung und Wahrnehmung von Filmhandlung sowie Protagonisten},
  year      = {2016},
  location  = {Wien, Austria},
  booktitle = {Tagungsband der Jahrestagung der Deutschen Gesellschaft für Musikpsychologie 2016},
  groups    = {audio mixing},
  pages     = {38--39},
}



Mit diesem Eintrag bekomme ich die Fehlermeldung. Ändere ich "InProceeding" zu "Proceeding" wird zwar der Eintrag zwar im Literaturverzeichnis angezeigt aber ohne Autor und dem Proceeding-Band. Mache ich aus "InProceeding" "Iproceeding" funktionierts komischerweise, aber auch da wird der Proceeding-Band nicht angezeigt. Auch der Eintrag "journal ={...}" hilft da nicht weiter.

In dem Exposé verwende ich auch eine schon häufiger zitierte Quelle, bei der es auch hier ohne Probleme klappt:

Code • Öffne in Overleaf
@InProceedings{fastl2013basics,
  author    = {Fastl, Hugo
},
  title     = {Basics and applications of psychoacoustics},
  booktitle = {Proceedings of Meetings on Acoustics at ICA 2013, Montr\'{e}al},
  year      = {2013},
  pages     = {1 -- 23},
  abstract  = {The field of psychoacoustics studies relations between acoustic stimuli, defined in the physical domain, and the hearing sensations elicited by these stimuli. The lecture will address questions of stimulus generation and presentation. Both traditional methods and more recent methods like wave field synthesis will be touched. Concerning hearing sensations, basic magnitudes as for example absolute thresholds or loudness, but also advanced topics like pitch strength will be covered. Applications of psychoacoustics will include rather different fields such as music, noise evaluation or audiology, and address also cognitive effects as well as audio-visual interactions.},
  groups    = {psychoacoustics},
}



Versteht jemand, woran es liegt?

hier dazu noch mein Quelltext aus Texmaker:

Code • Öffne in Overleaf
\documentclass[12pt, oneside]{article}
\usepackage{pdfpages}     % http://tug.ctan.org/tex-archive/mac.....rib/pdfpages/pdfpages.pdf

\usepackage{selectp}
\usepackage{amsmath}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel} % Deutsche Sprache

\usepackage{geometry}
\usepackage{setspace}
\usepackage{fancyhdr} % Package für die Kopf- und Fußzeile
\fancyhead[R]{\leftmark}

\usepackage{caption}% oder capt-of, oder ohne die Zeile mit KOMA-Script-Klasse
\usepackage{color}
\usepackage{graphicx}
\usepackage{enumitem}
\usepackage{longtable}
%\setlist[itemize]{nosep,after=\vskip-\baselineskip,label={\textbullet},leftmargin=*,before=\minipagetrue,}
\usepackage{float}
\usepackage[backend=bibtex,style=numeric,citestyle=numeric,maxbibnames=99,pagetracker=false, url=false, block=space]{biblatex}
\bibliography{Bibdatabase}
\usepackage{csquotes}

\begin{document}

Text Text Text \autocite{fastl2013basics}
Text Text Text \autocite{herget2016musikinduziert}

\label{References}
\printbibliography[title={Literaturverzeichnis}]
\end{document}


Es wäre super, wenn mir jemand weiterhelfen kann!
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 12:31     Titel:
  Antworten mit Zitat      
Bei mir reproduziert der gezeigte Code die erwähnte Fehlermeldung nicht. Die Ausgabe sieht auch in Ordnung aus.

Etwas kompakter
Code • Öffne in Overleaf
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}

\usepackage[backend=bibtex,style=numeric,citestyle=numeric,maxbibnames=99,pagetracker=false, url=false, block=space]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@InProceedings{herget2016musikinduziert,
  author    = {Herget, Ann-Kathrin
},
  title     = {Musikinduzierte Assoziationen. Wirkungen von Hintergrundmusik auf Emotionalisierung und Wahrnehmung von Filmhandlung sowie Protagonisten},
  year      = {2016},
  location  = {Wien, Austria},
  booktitle = {Tagungsband der Jahrestagung der Deutschen Gesellschaft für Musikpsychologie 2016},
  groups    = {audio mixing},
  pages     = {38--39},
}
@InProceedings{fastl2013basics,
  author    = {Fastl, Hugo
},
  title     = {Basics and applications of psychoacoustics},
  booktitle = {Proceedings of Meetings on Acoustics at ICA 2013, Montr\'{e}al},
  year      = {2013},
  pages     = {1 -- 23},
  abstract  = {The field of psychoacoustics studies relations between acoustic stimuli, defined in the physical domain, and the hearing sensations elicited by these stimuli. The lecture will address questions of stimulus generation and presentation. Both traditional methods and more recent methods like wave field synthesis will be touched. Concerning hearing sensations, basic magnitudes as for example absolute thresholds or loudness, but also advanced topics like pitch strength will be covered. Applications of psychoacoustics will include rather different fields such as music, noise evaluation or audiology, and address also cognitive effects as well as audio-visual interactions.},
  groups    = {psychoacoustics},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Text Text Text \autocite{fastl2013basics}
Text Text Text \autocite{herget2016musikinduziert}

\label{References}
\printbibliography[title={Literaturverzeichnis}]
\end{document}


Die erwähnte Fehlermeldung tritt normalerweise auf, wenn nicht-ASCII-Zeichen genutzt werden, die bei TeX nicht angemeldet worden sind. Soweit ich das sehen kann, enthält herget2016musikinduziert aber kein problematisches Zeichen. Das Umstellen von @inproceedings zu @proceedings (oder noch schlimmer dem unbekannten Typen @inproceeding) könnte das Problem nur scheinbar lösen, wenn dadurch bestimmte Felder nicht mehr angezeigt werden. In Frage kommt da vor allem booktitle.

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1500
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 26.11.2018, 14:28     Titel:
  Antworten mit Zitat      
@ClaudiaS

Du brauchst die biblatex-Optionen style, citestyle und pagetracker in Deinem Fall nicht.

Dürfen wir erfahren, warum Du die Voreinstellung Biber durch BibTeX ersetzt hast?
Private Nachricht senden Benutzer-Profile anzeigen

ClaudiaS
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 26.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 16:07     Titel:
  Antworten mit Zitat      
Danke für eure Antworten! Smile

@Gast: Ok, schonmal gut zu wissen, dass es bei dir ganz normal funktioniert. Wenn ich bei "booktitle" "Test" eingebe wird der Eintrag auch ganz normal im Literaturverzeichnis angezeigt.

@Bartman: Das weiß ich gar nicht mehr genau. Ich habe das tex.-file von einer älteren Arbeit als Vorlage verwendet und die Einstellung so übernommen, weil sie gut passte. Ich glaube, dass ich damals besser mit BibTex zurecht kam.
Private Nachricht senden Benutzer-Profile anzeigen

ClaudiaS
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 26.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 16:16     Titel:
  Antworten mit Zitat      
Update: Ich habe den das "Problemzeichen" gefunden. Das "ü" musste ich noch als
Code • Öffne in Overleaf
\"u
kodieren. Rolling Eyes
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 16:26     Titel:
  Antworten mit Zitat      
Das sollte nicht nötig sein, wenn Du wie von Bartman subtil vorschlagen Biber verwendest und die .tex- und .bib-Datei in derselben Codierung (bei Dir UTF-8) speicherst.

Code • Öffne in Overleaf
\documentclass{article}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{csquotes}

\usepackage[backend=biber,style=numeric, maxbibnames=99, url=false, block=space]{biblatex}
\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@InProceedings{herget2016musikinduziert,
  author    = {Herget, Ann-Kathrin
},
  title     = {Musikinduzierte Assoziationen. Wirkungen von Hintergrundmusik auf Emotionalisierung und Wahrnehmung von Filmhandlung sowie Protagonisten},
  year      = {2016},
  location  = {Wien, Austria},
  booktitle = {Tagungsband der Jahrestagung der Deutschen Gesellschaft für Musikpsychologie 2016},
  groups    = {audio mixing},
  pages     = {38--39},
}
@InProceedings{fastl2013basics,
  author    = {Fastl, Hugo
},
  title     = {Basics and applications of psychoacoustics},
  booktitle = {Proceedings of Meetings on Acoustics at ICA 2013, Montr\'{e}al},
  year      = {2013},
  pages     = {1 -- 23},
  abstract  = {The field of psychoacoustics studies relations between acoustic stimuli, defined in the physical domain, and the hearing sensations elicited by these stimuli. The lecture will address questions of stimulus generation and presentation. Both traditional methods and more recent methods like wave field synthesis will be touched. Concerning hearing sensations, basic magnitudes as for example absolute thresholds or loudness, but also advanced topics like pitch strength will be covered. Applications of psychoacoustics will include rather different fields such as music, noise evaluation or audiology, and address also cognitive effects as well as audio-visual interactions.},
  groups    = {psychoacoustics},
}
\end{filecontents}

\addbibresource{\jobname.bib}

\begin{document}

Text Text Text \autocite{fastl2013basics}
Text Text Text \autocite{herget2016musikinduziert}

\label{References}
\printbibliography[title={Literaturverzeichnis}]
\end{document}


Selbst mit BibTeX sollte hier das "ü"eigentlich funktionieren, wenn .tex- und .bib-Datei wie angemeldet in UTF-8 codiert sind. Die Sortierung bekommt dann natürlich nur Biber vernünftig hin. Der Umstieg zu Biber sollte heutzutage eigentlich auch kein Problem mehr sein: Du musst nur backend=biber statt backend=bibtex schreiben und dann Biber statt BibTeX aufrufen bzw. das Deinem Editor erklären: https://tex.stackexchange.com/q/154751/35864 Dann sollte eigentlich alles funktionieren. Wenn irgendetwas nicht geht: Alle temporären Dateien (.aux, .bbl, .bcf, ...) löschen und nochmal probieren. Wenn es dann immer noch nicht geht, einmal die TeX-Distribution updaten (bei MikTeX im Admin- und User-Modus, wenn es beide gibt), dann sollte es gehen.

ClaudiaS
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 26.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.11.2018, 18:56     Titel:
  Antworten mit Zitat      
Cool, alles klar, danke für den Hinweis. Smile
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de