Geometry Definition der Seitenränder passt nicht

Layout von Seiten, Rändern, Fusszeilen, usw, modifizieren
elloro
Forum-Anfänger
Forum-Anfänger
Beiträge: 10
Registriert: Mi 22. Jul 2015, 09:35

Geometry Definition der Seitenränder passt nicht

Beitrag von elloro »

Hallo zusammen,
ich habe ein Problem mit dem Layout der Seite ob es an den Seitenrändern liegt oder doch eher mit den minipages kann ich nicht genau verifizieren.
Das Problem ist folgendes, es wird eine Latex Vorlage für Herma Etiketten No. 9010 benötigt. Also habe ich mir gedacht das ganze über Miniages zu lösen. Die Documentclass ist report und die Seitenränder habe ich mit geometry auf left=2.5cm, right=0.5cm, top=2.9cm, bottom=0.9cm,. Die Werte Left (2,5cm) und Top(2,9cm) habe ich von dem DIN A4 Etikettenbogen gemessen. Das Etikett selber ist 7,5cm breit und 4cm hoch, Zwischen den Etiketten gibt es einen Abstand von 1cm.
Ich habe nun eine Minipage mit den Maßen des Etikettes erstellt als newcommand.
Allerdings stimmen die Seitenränder nicht, die sind jeweils um 0,4cm zu groß. Gemessen an dem Ausdruck der erzeugten PDF Daten

Wenn mir jemand sagen kann was ich da falsch mache, ich sehe da aktuell meine Fehler nicht.

Das ist meine tex-Daten

Code: Alles auswählen

\documentclass[11pt, a4paper]{report}

\usepackage[T1]{fontenc}
\usepackage[left=2.5cm, right=2.5cm,top=2.9cm,bottom=0.9cm, ]{geometry}



\newcommand{\boxheight}{4cm}
\newcommand{\boxwidth}{7.5cm}


\newcommand{\cell}[2]{%
\fbox{%
	\begin{minipage}[c][\boxheight]{\boxwidth}
		{#1}{#2}
	\end{minipage}
}
}

\newcommand{\bridge}{%
\fbox{
	\begin{minipage}[c]{1cm}
	\end{minipage}
}
}

\begin{document}
\pagestyle{empty}%
\noindent%
%\fbox{\begin{minipage}[24cm]{16cm}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
	\cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
%\end{minipage}}
\end{document}
Vielen Dank für die Hilfe schon mal im voraus

Rolli
Forum-Guru
Forum-Guru
Beiträge: 345
Registriert: Mi 15. Feb 2017, 08:50
Wohnort: Mittelfranken

Beitrag von Rolli »

Hallo elloro,

Die fbox hat standardmäßig Ränder zwischen Boxbegrenzung und Text eingebaut, ich glaube,es sind 6pt. Wenn Du die nicht willst:

Code: Alles auswählen

\setlength{\fboxsep}{0mm}
Gruß vom Rolli

elloro
Forum-Anfänger
Forum-Anfänger
Beiträge: 10
Registriert: Mi 22. Jul 2015, 09:35

Beitrag von elloro »

Hi Rolli,
das hatte ich nicht gemeint. Die erste Box sollte mit Ihrer linken oberen Ecke eigentlich vom linken Seitenrand 2.5cm weg sein ist aber 3,0cm entfernt von oberen Seitenrand eigentlich 2.9cm ist aber 3.3cm entfernt.

Ich habe mal ein Bild mit angefügt, das zeigt es vielleicht besser was mein Problem ist. :o
Dateianhänge
Unbenannt.png
Unbenannt.png (26.41 KiB) 536 mal betrachtet

Rolli
Forum-Guru
Forum-Guru
Beiträge: 345
Registriert: Mi 15. Feb 2017, 08:50
Wohnort: Mittelfranken

Beitrag von Rolli »

Ich vermute: Dein oberer Rand kommt vom fehlenden "ignoreheadfoot" und der rechte Rand von der Einrückung.
Ich habe die Dokumentenklasse auf KOMA mit Option parskip=half geändert, und Dir einen absolut positionierte Textblock mit xxx yyy zzz eingebaut.

Gruß vom Rolli

Code: Alles auswählen

\documentclass[11pt, a4paper, parskip=half]{scrreprt}

\usepackage[T1]{fontenc}
\usepackage[left=2.5cm, right=2.5cm,top=2.9cm,bottom=0.9cm, ignoreall, bindingoffset=0mm]{geometry}
\usepackage{showframe}
\usepackage[absolute,showboxes]{textpos}

\newcommand{\boxheight}{4cm}
\newcommand{\boxwidth}{7.5cm}

\newcommand{\cell}[2]{%
\fbox{%
   \begin{minipage}[c][\boxheight]{\boxwidth}
      {#1}{#2}
   \end{minipage}
}
}

\newcommand{\bridge}{%
\fbox{
   \begin{minipage}[c]{1cm}
   \end{minipage}
}
}

\begin{document}
\pagestyle{empty}%
\noindent%
%\fbox{\begin{minipage}[24cm]{16cm}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
%\end{minipage}}

\begin{textblock*}{75mm}(0mm,0mm)
   xxx xxx\\yyy yyy\\zzz zzz
\end{textblock*}

\end{document}

esdd
Forum-Meister
Forum-Meister
Beiträge: 2490
Registriert: So 7. Feb 2010, 16:36

Beitrag von esdd »

Kontrolliere auch Deine Druckereinstellungen: dort muss "Tatsächliche Größe" oder ähnliches ausgewählt sein, sonst kann es sein, dass die Seite beim Drucken etwas verkleinert wird, was zu größeren Rändern führt.

Antworten