goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98860
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer LatexGast.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Geometry Definition der Seitenränder passt nicht

 

elloro
Forum-Anfänger
Forum-Anfänger

Beiträge: 10
Anmeldedatum: 22.07.15
Wohnort: ---
Version: MiKTeX 2.9
     Beitrag Verfasst am: 19.11.2018, 15:12     Titel: Geometry Definition der Seitenränder passt nicht
  Antworten mit Zitat      
Hallo zusammen,
ich habe ein Problem mit dem Layout der Seite ob es an den Seitenrändern liegt oder doch eher mit den minipages kann ich nicht genau verifizieren.
Das Problem ist folgendes, es wird eine Latex Vorlage für Herma Etiketten No. 9010 benötigt. Also habe ich mir gedacht das ganze über Miniages zu lösen. Die Documentclass ist report und die Seitenränder habe ich mit geometry auf left=2.5cm, right=0.5cm, top=2.9cm, bottom=0.9cm,. Die Werte Left (2,5cm) und Top(2,9cm) habe ich von dem DIN A4 Etikettenbogen gemessen. Das Etikett selber ist 7,5cm breit und 4cm hoch, Zwischen den Etiketten gibt es einen Abstand von 1cm.
Ich habe nun eine Minipage mit den Maßen des Etikettes erstellt als newcommand.
Allerdings stimmen die Seitenränder nicht, die sind jeweils um 0,4cm zu groß. Gemessen an dem Ausdruck der erzeugten PDF Daten

Wenn mir jemand sagen kann was ich da falsch mache, ich sehe da aktuell meine Fehler nicht.

Das ist meine tex-Daten

Code • Öffne in Overleaf

\documentclass[11pt, a4paper]{report}

\usepackage[T1]{fontenc}
\usepackage[left=2.5cm, right=2.5cm,top=2.9cm,bottom=0.9cm, ]{geometry}



\newcommand{\boxheight}{4cm}
\newcommand{\boxwidth}{7.5cm}


\newcommand{\cell}[2]{%
\fbox{%
   \begin{minipage}[c][\boxheight]{\boxwidth}
      {#1}{#2}
   \end{minipage}
}
}

\newcommand{\bridge}{%
\fbox{
   \begin{minipage
}[c]{1cm}
   \end{minipage}
}
}

\begin{document}
\pagestyle{empty}%
\noindent%
%\fbox{\begin{minipage}[24cm]{16cm}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
%\end{minipage}}
\end{document}
 


Vielen Dank für die Hilfe schon mal im voraus
Private Nachricht senden Benutzer-Profile anzeigen

Rolli
Forum-Guru
Forum-Guru

Beiträge: 321
Anmeldedatum: 15.02.17
Wohnort: Mittelfranken
Version: MikTeX 2.9 64-bit
     Beitrag Verfasst am: 19.11.2018, 15:29     Titel:
  Antworten mit Zitat      
Hallo elloro,

Die fbox hat standardmäßig Ränder zwischen Boxbegrenzung und Text eingebaut, ich glaube,es sind 6pt. Wenn Du die nicht willst:

Code • Öffne in Overleaf

\setlength{\fboxsep}{0mm}
 


Gruß vom Rolli
_________________

Rolli's Korollar:
Jede Aktion führt zu (meist unerwünschten)
Nebeneffekten.
Beweis: Rückführung auf Murphy's Gesetz.
-----------------------------------------------------
Linux ist ein Betriebssystem.
WinDoof ist ein Zustand!
-----------------------------------------------------
Fleißiges Löschen der .AUX-Datei führt oft zum Ziel.
-----------------------------------------------------
Beim Arbeiten mit TeX/LaTeX sollten die Dateipfade
weder Umlaute/ß noch Leerräume noch sonstige
Nicht-ASCII7-Zeichen (wie beispielsweise diakritische
Zeichen) haben.
Private Nachricht senden Benutzer-Profile anzeigen

elloro
Forum-Anfänger
Forum-Anfänger

Beiträge: 10
Anmeldedatum: 22.07.15
Wohnort: ---
Version: MiKTeX 2.9
     Beitrag Verfasst am: 19.11.2018, 16:08     Titel:
  Antworten mit Zitat      
Hi Rolli,
das hatte ich nicht gemeint. Die erste Box sollte mit Ihrer linken oberen Ecke eigentlich vom linken Seitenrand 2.5cm weg sein ist aber 3,0cm entfernt von oberen Seitenrand eigentlich 2.9cm ist aber 3.3cm entfernt.

Ich habe mal ein Bild mit angefügt, das zeigt es vielleicht besser was mein Problem ist. Surprised

Unbenannt.png
 Beschreibung:

Download
 Dateiname:  Unbenannt.png
 Dateigröße:  26.41 KB
 Heruntergeladen:  154 mal
Private Nachricht senden Benutzer-Profile anzeigen

Rolli
Forum-Guru
Forum-Guru

Beiträge: 321
Anmeldedatum: 15.02.17
Wohnort: Mittelfranken
Version: MikTeX 2.9 64-bit
     Beitrag Verfasst am: 19.11.2018, 16:37     Titel:
  Antworten mit Zitat      
Ich vermute: Dein oberer Rand kommt vom fehlenden "ignoreheadfoot" und der rechte Rand von der Einrückung.
Ich habe die Dokumentenklasse auf KOMA mit Option parskip=half geändert, und Dir einen absolut positionierte Textblock mit xxx yyy zzz eingebaut.

Gruß vom Rolli

Code • Öffne in Overleaf

\documentclass[11pt, a4paper, parskip=half]{scrreprt}

\usepackage[T1]{fontenc}
\usepackage[left=2.5cm, right=2.5cm,top=2.9cm,bottom=0.9cm, ignoreall, bindingoffset=0mm]{geometry}
\usepackage{showframe}
\usepackage[absolute,showboxes]{textpos}

\newcommand{\boxheight}{4cm}
\newcommand{\boxwidth}{7.5cm}

\newcommand{\cell}[2]{%
\fbox{%
   \begin{minipage}[c][\boxheight]{\boxwidth}
      {#1}{#2}
   \end{minipage}
}
}

\newcommand{\bridge}{%
\fbox{
   \begin{minipage
}[c]{1cm}
   \end{minipage}
}
}

\begin{document}
\pagestyle{empty}%
\noindent%
%\fbox{\begin{minipage}[24cm]{16cm}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
   \cell{Hallo}{Du}\bridge{}\cell{Hallo}{Du}
%\end{minipage}}

\begin{textblock*}{75mm}(0mm,0mm)
   xxx xxx\\yyy yyy\\zzz zzz
\end{textblock*}

\end{document}
 

_________________

Rolli's Korollar:
Jede Aktion führt zu (meist unerwünschten)
Nebeneffekten.
Beweis: Rückführung auf Murphy's Gesetz.
-----------------------------------------------------
Linux ist ein Betriebssystem.
WinDoof ist ein Zustand!
-----------------------------------------------------
Fleißiges Löschen der .AUX-Datei führt oft zum Ziel.
-----------------------------------------------------
Beim Arbeiten mit TeX/LaTeX sollten die Dateipfade
weder Umlaute/ß noch Leerräume noch sonstige
Nicht-ASCII7-Zeichen (wie beispielsweise diakritische
Zeichen) haben.
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2457
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 19.11.2018, 17:20     Titel:
  Antworten mit Zitat      
Kontrolliere auch Deine Druckereinstellungen: dort muss "Tatsächliche Größe" oder ähnliches ausgewählt sein, sonst kann es sein, dass die Seite beim Drucken etwas verkleinert wird, was zu größeren Rändern führt.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de