goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

kleine Buchstaben am Datum angehängt

 

thomasgoetz
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 06.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.11.2018, 18:36     Titel: kleine Buchstaben am Datum angehängt
  Antworten mit Zitat      
Hallo allerseits,

ich schreibe derzeit meine erste Arbeit mit Latex und bin auf folgendes Problem gestoßen:

In der Fußnote gibt Latex folgende Fußnote aus: " Vgl. BFH(17. Sep. 2015a). III R 49/13. " Den kleinen Buchstaben nach dem Datum würde ich gerne entfernen.

Das Problem besteht bei anderen Einträgen ebenso, wenn zwei oder mehr Einträge aus diesem Jahr stammen.

Das Dokument wurde als pdfLaTeX, BibTeX und anschließend erneut als pdfLaTeX gerechnet.

Das Literaturverzeichnis wurde mit JabRef erstellt.

Hat jemand eine Idee, wie man den Buchstaben entfernen kann?

Viele Grüße
Thomas

Code • Öffne in Overleaf

\begin{filecontents*}{literaturdiplarbeit.bib}

@Urteil{BFHIVR8/12,
  author  = {BFH
},
  date    = {2015-12-16},
  title   = {IV R 8/12},
  journal = {BStBl II 2017},
  pages   = {766},
}

@Urteil{BFHIIIR49/13,
  author  = {BFH
},
  date    = {2015-09-17},
  title   = {III R 49/13},
  journal = {BStBl II 2017},
  pages   = {37},
}

\end{filecontents*}


\documentclass[10pt, a4paper] {scrreprt}                                                   % setzt Schriftgröße, Papierformat und Dokumentenklasse
\usepackage[style=authoryear, autocite=footnote, backend=bibtex]{biblatex}                              % ermöglicht Verwendung von Biblatex; Zitate als Fußnoten, Bibtex
\addbibresource{literaturdiplarbeit.bib}                                                   % bindet Biblatex-Datei ein

\begin{document}                                                               % Beginn des Dokumentes


Text \footfullcite[Vgl.][]{BFHIIIR49/13}
Text \footfullcite[Vgl.
][]{BFHIVR8/12}

\end{document}
 


Zuletzt bearbeitet von thomasgoetz am 06.11.2018, 22:13, insgesamt 4-mal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1422
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 06.11.2018, 19:11     Titel:
  Antworten mit Zitat      
Dein Beispiel ist nicht vollständig.
Private Nachricht senden Benutzer-Profile anzeigen

thomasgoetz
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 06.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.11.2018, 19:48     Titel:
  Antworten mit Zitat      
Habe noch begin und end{document} ergänzt. Fehlt dann noch was?
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1422
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 06.11.2018, 20:51     Titel:
  Antworten mit Zitat      
Dein Beispiel zeigt das von Dir beschriebene Problem nicht. Der Buchstabe erscheint erst ab mehr als einem Literaturverweis und bei den biblatex-Optionen dürfte etwas fehlen, um die Ausgabe Deines Datums zu erreichen.

Dürfen die Leser Deines Themas erfahren, warum Du BibTeX statt Biber benutzt?
Private Nachricht senden Benutzer-Profile anzeigen

thomasgoetz
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 06.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.11.2018, 21:06     Titel:
  Antworten mit Zitat      
Stimmt im Text sind beide zitiert. Werde das Minimalbeispiel ergänzen. Weitere Eingaben im Zusammenhang dürften nicht erfolgt sein.

Die übrigen Befehle/ Pakete beschränken sich auf das Layout (scrlayer-scrpage, geometry) oder die Ausgabe von Umlauten und Zeichen(inputenc,babel,...)

Ich verwende Bibtex anstelle von Biber, da ich meinen ersten Versuch mit LateX geführt vom Buch "Wissenschaftliche Arbeiten schreiben mit LateX - Leitfaden für Einsteiger " in der 6. Auflage von Joachim Schlosser unternommen habe.
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1422
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 06.11.2018, 21:56     Titel:
  Antworten mit Zitat      
Das Leerzeichen zwischen \end und {filecontents*} erzeugt zumindest bei Overleaf eine Fehlermeldung.

Das Datum des Beispiels zeigt weiterhin nur das Jahr.

thomasgoetz hat Folgendes geschrieben:
Ich verwende Bibtex anstelle von Biber, da ich meinen ersten Versuch mit LateX geführt vom Buch "Wissenschaftliche Arbeiten schreiben mit LateX - Leitfaden für Einsteiger " in der 6. Auflage von Joachim Schlosser unternommen habe.


In meiner 4. Auflage des Werkes wurde Biber zwar als Nachfolger erwähnt, aber noch nicht verwendet. Herr Schlosser dürfte das in der 6. Auflage geändert haben.
Private Nachricht senden Benutzer-Profile anzeigen

thomasgoetz
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 06.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.11.2018, 22:07     Titel:
  Antworten mit Zitat      
Entschuldige, ja Herr Schlosser verwendet Biber, bin gerade etwas mit den Begrifflichkeiten Bibtex, Biblatex durcheinander gekommen.
Bei habe ich kein Literaturverzeichnis am Ende erhalten. Habe dann auf bibtex umgestellt und seitdem funktioniert es. Warum bzw. wo das Problem davor liegt kann ich aber nicht erklären.

Besteht evtl. die Möglichkeit, dass der kleine Buchstabe durch die Vergabe von BibTe-Keys entsteht? Ich habe zuvor die Keys nach dem Muster Autor, Jahr generieren lassen. Die alten Keys waren somit {BFH2015} und {BFH 2015a}

Nachtrag: Habe das Leerzeichen entfernt. Der Code müsste nun unter Overleaf laufen.
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1422
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 06.11.2018, 23:56     Titel:
  Antworten mit Zitat      
thomasgoetz hat Folgendes geschrieben:
Bei habe ich kein Literaturverzeichnis am Ende erhalten. Habe dann auf bibtex umgestellt und seitdem funktioniert es. Warum bzw. wo das Problem davor liegt kann ich aber nicht erklären.


Wenn Du das Problem lösen möchtest, dann starte dafür ein neues Thema und erkläre dort, weshalb der Einsatz von Biber bei Dir nicht funktioniert. Es gäbe übrigens einen besonderen Grund für Dich, Biber einzusetzen.

thomasgoetz hat Folgendes geschrieben:
Besteht evtl. die Möglichkeit, dass der kleine Buchstabe durch die Vergabe von BibTe-Keys entsteht? Ich habe zuvor die Keys nach dem Muster Autor, Jahr generieren lassen. Die alten Keys waren somit {BFH2015} und {BFH 2015a}


Nein. Die Schlüssel werden nur intern verwendet. Das Erscheinungsbild der Literaturverweise in der PDF-Datei wird anderweitig vom ausgewählten Stil bestimmt. Wenn Du im Dokument an der Stelle des Zitates im Text den Schlüssel siehst, dann ist irgendetwas während des Ablaufs zur Erstellung des Literaturverzeichnisses schief gelaufen.

À propos Eintragstyp: Der Eintragstyp @Urteil wird von biblatex nicht angeboten. Falls nötig, müsste wohl mithilfe des Befehls \DeclareBibliographyDriver ein Eintragstyp angelegt werden.

Wenn Du Dein Verzeichnis mit \printbibliography ausgeben lässt, dann fehlen die Inhalte einiger Datenfelder aus den Eintragstypen in der bib-Datei.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.11.2018, 12:05     Titel:
  Antworten mit Zitat      
Die Standardstile von biblatex sind leider nicht sehr gut für Zitate von Urteilen, Gesetzen und Statuten ausgerüstet. Diese haben häufig eine ganz eigene Struktur, die sich mit dem normalen "Autor, Titel, Datum" nur schwerlich ordentlich abbilden lässt, obwohl man mit etwas gutem Willen vielleicht schon etwas zusammenbasteln kann. Ich bin mir nicht sicher, ob Dein echtes Dokument noch etwas mehr Code für @Urteil hat, denn in dem Zustand hier werden ja einige Angaben einfach ignoriert.

Nur um das deutlich zu machen: Du bekommst diesen Buchstaben, da BibTeX in authoryear-Stil allen Werken desselben Autors aus einem Jahr diese Disambiguierungsbuchstaben zur Seite stellt, damit Zitate im Autor-Jahr-Format eindeutig sind. Dass das sinnvoll ist, kannst Du in
Code • Öffne in Overleaf
\documentclass{article}
\usepackage[style=authoryear]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}
\cite{sigfridsson,knuth:ct:b,knuth:ct:c}
\printbibliography
\end{document}

leicht nachvollziehen.

Auch in Deinem Fall ist es für biblatex klar, dass der Buchstabe gebraucht wird, denn Du nutzt zwar \footfullcite, das 'normale' Zitat \cite würde aber "BFH 2015a" und "BFH 2015b" produzieren. Ohne den Buchstaben wäre das Kürzel nicht eindeutig. Es schert biblatex an der Stelle recht wenig, dass Du gar nicht vorhast, jemals \cite{BFHIIIR49/13} zu schreiben und "BFH 2015a" zu bekommen, die Möglichkeit allein reicht.

Es gibt zwar grundsätzlich Möglichkeiten, den Buchstaben wegzubekommen, wenn er da ist, aber das erscheint mir eher so als würden wir an einem Symptom herumdoktern, wenn man sich eigentlich um das große Ganze kümmern müsste. Wie von Bartman angedeutet, könntest Du mit Biber dafür sorgen, dass der Buchstabe nur noch angehängt wird, wenn ein Label der Form "Name Jahr-Monat-Tag" nicht mehr eindeutig ist, das würde in diesem Beispiel helfen, aber wohl nicht, wenn es zwei Urteile desselben Gerichtes vom gleichen Tag gibt. Mit options = {skiplab}, im .bib-Eintrag könntest Du bei Nutzung von Biber der Erstellung der Disambiguierungsinformation zuvorkommen. Das kann man auch für einen ganzen Typen so einstellen.
Code • Öffne in Overleaf
%\RequirePackage{filecontents}
\begin{filecontents*}{\jobname.bib}
@Urteil{BFHIVR8/12,
  author  = {BFH
},
  date    = {2015-12-16},
  title   = {IV R 8/12},
  journal = {BStBl II 2017},
  pages   = {766},
}
@Urteil{BFHIIIR49/13,
  author  = {BFH
},
  date    = {2015-09-17},
  title   = {III R 49/13},
  journal = {BStBl II 2017},
  pages   = {37},
}
\end{filecontents*}
\documentclass[10pt, a4paper]{scrreprt}
\usepackage[style=authoryear, autocite=footnote, backend=biber]{biblatex}
\addbibresource{\jobname.bib}

\ExecuteBibliographyOptions[urteil]{skiplab}

\begin{document}
Text \footfullcite[Vgl.][]{BFHIIIR49/13}
Text \footfullcite[Vgl.
][]{BFHIVR8/12}
\end{document}

thomasgoetz
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 06.11.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.11.2018, 17:58     Titel:
  Antworten mit Zitat      
Vielen Dank an alle, die Buchstaben sind jetzt weg.

Nachtrag:
Biber lief bei mir im gesamten Dokument nicht, da nicht für alle Einträge Keys generiert wurden.

Den Eintragstyp habe ich mittlerweile eingefügt.

Urteile, Kommentare, etc. lassen sich, wenn auch etwas umständlich, in LateX einpflegen, ich bin derzeit aber noch am basteln.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de