goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Paket caption ändern generell Einzug vor Absätzen

 

Verena
Forum-Anfänger
Forum-Anfänger

Beiträge: 32
Anmeldedatum: 18.11.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 10:29     Titel: Paket caption ändern generell Einzug vor Absätzen
  Antworten mit Zitat      
Hallo an alle,

ich habe vorhin bemerkt, dass die Beschriftungen meiner Tabellen 1,5-zeilig war, was ich auf 1zeilig umstellen wollte. Das habe ich also über die Einbindung des Caption-Paketes geschafft und es funktioniert.
Allerdings hat sich hierdurch etwas geändert, was sich nicht ändern soll: Die jeweils erste Zeile der neuen Absätze (generell im Fließtext) werden jetzt nicht mehr eingezogen.

Code • Öffne in Overleaf

\documentclass[12pt, twoside, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\usepackage{setspace}
\setstretch{1.3}
\setlength{\parindent}{1cm} %Einrückung der ersten Zeile eines neuen Absatzes -> FUNKTIONIERT NICHT MEHR
\usepackage{chngcntr}
\usepackage{float}
\usepackage{microtype}
\setkomafont{pagehead}{\normalfont\footnotesize}
\usepackage[parindent=1cm]{caption} % HIER HABE ICH SCHON GANZ VERSCHIEDENE ARGUMENTE EINGEGEBEN, ABER NICHTS ÄNDERT DEN EINZUG DER ABSÄTZE IM FLIESSTEXT


\begin{document}

Hier steht nun Text und noch mehr Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, der eigentlich um 1cm eingerückt war. Nun ist er nicht mehr eingerückt.

\end{document}
 


Wenn ich das PDF-Dokument genau anschaue ist es sogar so:
Die ersten Zeilen der neuen Absätze sind so lange eingerückt, bis die erste Tabelle kommt.... Danach ist die erste Zeile eines Absatzes NIE eingerückt.

Weiß jemand Abhilfe?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 10:42     Titel:
  Antworten mit Zitat      
Hast Du wirklich genau dieses Beispiel ausprobiert. Wenn ich auf den Overleaf-Link klicke, dann sind bei mir die Absätze eingezogen.

BTW: Bei KOMA-Script-Klassen sollte man nicht selbst an \parindent fummeln. Wenn der voreingestellt Einzug von 1em nicht passt (und auch die Einstellungen von Option parskip), dann sollte man \setparsizes verwenden. Siehe auch https://komascript.de/faq_parindent (auch, wenn es dort vordergründig darum geht, den Einzug abzuschalten).

Achja: Option babel für csquotes ist veraltet. Schau mal in die log-Datei.

Außerdem braucht man bei aktuellen LaTeX weder inputenc (jedenfalls für UTF8) noch chngcntr. Und \normalfont ist für pagehead quasi der Ausgangspunkt, so dass man das dort nicht extra anzugeben braucht. Ebenso ist twoside für scrbook die Voreinstellung.

Zitat:
Wenn ich das PDF-Dokument genau anschaue ist es sogar so:
Die ersten Zeilen der neuen Absätze sind so lange eingerückt, bis die erste Tabelle kommt....

Welche Tabelle? Dein Beispiel hat keine Tabelle.

markusv
Forum-Meister
Forum-Meister

Beiträge: 614
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 13.09.2018, 11:29     Titel: Re: Paket caption ändern generell Einzug vor Absätzen
  Antworten mit Zitat      
Verena hat Folgendes geschrieben:
Code • Öffne in Overleaf

\usepackage[parindent=1cm]{caption} % HIER HABE ICH SCHON GANZ VERSCHIEDENE ARGUMENTE EINGEGEBEN, ABER NICHTS ÄNDERT DEN EINZUG DER ABSÄTZE IM FLIESSTEXT
 
caption ist für Beschriftungen von Gleitumgebungen zuständig. Dass sich hierbei nichts im Fließtext ändert, sollte einleuchten. Ansonsten ist das zu beachten, was Gast bereits erwähnt hat.
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Verena
Forum-Anfänger
Forum-Anfänger

Beiträge: 32
Anmeldedatum: 18.11.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 11:31     Titel:
  Antworten mit Zitat      
Stimmt, im Beispiel geht es natürlich, tut mir leid!
Habe jetzt auch \setparsizes{1cm}{0pt}{0pt plus 1fil} eingefügt und den Sünden-Code entfernt.
Allerdings ist das Problem mit der ersten Zeile der Absätze weiterhin dasselbe:

Code • Öffne in Overleaf

\documentclass[12pt, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{framed}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{etoolbox}
\usepackage{kantlipsum}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\usepackage{setspace}
\setstretch{1.3}
\setparsizes{1cm}{0pt}{0pt plus 1fil} %-> neu eingefügt
\usepackage[parindent=1cm]{caption}

\begin{document}

Hier steht Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, dessen erste Zeile um 1 cm korrekt eingerückt wird. Danach kommt nun allerdings meine Tabelle.

\begin{tabular}{l|l|l}\hline\hline
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
Text & Text & Text \\\hline
\end{tabular}      
\captionof{table}{Hier steht die etwas längere und daher zweizeilige Tabellenunterschrift.}
\normalsize
\noindent
Hier kommt neuer Text.

Und ab hier nun funktioniert das Einrücken der ersten Zeile nicht mehr. Betrifft ab hier das gesamte Dokument.

\end{document}
 


Zuletzt bearbeitet von Verena am 13.09.2018, 11:37, insgesamt einmal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

Verena
Forum-Anfänger
Forum-Anfänger

Beiträge: 32
Anmeldedatum: 18.11.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 11:34     Titel:
  Antworten mit Zitat      
@Forum-Meister

Ja, ganz genau! Es sollte sich im Fließtext eben nichts ändern....
Du hast Recht, dass ich über die Zeile, die du anführst, nichts verändern kann. Aber insgesamt ändert das Einbinden des caption-Paketes leider doch meinen Fließtext Sad
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 12:12     Titel:
  Antworten mit Zitat      
https://tex.stackexchange.com/q/62875/35864

Du brauchst irgendeine Gruppe um \captionof.

Code • Öffne in Overleaf
\documentclass[12pt, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{framed}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{etoolbox}
\usepackage{kantlipsum}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\usepackage{setspace}
\setstretch{1.3}
\setlength{\parindent}{1cm}
\usepackage{caption}

\begin{document}

Hier steht Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, dessen erste Zeile um 1 cm korrekt eingerückt wird. Danach kommt nun allerdings meine Tabelle.

\begingroup
\begin{tabular}{l|l|l}\hline\hline
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
Text & Text & Text \\\hline
\end{tabular}      
\captionof{table}{Hier steht die etwas längere und daher zweizeilige Tabellenunterschrift.}
\endgroup
\noindent
Hier kommt neuer Text.

Und ab hier nun funktioniert das Einrücken der ersten Zeile nicht mehr. Betrifft ab hier das gesamte Dokument.

\end{document}

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 12:19     Titel:
  Antworten mit Zitat      
Ich gehe einmal davon aus, dass Du nicht willst, dass zwischen Tabelle und Tabellenunterschrift ein Seitenumbruch erfolgen darf. Dann sollte da min. eine minipage darum herum:
Code • Öffne in Overleaf
\documentclass[12pt, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{framed}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{etoolbox}
\usepackage{kantlipsum}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\usepackage{setspace}
\setstretch{1.3}
\setparsizes{1cm}{0pt}{0pt plus 1fil} %-> neu eingefügt
\usepackage[parindent=1cm]{caption}

\begin{document}

Hier steht Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, dessen erste Zeile um 1 cm korrekt eingerückt wird. Danach kommt nun allerdings meine Tabelle.

\noindent\begin{minipage}{\linewidth}
\begin{tabular}{l|l|l}\hline\hline
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
Text & Text & Text \\\hline
\end{tabular}      
\captionof{table}{Hier steht die etwas längere und daher zweizeilige Tabellenunterschrift.}
\end{minipage}
\noindent
Hier kommt neuer Text.

Und ab hier nun funktioniert das Einrücken der ersten Zeile nicht mehr. Betrifft ab hier das gesamte Dokument.

\end{document}

Allerdings finde ich, dass auch das noch furchtbar aussieht. Ich würde da min.
Code • Öffne in Overleaf
\documentclass[12pt, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage{framed}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{etoolbox}
\usepackage{kantlipsum}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\usepackage{setspace}
\setstretch{1.3}
\setparsizes{1cm}{0pt}{0pt plus 1fil} %-> neu eingefügt
\usepackage[parindent=1cm]{caption}

\begin{document}

Hier steht Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, dessen erste Zeile um 1 cm korrekt eingerückt wird. Danach kommt nun allerdings meine Tabelle.

\begin{center}
\begin{minipage}{\linewidth}\centering
\begin{tabular}{l|l|l}\hline\hline
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
Text & Text & Text \\\hline
\end{tabular}      
\captionof{table}{Hier steht die etwas längere und daher zweizeilige Tabellenunterschrift.}
\end{minipage}
\end{center}
Hier kommt neuer Text.

Und ab hier nun funktioniert das Einrücken der ersten Zeile nicht mehr. Betrifft ab hier das gesamte Dokument.

\end{document}
verwenden, wenn nicht sogar explizit ein \vspace*{\intextsep} am Anfang und Ende der minipage einfügen:
Code • Öffne in Overleaf
\documentclass[12pt, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[utf8]{inputenc}% <-- für csquotes verschoben!
\usepackage{csquotes}% <-- für biblatex eingefügt!
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[T1]{fontenc}
\usepackage{lmodern}

\usepackage{setspace}
\setstretch{1.3}
\setparsizes{1cm}{0pt}{0pt plus 1fil} %-> neu eingefügt
\usepackage[parindent=1cm]{caption}

\begin{document}

Hier steht Text und noch mehr Text und noch mehr Text und noch mehr Text.

Hier beginnt ein neuer Absatz, dessen erste Zeile um 1 cm korrekt eingerückt wird. Danach kommt nun allerdings meine Tabelle.

\noindent\begin{minipage}{\linewidth}
\vspace*{\intextsep}\centering
\begin{tabular}{l|l|l}\hline\hline
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
\multicolumn{1}{c|}{Text} & \multicolumn{2}{c}{Text}\\
Text & Text & Text \\\hline
\end{tabular}      
\captionof{table}{Hier steht die etwas längere und daher zweizeilige Tabellenunterschrift.}
\par\vspace*{\intextsep}
\end{minipage}
Hier kommt neuer Text.

Und ab hier nun funktioniert das Einrücken der ersten Zeile nicht mehr. Betrifft ab hier das gesamte Dokument.

\end{document}

Ich habe mir außerdem erlaubt, in dem Beispiel ein paar für das Beispiel überflüssige Dinge rauszuwerfen und gleichzeitig ein paar Unsauberkeiten zu korrigieren und zu kommentieren.

Verena
Forum-Anfänger
Forum-Anfänger

Beiträge: 32
Anmeldedatum: 18.11.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.09.2018, 13:06     Titel:
  Antworten mit Zitat      
Oh vielen Dank!!!
Und danke auch für die Hinweise zum Code. Wirklich super! Ich habe mir da vieles über die letzten beiden Jahre nach und nach aus dem Internet zusammengesucht.......
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de