Zusammenhang Sprache - Farbe?

Inhalt, Abbildungen, Tabellen, Quellcodes und andere Verzeichnisse


Verena
Forum-Anfänger
Forum-Anfänger
Beiträge: 44
Registriert: Mi 18. Nov 2015, 14:41

Zusammenhang Sprache - Farbe?

Beitrag von Verena »

Liebe alle,

ich habe ein Problem, das mir sehr kurios erscheint. Schaffe es nicht, es zu "durchschauen".

Folgender Code (quasi mein Ausgangscode) funktioniert perfekt:

Code: Alles auswählen

\documentclass[paper=a4, 12pt, oneside, headsepline, headings=optiontoheadandtoc]{scrbook}
\usepackage[french, ngerman]{babel}
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\renewcommand*{\postnotedelim}{\addcolon\space} 
\usepackage[utf8]{inputenc}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage{xcolor, colortbl}
\usepackage{framed}
\usepackage{enumerate} \usepackage{enumitem} 
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{textcomp} 
\usepackage{etoolbox}
\usepackage{kantlipsum}
\usepackage{pdflscape} 
\usepackage{hyphenat}

\definecolor{aquamarine}{rgb}{0.5, 1.0, 0.83}
\definecolor{aqua}{rgb}{0.0, 1.0, 1.0}
\definecolor{bluegray}{rgb}{0.4, 0.6, 0.8}
\definecolor{languidlavender}{rgb}{0.84, 0.79, 0.87}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}
\renewcaptionname{french}{\figurename}{Abb.} 
\renewcaptionname{french}{\tablename}{Tab.} 

\begin{document}
Gleich folgt eine sogenannte \og Tabelle\fg{}.
\begin{landscape}
\renewcommand{\arraystretch}{0.9} 
\small
\begin{longtable}{lll}
\toprule
\multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}\\
\midrule
\rowcolor{languidlavender!60} text & text &  text \\
\midrule
text & text &  text \\
text & text &  text \\
\bottomrule
\end{longtable}
\end{landscape}
Bis hierhin klappt alles perfekt.
Nun habe ich den Text im Dokument ins Französische übersetzt und, da es ja Anführungszeichen im Text gibt, die Sprache und Einstellung für die Anführungszeichen geändert.
Plötzlich spuckt mir Latex jetzt Fehler aus.

Minimalbeispiel

Code: Alles auswählen

\documentclass[paper=a4, 12pt, oneside, headsepline, headings=optiontoheadandtoc]{scrbook}

\usepackage[french]{babel} %-> HIER SPRACHE GEÄNDERT
\usepackage[backend=biber, style=authoryear-comp, isbn=false, dashed=false, maxitems=2, maxnames=3, uniquename=false]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[babel, french=quotes]{csquotes} %-> HIER SPRACHE GEÄNDERT
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage{xcolor, colortbl}
\usepackage{framed}
\usepackage{enumerate} \usepackage{enumitem}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{textcomp} 
\usepackage{etoolbox}
\usepackage{kantlipsum}
\usepackage{pdflscape} 
\usepackage{hyphenat}

\definecolor{aquamarine}{rgb}{0.5, 1.0, 0.83}
\definecolor{aqua}{rgb}{0.0, 1.0, 1.0}
\definecolor{bluegray}{rgb}{0.4, 0.6, 0.8}
\definecolor{languidlavender}{rgb}{0.84, 0.79, 0.87}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}
\renewcaptionname{french}{\figurename}{Abb.} 
\renewcaptionname{french}{\tablename}{Tab.} 

\begin{document}
Hier steht französischer Text und die so genannte \og Tabelle\fg{}.
\begin{landscape}
\renewcommand{\arraystretch}{0.9} 
\small
\begin{longtable}{lll}
\toprule
\multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}\\
\midrule
\rowcolor{languidlavender!60} text & text &  text \\
\midrule
text & text &  text \\
text & text &  text \\
\bottomrule
\end{longtable}
\end{landscape}
Fehlermeldung:
Package xcolor Error: Undefined Color bluegray\penalty\x@M\hskip .5\fontdimen \2font \relax '.

Irgendwie muss der Haken in der Kombination von FRENCH und der Farbe liegen. Hat jemand eine Idee?
DANKE schon mal!

P.S.: Die Sprachänderung für die Anführungszeichen funktioniert. Sie sind automatisch französisch.

Bartman
Forum-Meister
Forum-Meister
Beiträge: 2116
Registriert: Do 16. Jul 2009, 21:41
Wohnort: Hessische Provinz

Beitrag von Bartman »

Deine Fehlermeldung erhalte ich mit meinem geänderten Beispiel nicht, dafür hängt es an anderer Stelle.

Code: Alles auswählen

\documentclass[fontsize=12pt, twoside=false, headsepline, headings=optiontoheadandtoc]{scrbook}

\usepackage[french]{babel} %-> HIER SPRACHE GEÄNDERT
\usepackage[style=authoryear-comp, isbn=false, dashed=false, maxitems=2]{biblatex}
\usepackage[utf8]{inputenc}
\usepackage[autostyle]{csquotes}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{lmodern}
\usepackage[table]{xcolor}% <- geändert
\usepackage{enumitem}
\usepackage{pdfpages}
\pdfoptionpdfminorversion=5
\usepackage{booktabs}
\usepackage{pdflscape} 
\usepackage{hyphenat}

\definecolor{aquamarine}{rgb}{0.5, 1.0, 0.83}
\definecolor{aqua}{rgb}{0.0, 1.0, 1.0}
\definecolor{bluegray}{rgb}{0.4, 0.6, 0.8}
\definecolor{languidlavender}{rgb}{0.84, 0.79, 0.87}

% Tabelle
\usepackage{longtable}
\usepackage{tabularx}

\renewcaptionname{french}{\figurename}{Abb.} 
\renewcaptionname{french}{\tablename}{Tab.} 

\begin{document}
Hier steht französischer Text und die so genannte \enquote{Tabelle}.
\begin{landscape}
\renewcommand{\arraystretch}{0.9} 
\small
\begin{longtable}{lll}
\toprule
\multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}}\\% Hier fehlte eine schließende geschweifte Klammer
\midrule
\rowcolor{languidlavender!60} text & text &  text \\
\midrule
text & text &  text \\
text & text &  text \\
\bottomrule
\end{longtable}
\end{landscape}
\end{document}% fehlt in beiden Beispielen
Zuletzt geändert von Bartman am Sa 8. Sep 2018, 15:56, insgesamt 1-mal geändert.

Gast

Beitrag von Gast »

Dein Code hat zwei kleine Problemchen, die mit der erwähnten fehlermeldung nichts zu tun haben.
  1. Es fehlt ein \end{document}
  2. Es fehlt eine schließende Klammer in

    Code: Alles auswählen

    \multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}\\
    es müsste

    Code: Alles auswählen

    \multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}}\\
    heißen
In klein nachvollziehen kann man das eigentliche Problem in

Code: Alles auswählen

\documentclass{article}
\usepackage[french]{babel}
\usepackage[utf8]{inputenc}
\usepackage[babel, french=quotes]{csquotes}
\usepackage[T1]{fontenc}
\usepackage{xcolor, colortbl}

\begin{document}
\begin{tabular}{lll}
\multicolumn{3}{>{\columncolor{red!60}}l}{\textbf{ERSTE ZEILE}}\\
\end{tabular}
\end{document}
Die Fehlermeldung lautet hier

Code: Alles auswählen

! Package xcolor Error: Undefined color `red\penalty \@M \hskip .5\fontdimen 2\
font \relax '.
Da hat also irgendwer unser schönes red!60 durch red und irgendeinen Kokolores ersetzt. In der Tat war dieser jemand das französische Sprachmodul von babel, das muss nämlich um den französischen Regeln zu Leerzeichen vor bestimmter Interpunktion gerecht zu werden, das Ausrufezeichen umdefinieren. Damit hat colortbl aber ein paar Probleme.

Lade statt xcolor und colortbl einfach nur xcolor mit der Option table, siehe auch https://tex.stackexchange.com/q/355394/35864

Code: Alles auswählen

\usepackage[table]{xcolor}
Und siehe da

Code: Alles auswählen

\documentclass{article}
\usepackage[french]{babel}
\usepackage[utf8]{inputenc}
\usepackage[babel, french=quotes]{csquotes}
\usepackage[T1]{fontenc}
\usepackage[table]{xcolor}
\usepackage{booktabs}
\usepackage{pdflscape} 

\definecolor{aquamarine}{rgb}{0.5, 1.0, 0.83}
\definecolor{aqua}{rgb}{0.0, 1.0, 1.0}
\definecolor{bluegray}{rgb}{0.4, 0.6, 0.8}
\definecolor{languidlavender}{rgb}{0.84, 0.79, 0.87}

\usepackage{longtable}

\begin{document}
Hier steht französischer Text und die so genannte \enquote{Tabelle}.
\begin{landscape}
\renewcommand{\arraystretch}{0.9}
\small
\begin{longtable}{lll}
\toprule
\multicolumn{3}{>{\columncolor{bluegray!60}}l}{\textbf{ERSTE ZEILE}}\\
\midrule
\rowcolor{languidlavender!60} text & text &  text \\
\midrule
text & text &  text \\
text & text &  text \\
\bottomrule
\end{longtable}
\end{landscape}
\end{document}
es geht.

PS: Wenn Du csquotes lädst, warum nutzt Du es dann nicht?

Verena
Forum-Anfänger
Forum-Anfänger
Beiträge: 44
Registriert: Mi 18. Nov 2015, 14:41

Beitrag von Verena »

Vielen Dank an euch!

\end{document} und die schließende Klammer im Minimalbeispiel zu vergessen, war natürlich nicht schlau (sorry!)

Die Frage mit dem Paket csquotes ist berechtigt -> Werde ich ändern.

Mit der farbigen Gestaltung der Tabelle funktioniert nun alles. Vielen Dank, das hätte ich alleine nicht gefunden!

Antworten