goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

\pagenumbering wirkt schon ein Kapitel vorher

 

buster65
Forum-Anfänger
Forum-Anfänger

Beiträge: 26
Anmeldedatum: 19.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.06.2018, 21:36     Titel: \pagenumbering wirkt schon ein Kapitel vorher
  Antworten mit Zitat      
Hallo zusammen,

ich habe bei der Umschaltung des Seitennummerierungsmodus ein unlogisches Verhalten des Kommandos \pagenumbering festgestellt.

Der Modus wird schon umgeschalten bevor das Kommando im Code erscheint (Im Anhang ist das PDF):

Code • Öffne in Overleaf

\documentclass[toc=bibnumbered]{scrreprt}

\usepackage[ngerman]{babel}

\usepackage[babel,german=quotes]{csquotes}
\usepackage[]{biblatex}

\addbibresource{Literatur.bib}

\begin{document}

\pagenumbering{Roman}

\pagestyle{empty}
\include{Test_titel}
   
\pagestyle{plain}
\include{02_erklaerung}

\tableofcontents
\addcontentsline{toc}{chapter}{Inhaltsverzeichnis}
% Umschaltung auf arabische Zahlen kommt erst nach Inhaltsverzeichnis
\pagenumbering{arabic}
   
\include{10_einleitung}

\include{12_standdertechnik}

\printbibliography
% Umschaltung auf gr. Buchstaben kommt erst nach dem Literaturverzeichnis
\pagenumbering{Alph}

\include{30_Anhang}

\end{document}
 



Ich hätte erwartet, daß das Inhaltsverzeichnis noch Seite III hat und das Literaturverzeichnis Seite 3 oder 4 und nicht A.

Ich vermute, daß sich die Kommandos \addcontentsline und \printbibliography irgendwie anders als \include auf das Kommando \pagenumbering auswirken.

Wenn ich das Kommando \pagenumbering herausnehme, werden die Seiten lückenlos und ohne Initialisierungen durchnummeriert - wie erwartet.

Ich finde keine Erklärung dafür.

Hat jemand eine Idee was die Ursache sein könnte und wie man sie beseitgen kann?

Vielen Dank für jeden Hinweis!



Grüße aus dem Rheinland

Test_DA.pdf
 Beschreibung:

Download
 Dateiname:  Test_DA.pdf
 Dateigröße:  60.27 KB
 Heruntergeladen:  22 mal
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1317
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 10.06.2018, 23:15     Titel:
  Antworten mit Zitat      
Wenn es sein muss, dann verwende besser \setuptoc{toc}{totoc} statt \addcontentsline{toc}{chapter}{Inhaltsverzeichnis}.

In der Anleitung zur Erstellung eines InfoMinimalbeispiels kannst Du nachlesen, wie Du mit \include-Anweisungen verfahren solltest.

Lies bitte, wie man einen Anhang richtig setzt.
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4995
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.06.2018, 05:34     Titel:
  Antworten mit Zitat      
\cleardoublepage gehört grundsätzlich vor \pagenumbering.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.06.2018, 07:38     Titel:
  Antworten mit Zitat      
Johannes_B hat Folgendes geschrieben:
\cleardoublepage gehört grundsätzlich vor \pagenumbering.

Bei KOMA-Script-Klassen sogar \cleardoubleoddpage (Zitat aus der Erklärung zu \pagenumbering auf Seite 102 der 6. Auflage des KOMA-Script-Buchs):
Markus Kohm hat Folgendes geschrieben:
Die Umschaltung gilt ab sofort, also ab der Seite, auf der diese Anweisung aufgerufen wird. Gegebenenfalls sollte also zuvor mit \clearpage oder besser \cleardoubleoddpage diese Seite erst beendet werden.

Vermutlich steht im aktuellen scrguide vergleichbares.

Dein Eintrag des Inhaltsverzeichnisses ins Inhaltsverzeichnis ist übrigens auch zu spät. So wird die letzte Seite des Inhaltsverzeichnisses ins Inhaltsverzeichnis eingetragen statt der ersten. Bei KOMA-Script verwendet man besser \setuptoc in der Dokumentpräambel, wie ebenfalls in Buch und Anleitung erklärt (wobei zumindest im Buch AFAIK auch erklärt ist, dass man das Inhaltsverzeichnis besser nicht ins Inhaltsverzeichnis einträgt, ist ja irgendwie sinnlos).

Für die Verwendung von Option babel beim Laden von csquotes müsstest Du eigentlich eine Warnung in der log-Datei haben. Dort steht auch, wodurch man sie ggf. ersetzen sollte.

Es sei darauf hingewiesen, dass die Kombination von \include und \addcontentsline u. U. kritisch ist, da \addcontentsline verzögert in die aux-Datei schreibt, \include aber sofort. Deshalb kann es passieren, dass der entsprechende Eintrag nach allen Einträgen der Unterdatei ausgeführt wird. Im Beispiel wird das vermutlich nicht auftreten und spielt es ohnehin keine Rolle, weil \addcontentsline ja ohnehin falsch eingesetzt wird (siehe oben).

buster65
Forum-Anfänger
Forum-Anfänger

Beiträge: 26
Anmeldedatum: 19.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.06.2018, 14:02     Titel:
  Antworten mit Zitat      
Hallo zusammen,

danke für die hilfreichen Tipps und Erklärungen!

Ein Einfügen von \clearpage vor \pagenumbering hat das Problem gelöst.

Wenn ich \setuptoc{toc}{totoc} statt \addcontentsline{toc}{chapter}{Inhaltsverzeichnis} einsetzte, fehlt der Eintrag für das Inhaltsverzeichnis.
Also habe ich \addcontentsline gelassen und alles sieht gut aus.

Vielen Dank nochmals!



Grüße aus dem Rheinland
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2328
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 11.06.2018, 14:19     Titel:
  Antworten mit Zitat      
buster65 hat Folgendes geschrieben:

Wenn ich \setuptoc{toc}{totoc} statt \addcontentsline{toc}{chapter}{Inhaltsverzeichnis} einsetzte, fehlt der Eintrag für das Inhaltsverzeichnis.


Zeig ein Beispiel, bei dem das der Fall ist. Im folgenden funktioniert das ganz hervorragend:

Code • Öffne in Overleaf

\documentclass{scrreprt}
\setuptoc{toc}{totoc}
\begin{document}
\tableofcontents
\chapter{Kapitel}
\end{document}
 



buster65 hat Folgendes geschrieben:

Also habe ich \addcontentsline gelassen und alles sieht gut aus.


Dann hoffe, dass Dein Inhaltsverzeichnis am Ende nicht mehr als eine Seite hat. Der manuelle Eintrag in Deinem Code wird auf dessen letzter Seite veranlasst, also wird auch die letzte Seitennummer des Inhaltsverzeichnisses bei dem Eintrag angegeben. Abgesehen davon ist der Eintrag des TOCs ins TOC komplett überflüssig ...
Private Nachricht senden Benutzer-Profile anzeigen

buster65
Forum-Anfänger
Forum-Anfänger

Beiträge: 26
Anmeldedatum: 19.05.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.06.2018, 16:31     Titel:
  Antworten mit Zitat      
Hallo esdd,

ich hatte \setuptoc{toc}{totoc} an die Stelle gesetzt wo vorher \addcontentsline{toc}{chapter}{Inhaltsverzeichnis} war und das was nach \begin{document}. Confused

Jetzt läuft es. Laughing

Besten Dank für den Hinweis!
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de