goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97626
Top-Poster: Johannes_B (5052)

Wir begrüßen unseren neuesten Benutzer timmetimtimme.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Referenzierung mit autoref

 

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.02.2019, 19:28     Titel: Referenzierung mit autoref
  Antworten mit Zitat      
Hallo!

Ich habe eine Tabelle mit xltabular eingebunden. Unter der Tabelle wird auch die korrekte Caption mit "Tabelle 1: " angezeigt.
Im Text referenziert taucht allerdings "Tabelle 0" auf. Bei allen anderen Tabellen passt die Nummerierung und auch die Referenzierung im Text.

Hatte dieses Problem schon einmal jemand?

Viele Grüße

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1659
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 23.02.2019, 19:38     Titel:
  Antworten mit Zitat      
Kannst Du das Problem mit einem InfoMinimalbeispiel nachbilden?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.02.2019, 19:51     Titel:
  Antworten mit Zitat      
Ja klar, hätte ich gleich machen sollen.

Code • Öffne in Overleaf
\documentclass[12pt, a4paper]{scrartcl}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage{longtable,tabu}
\usepackage{xltabular}
\usepackage{booktabs}
\usepackage{wasysym}
\usepackage{ragged2e}
\usepackage[hidelinks]{hyperref}
\renewcommand{\tabularxcolumn}[1]{m{#1}}

\begin{document}
   In der nachfolgenden \autoref{tab:3.1}
   
      \begin{xltabular}{\textwidth}{p{2.5cm}|X}
      \toprule
      \textbf{Name}   &   \textbf{Beschreibung}  \\
      \midrule
      \endhead
      test & test \\
      \midrule
      \caption{Entwicklung im zeitlichen Verlauf}
      \label{tab:3.1}  
   \end{xltabular}
   
\end{document}
 

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1659
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 23.02.2019, 20:24     Titel:
  Antworten mit Zitat      
Meine verhältnismäßig aktuelle MiKTeX-Installation kann Dein Problem nicht nachbilden.

Du möchtest an der Stelle wirklich den Spaltentyp p statt m verwenden?

Auf ctan.org erfährst Du, welche Pakete mit xltabular geladen werden. Brauchst Du außer dem genannten Paket auch tabu?

Musst Du in der Tabelle den senkrechten Strich benutzen?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.02.2019, 20:46     Titel:
  Antworten mit Zitat      
Komisch. Vielleicht sollte ich Latex neu installieren.
Aktuell ist das noch Tex Live 2017

Tabu brauch ich tatsächlich nicht mehr. Ursprünglich war das ganze eine longtabu.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2019, 08:40     Titel:
  Antworten mit Zitat      
Ich kann das Problem auch nicht reproduzieren. Von einer Neuinstallation würde ich zunächst abraten, das ist nur sinnvoll, wenn wir sicher wissen, dass es an einem veralteten Paket liegt.

Reproduziert der exakte gezeigte Code das Problem, wenn Du ihn mindestens zweimal (um sicher zu sein, sagen wir dreimal) in einem neuen, leeren Ordner mit LaTeX kompilierst? Kannst Du den Code noch weiter reduzieren, indem Du ungenutzte Pakete (wasysym, tabu ...) herauswirfst? Kannst Du uns von dem neuen reduzierten InfoMinimalbeispiel die .log und .aux-Datei hochladen?

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2019, 10:05     Titel:
  Antworten mit Zitat      
Hallo!

Mehrmals kompilieren nützt leider nichts. Auch das Rauswerfen der überflüssigen Pakete (die ich aber für meine komplette Arbeit brauche) bringt nichts.

Ich hab gestern Abend noch die 2018er Version installiert.
Damit funktioniert komischerweise das Minimalbeispiel einwandfrei.

In meiner Arbeit steht jetzt auch die gleiche Zahl im Text, die auch in der Caption steht. Die ist jetzt allerdings nicht mehr 0 sondern auf einmal 2. Und auch alle anderen Tabellen reihen sich danach ein - Tabelle 1 fehlt auch im Tabellenverzeichnis am Ende.
Schreibe ich "\setcounter{table}{-1}" vor die erste Tabelle, ist die Nummerierung wieder richtig.
Woran das liegt.. keine Ahnung.
Aber immerhin passt jetzt die Nummerierung.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2019, 10:10     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:
Von einer Neuinstallation würde ich zunächst abraten

Von einer Neuinstallation derselben TeX-Live-Version, ja. Aber zusätzlich zum veralteten TeX Live 2017 das derzeit noch aktuelle TeX Live 2018 zu installieren, sollte bei Verwendung von Vanilla TeX Live 2018 gefahrlos möglich sein. Man kann dann einfach per PATH-Einstellung umschalten. Bevor man die neue Version fest in PATH verankert kann man sogar einfach PATH nur versuchsweise in einem Terminal ändern. Bei der bash geht das auch ganz einfach nur für einen Aufruf per:
Code • Öffne in Overleaf
PATH="/usr/local/texlive/2018/bin/x86_64-linux:$PATH" pdflatex testdatei.tex

Ich habe in der Übergangszeit von einer TeX-Live-Version zur nächsten meist zwei Versionen parallel installiert. Das funktioniert problemlos.

Johannes_B
Moderator
Moderator


Beiträge: 5052
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2019, 10:17     Titel:
  Antworten mit Zitat      
Hast du am Anfang ein Abkürzungsverzeichnis (oder was ähnliches) mit longtable erstellt?
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2019, 11:13     Titel:
  Antworten mit Zitat      
Zur Installation:
Genau so hab ich es gemacht. 2018er Version neben der 2017er installiert und den 2018er PATH über den 2017er gestellt.

longtable:
Nein, Ich hab am Anfang nur die Deklaration einer Titelseite.
Tabellenverzeichnis, Abbildungsverzeichnis und Quellen kommen am Schluss der Arbeit und sind auch mit den folgenden Befehlen erstellt.
Code • Öffne in Overleaf

   \listoffigures
   
   \clearpage
   
   \listoftables
   
   \clearpage
   \bibliography{literaturverzeichnis}
 

Der Anhang mit einer Tabelle folgt auch erst danach, der hat aber weder ein Label noch eine Caption

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de