Fehlermeldung beim Kompilieren mit makeglossaries

Antwort erstellen


Diese Frage dient dazu, das automatisierte Versenden von Formularen durch Spam-Bots zu verhindern.
Smilies
:D :) :( :o :shock: :? 8) :lol: :-x :P :oops: :cry: :evil: :twisted: :roll: :wink: :!: :?: :idea: :arrow: :| :mrgreen:

Markdown is OFF

BBCode ist eingeschaltet
[img] ist eingeschaltet
[flash] ist ausgeschaltet
[url] ist eingeschaltet
Smilies sind eingeschaltet

Die letzten Beiträge des Themas

Ich habe die Datenschutzerklärung gelesen und bin damit einverstanden.

   

Wenn du eine Datei oder mehrere Dateien anhängen möchtest, gib die Details unten ein.

Ansicht erweitern Die letzten Beiträge des Themas: Fehlermeldung beim Kompilieren mit makeglossaries

von Varus » Mi 11. Apr 2018, 19:06

Ah okay, habe ich gemacht. Nun kommt beim Befehl glossaries folgende Meldung, sowohl in der Konsole als auch in TexStudio:

Code: Alles auswählen

Prozess gestartet: makeglossaries.exe "00_Master"

Warning: File '00_Master.glo' is empty. Have you used any entries defined in glossary 'main'? Remember to use package option 'nomain' if you don't want to use the main glossary.

Prozess endete normal
EDIT: Diese Meldung kommt bei meinem Projekt welches aus mehreren Files besteht. Bei dem minimal Beispiel passiert immer noch nichts, also alles so wie vorher.

EDIT2: Habe es jetzt zum Laufen bringen können indem ich die Optionen alle deaktiviert habe:

Code: Alles auswählen

\documentclass[a4paper]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}


\usepackage{amsmath}
\usepackage[ngerman]{varioref}%reihenfolge hier wichtig, ist für Querverweise
\usepackage[ngerman]{hyperref}%vref, cref und ref sind die befehle
\usepackage[ngerman]{cleveref}


\usepackage{glossaries}
%\usepackage[xindy,style=tree]{glossaries}
%\GlsSetXdyLanguage{german}
%\GlsSetXdyCodePage{duden-utf8}
\makeglossaries	
\newacronym{abc}{IMU}{Inert Measurment Unit}


\begin{document}
\printglossary

\gls{abc}	
        asdsadas \gls{abc}

\end{document}
Danke Gruß

von u_fischer » Mi 11. Apr 2018, 18:55

Doch das ist schon die richtige Datei. Füge meinen Code da ein und ersetze die ~.

von Varus » Mi 11. Apr 2018, 18:42

Hi,
sry für die späte Antwort war noch auf der Arbeit.

Habe die Datei gesucht und gefunden. Allerdings ist der Inhalt nicht wie erwartet^^:

Code: Alles auswählen

% (Public domain.)
% This texmf.cnf file should contain only your personal changes from the
% original texmf.cnf (for example, as chosen in the installer).
%
% That is, if you need to make changes to texmf.cnf, put your custom
% settings in this file, which is .../texlive/YYYY/texmf.cnf, rather than
% the distributed file (which is .../texlive/YYYY/texmf-dist/web2c/texmf.cnf).
% And include *only* your changed values, not a copy of the whole thing!
%
OSFONTDIR = $SystemRoot/fonts//

% Prefer external Perl for third-party TeXLive Perl scripts
% Was set to 1 if at install time a sufficiently recent Perl was detected.
TEXLIVE_WINDOWS_TRY_EXTERNAL_PERL = 0
Externes Pearl glaube schon, habe gestern ein Anleitung gefunden nachdem es nicht funktioniert hatte. Habe dann ActivePerl runtergeladen und installiert. Dummerweise finde ich die Seite aber gerade nicht mehr.

EDIT: Hier die Seite, bin nach Anleitung 2 vorgegangen:
http://www.mrunix.de/forums/showthread. ... t%20falsch

Vielen Dank,
Gruß

von u_fischer » Mi 11. Apr 2018, 08:56

Du kannst mal in die texmf.cnf in texlive/2017 Änderungen für die drei Variablen eingeben, die dein Benutzerprofil nutzen:

Code: Alles auswählen

% ~ expands
% to %USERPROFILE% on Windows, $HOME otherwise.

TEXMFHOME = ~/texmf

% TEXMFVAR, where texconfig/updmap/fmtutil store cached runtime data.

TEXMFVAR = ~/.texlive2017/texmf-var

% TEXMFCONFIG, where texconfig/updmap/fmtutil store configuration data.

TEXMFCONFIG = ~/.texlive2017/texmf-config

Ersetze die ~ durch irgendwas geeignetes ohne Umlaute. Hilft das?

Wenn es hilft, sollte man das melden, denn eigentlich dachte ich, der Fehler wäre 2013 behoben worden. Hast du ein externes Perl? Hast du wie ich angenommen habe, texlive 2017?

von Varus » Mi 11. Apr 2018, 08:11

Guten Morgen,
danke für das Ausprobieren!
TexLive ist direkt unter C:/TexLive installiert. Das Dokument befindet sich unter G:...
Also scheint er da auf meinen Benutzer Ordner zuzugreifen warum auch immer. Könnte bis her alles mit Latex machen.

Mir fällt gerade auf dass ich evtl. im cmd Fenster den Pfad falsch eingegeben habe. Allerdings wenn ich den Befehl über texstudio starte fängt er an zu kompilieren. Aber weiter passiert nichts, keine Fehlermeldung oder irgendwelche Fortschritte. Normalerweise kompiliere ich über texstudio.

Was wäre das einfachste um das Problem zu gehen, wenn der Umlaut den Fehler verursacht? Ein neuen Benutzer anlegen?

Danke Gruß

von u_fischer » Di 10. Apr 2018, 15:15

Dein Dokument kompiliert bei mir ohne Problem und die Fehlermeldung sieht sehr danach aus, als wäre der Umlaut das Problem. Ist denn dein TeXlive in C:\Users\Günter?

von Bartman » Di 10. Apr 2018, 14:49

Eine Bemerkung am Rande: Wenn Du ngerman als Klassenoption setzt, darfst Du die Option an den anderen Stellen entfernen.

Fehlermeldung beim Kompilieren mit makeglossaries

von Varus » Di 10. Apr 2018, 13:15

Hallo zusammen,
da ich ein Abkürzungsverzeichnis benötige bediene ich mich an dem Paket "glossaries". Dabei habe ich mich an die Anleitung aus dem Buch "wissenschaftliche Arbeiten schreiben mit Latex" orientiert.

Ich verwende TexLive mit TexStudio.
Hier kann ich einfach nicht den Befehl "makeglossaries meinbsp" ausführen. Starte ich das in TexStudio, startet es aber es passiert nichts weiter. Führe ich den Befehl via CMD aus kommt folgendes:

Code: Alles auswählen

G:\Latex>makeglossaries 00_Master
makeglossaries version 4.35 (2017-11-14)
added glossary type 'main' (glg,gls,glo)
xindy  -L german -C duden-utf8 -I xindy -M "00_Master" -t "00_Master.glg" -o "00_Master.gls" "00_Master.glo"

*** - PARSE-NAMESTRING: syntax error in filename "C:/Users/G³nter\\" at
      position 10
Wende ich das Paket falsch an? Oder liegt es an dem Umlaut in meinem Namen dass er da Probleme hat? Nach diesem Fehler zu suchen ist schwierig daher habe ich ein neues Topic eröffnet.

Ich danke euch!

Hier mein Minimalbeispiel:

Code: Alles auswählen

\documentclass[a4paper]{scrreprt}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}


\usepackage{amsmath}
\usepackage[ngerman]{varioref}%reihenfolge hier wichtig, ist für Querverweise
\usepackage[ngerman]{hyperref}%vref, cref und ref sind die befehle
\usepackage[ngerman]{cleveref}


\usepackage[xindy,style=tree]{glossaries}
\GlsSetXdyLanguage{german}
\GlsSetXdyCodePage{duden-utf8}
\makeglossaries	
\newacronym{IMU}{IMU}{Inert Measurment Unit}

\begin{document}
\printglossary

 IMU\gls{IMU}	


\end{document}

Gruß

Nach oben