goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 98866
Top-Poster: Johannes_B (5059)

Wir begrüßen unseren neuesten Benutzer LatexGast.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

neue Quellen nicht mehr im Text und im LV angezeigt

 

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 15:26     Titel: neue Quellen nicht mehr im Text und im LV angezeigt
  Antworten mit Zitat      
Hallo zusammen,

ich schreibe gerade meine Masterarbeit in Latex. Bislang hat alles super funktioniert, sowohl das Zitieren als auch das Erstellen des Literaturverzeichnisses.
Heute habe ich jedoch im Citavi (Version 6.3.0.0) drei neue Quellen hinzugefügt. Nach dem Expotieren der .bib-Datei, habe ich die Quellen im Latex mit Hilfe des \cite-Befehls analog meinem vorherigen Vorgehen erwähnt. Ich habe auch keine Einstellungen bei Citavi oder in einem anderen Programm geändert.

Nach dem Erstellen der pdf.-Datei im (TeXstudio 2.12.10 (git 2.12.10)) wurden immer noch die alten Quellen sowohl richtig im Text zitiert, als Zahl in eckigen Klammern als auch richtig im Literaturverzeichnis angezeigt.
Die Quellen, die ich jedoch heute hinzugefügt habe, erkennt jedoch Latex nicht als Quellen und gibt an, dass diese undefinded sind, obwohl sie Teil meiner .bib-Datei sind und auch die gleiche Form aufweisen wie die alten Quellen.
Als MiKTeX Console verwende ich Version 2.9.6972.

Nachdem dieser Fehler aufgetreten ist, habe ich sowohl die MiKTeX Konsole als auch Citavi upgedatet. Es trat jedoch keine Verbesserung ein.

Darum bitte ich euch, mir Eure Ideen mitzuteilen, an was dies liegen könnte.

Vielen Dank im Voraus!

VG Stefan
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 5059
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 15:37     Titel:
  Antworten mit Zitat      
Hast du auch mal F11 gedrückt?
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 15:45     Titel:
  Antworten mit Zitat      
Ja, habe ich auch schon probiert. Hilft leider auch nicht. Immer noch das oben erläuterte Problem. Aber Danke für den Tipp Smile

Die .bib-Datei wird richtig erstellt und ist auch im TexStudio ersichtlich, dass die neuen Quellen enthalten sind, aber diese werden nicht richtig angezeigt, lediglich weiterhin die alten Quellen. Sad
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 5059
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 15:59     Titel:
  Antworten mit Zitat      
was steht in der blg-Datei?
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 16:05     Titel:
  Antworten mit Zitat      
[0] Config.pm:304> INFO - This is Biber 2.12
[0] Config.pm:307> INFO - Logfile is 'MA_Stefan_Linderer_Schriftfassung.blg'
[51] biber-MSWIN64:315> INFO - ===
[153] Biber.pm:371> INFO - Reading 'MA_Stefan_Linderer_Schriftfassung.bcf'
[320] Biber.pm:889> INFO - Found 47 citekeys in bib section 0
[341] Biber.pm:4093> INFO - Processing section 0
[376] Biber.pm:4254> INFO - Looking for bibtex format file 'Bibliothek.bib' for section 0
[390] bibtex.pm:1523> INFO - LaTeX decoding ...
[498] bibtex.pm:1340> INFO - Found BibTeX data source 'Bibliothek.bib'
[516] Utils.pm:193> WARN - Entry 'BundesanstaltfurStraenwesen.01.09.2018' (Bibliothek.bib): Invalid format '01.09.2018' of date field 'date' - ignoring
[635] Utils.pm:193> WARN - Entry 'RE-ING.2017' (Bibliothek.bib): Invalid format 'Dezember 2017' of date field 'date' - ignoring
[658] Utils.pm:193> WARN - Entry 'Geier.2017' (Bibliothek.bib): Invalid format 'bieg' of date field 'urldate' - ignoring
[673] Utils.pm:193> WARN - Entry 'RIZ-ING.2017' (Bibliothek.bib): Invalid format 'Dezember 2017' of date field 'date' - ignoring
[680] Utils.pm:193> WARN - year field '2010-12-01' in entry 'DINEN1990' is not an integer - this will probably not sort properly.
[683] Utils.pm:193> WARN - year field '2010-12-01' in entry 'DINEN1990/NA' is not an integer - this will probably not sort properly.
[686] Utils.pm:193> WARN - year field '2010-12-01' in entry 'DINEN1991-2' is not an integer - this will probably not sort properly.
[690] Utils.pm:193> WARN - year field '2012-08-01' in entry 'DINEN1991-2/NA' is not an integer - this will probably not sort properly.
[693] Utils.pm:193> WARN - year field '2010-12-01' in entry 'DINEN1992-2' is not an integer - this will probably not sort properly.
[696] Utils.pm:193> WARN - year field '2013-04-01' in entry 'DINEN1992-2/NA' is not an integer - this will probably not sort properly.
[703] Utils.pm:193> WARN - Entry 'BEM-ING.2012' (Bibliothek.bib): Invalid format 'Dezember 2012' of date field 'date' - ignoring
[709] Utils.pm:193> WARN - Entry 'RAB-ING.2018' (Bibliothek.bib): Invalid format 'Juni 2018' of date field 'date' - ignoring
[715] Utils.pm:193> WARN - Entry 'ZTV-ING.2018' (Bibliothek.bib): Invalid format 'Januar 2018' of date field 'date' - ignoring
[718] Utils.pm:193> WARN - year field '1999-11-01' in entry 'DIN1076' is not an integer - this will probably not sort properly.
[729] Utils.pm:193> WARN - year field 'Juni 2016' in entry 'Graubner.2016' is not an integer - this will probably not sort properly.
[741] Utils.pm:193> WARN - year field 'Juni 2016' in entry 'SchmidtThro.2016' is not an integer - this will probably not sort properly.
[754] Utils.pm:193> WARN - year field '2017-01-01' in entry 'DINEN206' is not an integer - this will probably not sort properly.
[757] Utils.pm:193> WARN - year field '2008-08-01' in entry 'DIN1045-2' is not an integer - this will probably not sort properly.
[767] Utils.pm:193> WARN - year field '2009-08-01' in entry 'DIN488-1' is not an integer - this will probably not sort properly.
[782] Utils.pm:193> WARN - year field '2017-02-01' in entry 'Fischer.2017' is not an integer - this will probably not sort properly.
[812] Utils.pm:193> WARN - I didn't find a database entry for 'Holst.2013' (section 0)
[852] UCollate.pm:68> INFO - Overriding locale 'de-DE' defaults 'normalization = NFD' with 'normalization = prenormalized'
[852] UCollate.pm:68> INFO - Overriding locale 'de-DE' defaults 'variable = shifted' with 'variable = non-ignorable'
[852] Biber.pm:3921> INFO - Sorting list 'none/global//global/global' of type 'entry' with template 'none' and locale 'de-DE'
[852] Biber.pm:3927> INFO - No sort tailoring available for locale 'de-DE'
[883] bbl.pm:636> INFO - Writing 'MA_Stefan_Linderer_Schriftfassung.bbl' with encoding 'UTF-8'
[902] bbl.pm:739> INFO - Output to MA_Stefan_Linderer_Schriftfassung.bbl
[908] Biber.pm:110> INFO - WARNINGS: 21

Das ist meine blg.Datei. Die Quellen, die mir jedoch Probleme bereiten, sind nicht namentlich erwähnt in dieser Datei...
Danke für die Hilfe.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 17:19     Titel:
  Antworten mit Zitat      
Ist die .blg-Datei tatsächlich kürzlich geschrieben worden oder ist sie laut Änderungsdatum älter (also noch von einem alten Biber-Durchlauf)? Gibt es in der .log-Datei vom LaTeX-Lauf noch andere Meldungen als die über undefined citations? Hast Du einmal probiert, alle temporären Dateien (.aux, .bbl, .bcf, ...) zu löschen und den ganzen Kompilierzyklus LaTeX, Biber, LaTeX, LaTeX neu durchlaufen zu lassen? Bist Du sicher, dass Du die .bib-Datei exportiert hast, die Biber jetzt auch findet (richtiger Dateiname, richtiger Speicherort)? Hast Du manuell mit einem Text-Editor in der .bib-Datei nachgesehen, dass die Einträge darin vorhanden sind (Holst.2013 ist zumindest laut Biber nicht drin)?

Eigentlich sollten alle Quellen in der .bib-Datei grundsätzlich gefunden werden. Wenn das nicht der Fall ist, sollte Biber das explizit erwähnen. Wenn die Quelle gefunden wird aber fehlerhaft ist, sollte das ebenfalls in der .blg-Datei stehen. Es kann auch vorkommen, dass bestimmte Dinge so kaputt sind, das Biber völlig aus dem Konzept kommt, aber dann sollte die .blg-Datei anders aussehen als bei Dir. Zur Zeit spricht eigentlich alles dafür, dass außer Holst.2013 alle angeforderten Quellen vorhanden sind und das auch in einem halbwegs nutzbaren Zustand (die meisten Warnungen in der .blg solltest Du wirklich beheben). Unter den Annahme, dass hier alles mit rechten Dingen zugeht (die .blg also von einem gerade eben ausgeführtem Zyklus LaTeX, Biber, LaTeX, LaTeX kommt), bleibt nur, dass die .tex-Datei die neuen Quellen nicht bei Biber angefordert hat.

Wenn das alles nichts hilft, dann kannst Du versuchen uns ein InfoMinimalbeispiel Deiner problematischen Datei samt .bib-Einträge zu zeigen, aber das kann schwierig werden, da hier nicht klar ist, wo das Problem liegt. Ansonsten würde ich Dir raten, dich an eine LaTeX-Expertin aus Deinem Umfeld zu wenden, die die Möglichkeit hat, direkt an Deinem Computer zu sitzen und zu sehen, was da läuft. Mein Gefühl sagt mir, dass einfach irgendwo ein banaler Fehler im Arbeitsablauf ist, aber der ist aus der Ferne häufig schwer zu diagnostizieren.

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 17:41     Titel:
  Antworten mit Zitat      
Der Tipp war schon mal super. Habe jetzt alle Dateien gelöscht und neu Kopilieren lassen. Jetzt zeigt mir Latex im PDF gar kein Literaturverzeichnis mehr an und erkennt auch die Zitate im Text (Befehl \cite) nicht mehr als solche an.
In der .bib-Datei sind alle Quellen enthalten und auch im Format passt alles.(Das mit Holst.2013 war ein Schreibfehler meinerseits, sollte Holst.2014 sein. Habe diesen Fehler auch gleich noch augebessert.)

Ich habe aber bei den Einstellungen im Citavi und im TEXStudio nichts geändert. Bin gerade etwas ratlos, warum es von den einen auf den anderen Tag nicht mehr funktioniert...

Hier noch ein Auszug aus meiner bib-Datei:

% This file was created with Citavi 6.3.0.0

@phdthesis{Arnold.2008,
author = {Arnold, Andreas},
year = {2008},
title = {Zum Einfluss der Zwangschnittgr{\"o}{\ss}en aus Temperatur bei Tragwerken aus Konstruktionsbeton mit und ohne Vorspannung},
address = {Dortmund},
publisher = {Fakult{\"a}t Bauwesen},
school = {{Technische Universit{\"a}t Dortmund}},
type = {Dissertation}
}


@book{Bauer.1971,
year = {1971},
title = {Ingenieurbauten: Theorie und Praxis},
address = {Wien},
edition = {1},
volume = {1},
publisher = {{Springer-Verlag Wien GmbH}},
series = {Spannbetonbauten - Konstruktion und Herstellung},
editor = {Bauer, Fritz}
}


@article{Baumann.2000,
author = {Baumann, Theodor},
year = {2000},
title = {Vorspannung von Br{\"u}cken: Anwendung interner und externer Spannglieder},
pages = {646--656},
pagination = {page},
volume = {95},
number = {11},
journal = {Beton- und Stahlbetonbau}
}

im Latex habe ich für das Literaturverzeichnis lediglich den Befehl
\printbibliography

Danke für eure Hilfe
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 17:50     Titel:
  Antworten mit Zitat      
Aha! Was sagen denn die .log-Datei vom LaTeX-Lauf und die .blg-Datei von Biber denn jetzt nach einer Runde LaTeX, Biber, LaTeX, LaTeX?

Wenn das Verzeichnis ganz weg bleibt, muss es da einen Grund für geben. Und der Grund muss auch irgendwo von LaTeX oder Biber dargelegt werden.

Die gezeigten Einträge sind der Grund schon mal nicht, sie sind zwar nicht sonderlich schön (wofür kann Biber denn Unicode, wenn man dann doch wieder die ASCII-Escapes von LaTeX nutzt? warum das Explizite pagination = {page},?), aber sie produzieren in einem kleinen Beispiel bei mir weder Warnungen noch Fehler und erscheinen wie erwünscht im Literaturverzeichnis.

Stefan_Linderer
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 20.02.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 18:08     Titel:
  Antworten mit Zitat      
Das Vorgehen habe ich so durchgeführt. Es hat sich aber nichts verändert.

Anbei habe ich die .log-Datei mitgesendet. Eine .blg-Datei liegt mir jetzt komischerweise nicht mehr vor...

In der .log-Datei ist immer der Fehler, dass die Quelle nicht erkannt wurde. Den Grund dafür kann ich aber leider nicht rauslesen..

Danke für die Hilfe.

MA_Stefan_Linderer_Schriftfassung.log
 Beschreibung:

Download
 Dateiname:  MA_Stefan_Linderer_Schriftfassung.log
 Dateigröße:  106.8 KB
 Heruntergeladen:  21 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2019, 18:29     Titel:
  Antworten mit Zitat      
Wenn da keine .blg-Datei ist, dann hast Du entweder Biber gar nicht aufgerufen oder Du hast Biber zwar aufgerufen, aber die Datei ist so kaputt, dass Biber derart daran verschluckt, dass es noch nicht einmal Zeit hat, eine .blg-Datei auch nur anzufangen. Letzteres soll zwar vorgekommen sein, ist aber eher unwahrscheinlich. Selbst wenn Biber fast nichts tut, schreibt es doch meist eine .blg-Datei.

Probier doch mal, die Datei aus der Kommandozeile zu kompilieren, eventuell ist Biber da gesprächiger: https://texwelt.de/wissen/fragen/34.....eaufforderung-im-terminal

Es gibt in Deiner .log-Datei einige Fehlermeldungen, die Du unbedingt beheben solltest. z.B.
Code • Öffne in Overleaf
! LaTeX Error: Command \c@subfigure already defined.
               Or name \end... illegal, see p.192 of the manual.

Das Paket sibfigure, dessen Laden dieses Problem auftreten lässt, ist übrigens als obsolet gekennzeichnet und sollte, wenn etwas in der Art gebraucht wird, durch eine Moderne Alternative wie subcaption oder subfig ersetzt werden. In der Tat scheint Dein Dokument auch subfig zu laden. Also solltest Du subfigure herauswerfen. Genaueres kann ich dazu aber nur mit InfoMinimalbeispiel sagen.

Ansonsten ist das einzige was ich sagen kann, dass auch die .log-Datei suggeriert, dass Biber nicht gelaufen ist, da keine .bbl gefunden wird. Andererseits bricht die .log-Datei nicht so böse oder plötzlich ab, wie es manchmal der Fall ist, wenn die .bcf-Datei nicht mehr geschrieben wird. Einen Hinweis auf das Problem gibt es hier also nicht.

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de