Mathematische Gleichungen anpassen

Schriftbild, Absätze und Auflistungen einstellen
F.S 89
Forum-Anfänger
Forum-Anfänger
Beiträge: 30
Registriert: Fr 24. Mai 2019, 14:18

Mathematische Gleichungen anpassen

Beitrag von F.S 89 »

Hallo liebe Community,

ich schreibe momentan meine Masterarbeit und habe ein Problem mit Formeln.
Leider sieht mein Anhang nicht so schön aus und ich weiß nicht, wie ich den weiter formatieren soll? Ich habe schon alles mögliche versucht. Ich hatte zuerst große Probleme diese langen Formeln mit Zeilenumbrüchen auf Papier zubekommen. Aber so sieht das optisch auch nicht gut aus. Ich würde gerne, dass alle = untereinander stehen. Weiß jemand, wie ich das hinbekomme?
Dateianhänge
latex.JPG
latex.JPG (33.43 KiB) 250 mal betrachtet

Gast

Beitrag von Gast »

Über alle Gleichungen hinweg dürfte das schwierig werden. Aber bei einigen könnten man schon gewisse Verbesserungen herbeiführen. Bei der letzten sollte es einfach sein, die Gleichheitszeichen nach A_t und B_t mit amsmath untereinander zu bringen. Bei der ersten würde ich die rechte Seite in einzelne Termglieder zerlegen und deren + oder - mit Hilfe von amsmath untereinander und am = ausrichten. Bei 72 und 73 geht vermutlich auch etwas. Ohne vorhandenes Minimalbeispiel werde ich aber sicher nicht weiter darüber nachdenken und schon gar nicht anfangen, die Gleichungen abzutippen.

Übrigens halte ich es für vorteilhaft, ein Bild nicht nur anzuhängen, sondern einzubinden:

Bild

F.S 89
Forum-Anfänger
Forum-Anfänger
Beiträge: 30
Registriert: Fr 24. Mai 2019, 14:18

Beitrag von F.S 89 »

Danke,

ich hoffe das hier ist mit einem Minimalbeispiel gemeint?
Dateianhänge
anhang.tex
(12.09 KiB) 31-mal heruntergeladen

Bartman
Forum-Meister
Forum-Meister
Beiträge: 2116
Registriert: Do 16. Jul 2009, 21:41
Wohnort: Hessische Provinz

Beitrag von Bartman »

Mal abgesehen davon, dass das angehängte Beispiel den Inhalt der Abbildung deutlich übersteigt, läuft es außerdem auch nicht fehlerfrei durch. Du nennst in Deiner Beschreibung aber keine Fehlermeldungen.

Gast

Beitrag von Gast »

F.S 89 hat geschrieben:ich hoffe das hier ist mit einem Minimalbeispiel gemeint?
Nein und das weißt du auch, wenn du die aus gutem Grund verlinkte Anleitung gelesen hast.

oft gesehener

Off-Topic: Problematische und wenig sinnvolle Vorlage

Beitrag von oft gesehener »

Der angehängte (statt korrekt eingebundene) Code enthält übrigens vielen, das man besser nicht machen sollte. Schon das seit Jahrzehnten ziemlich überholte \usepackage[latin1]{inputenc} sieht nach einer mehr als verstaubten LaTeX-Vorlage aus. Dazu kommen Pakete, die eindeutig gar nicht verwendet werden, und andere, die total veraltet sind. Und auch Einstellungen, die einfach nur Unfug sind, sind enthalten.

F.S 89
Forum-Anfänger
Forum-Anfänger
Beiträge: 30
Registriert: Fr 24. Mai 2019, 14:18

Beitrag von F.S 89 »

Der angehängte (statt korrekt eingebundene) Code enthält übrigens vielen, das man besser nicht machen sollte. Schon das seit Jahrzehnten ziemlich überholte \usepackage[latin1]{inputenc} sieht nach einer mehr als verstaubten LaTeX-Vorlage aus. Dazu kommen Pakete, die eindeutig gar nicht verwendet werden, und andere, die total veraltet sind. Und auch Einstellungen, die einfach nur Unfug sind, sind enthalten.
Hallo, ja das kann gut sein. Das ist die Vorlage des Instituts, die wir benutzen sollen. \usepackage[latin1]{inputenc} lösche ich raus. Und die anderen versuche ich upzudaten.

Gast

Beitrag von Gast »

F.S 89 hat geschrieben:\usepackage[latin1]{inputenc} lösche ich raus.
Einfach rauslöschen ist wahrscheinlich keine gute Idee. Man muss dann schon dafür sorgen, dass auch wirklich alle Dateien UTF-8-codiert sind. Sonst gibt das neue Probleme. Die Hilfsdateien sollte man bei so einer Aktion auch alle löschen.

Und natürlich wäre es schön, wenn sich mal jemand trauen würde, dem für die Vorlage verantwortlichen Menschen zu sagen, dass das eine Sammlung von Halbwissen und teXnischen und typografischen Fehlern ist. Sonst werden noch Generationen an Studenten und wir bis in alle Ewigkeit damit gequält.

F.S 89
Forum-Anfänger
Forum-Anfänger
Beiträge: 30
Registriert: Fr 24. Mai 2019, 14:18

Beitrag von F.S 89 »

Bartman hat geschrieben:Mal abgesehen davon, dass das angehängte Beispiel den Inhalt der Abbildung deutlich übersteigt, läuft es außerdem auch nicht fehlerfrei durch. Du nennst in Deiner Beschreibung aber keine Fehlermeldungen.
Das stimmt es kommen einige ganze Reihe von Fehlermeldungen, die ich bis jetzt noch nicht beseitigen konnte. Ich versuche die nach und nach zu beheben.

Da, ich jetzt feststellen musste, das die Vorlage nicht mehr up to date ist, weiss ich leider nicht, welche packages rausmüssen und welche ich ersetzen muss. Ich kann nur noch den Code hier reinposten.

Code: Alles auswählen

\begin{document}
    \pagenumbering{Roman}
Plugging in
\newline
\begin{align}
\begin{split}
x_t&=\frac{\sigma-\delta_x}{\sigma}(\omega^{x,ext}_t(1+\alpha_x))x_t +(\omega^{x,sta}_t-\alp\omega^{x,ext})x_{t-1}
&+\frac{1-\delta_\pi}{\sigma}(\omega^{\pi, ext}_t(1+\alpha_\pi))\pi_t 
&+(\omega^{\pi,sta}_t - \alpha_\pi\omega^{\pi,ext}_t)\pi_{t-1}-\frac{k}{\sigma}+u_t
\end{split}
\end{align}
\newline
After rearranging
\begin{align}
(1-\beta\omega^{\pi,ext}_t(1+\alpha_\pi))\pi_t- \gamma x_t &= \beta(\omega^{\pi,sta}_t -\alpha_\pi\omega^{\pi,ext})\pi_{t-1} +v_t
\end{align}
\begin{align}
\begin{split}
x_t-(\frac{\sigma-\delta_x}{\sigma})(\omega^{x,ext}_t(1+\alpha_x))x_t
-\frac{1-\delta_\pi}{\sigma}(\omega^{\pi,ext}_t(1+\alpha_\pi))\pi_t &=\frac{\sigma-\delta_x}{\sigma}(\omega^{x,sta}_t-\alpha_x\omega^{x,ext}_t)x_{t-1}
&+(\frac{1-\delta_\pi}{\sigma})(\omega^{\pi,sta}_t-\alpha\pi^{\pi,sta})\pi_{t-1}-\frac{k}{\sigma} +v_t
\end{split}
\end{align}
\begin{align}
\begin{split}
(1-(\frac{\sigma-\delta_x}{\sigma})(\omega^{x,sta}_t-\alpha_x\omega^{x,ext})x_t -\frac{1-\delta_\pi}{\sigma}(\omega^{x,ext}_t(1+\alpha_\pi)\pi_t &=\frac{\sigma-\delta_x}{\sigma}(\omega^{x,sta}_t-\alpha_x\omega^{x,ext}_t)x_{t-1}
&+(\frac{1-\delta_\pi}{\sigma})(\omega^{\pi,sta}_t-\alpha\pi^{\pi,sta})\pi_{t-1}-\frac{k}{\sigma} +v_t
\end{split}
\end{align}
\begin{align}
\begin{split}
(\sigma-(\sigma-\delta_x)(\omega^{x,sta}_t(1+\alpha_x))x_t-(1-\delta_\pi)(\omega^{\pi,ext}_t+(1+\alpha_\pi))\pi_t 
&=\sigma-\sigma_x(\omega^{x,sta}_t-\alpha_x\omega^{x,ext}_t)x_{t-1} 
&+(1-\delta_\pi)(\omega^{\pi,sta}_t-\alpha_\pi\omega^{\pi,ext})\pi_{t-1}- k + u_t\sigma
\end{split}
\end{align}
\newline
and the \textit{time independent} matrices
\begin{equation}    \label{eq:Matrix}
 \bm{A}_t =
 \begin{bmatrix} 
 1 - \beta\omega^{\pi, ext}_t(1 + \alpha_\pi) &  -\gamma \\
  -(1-\delta\pi)(\omega^{\pi,ext}(1+\alpha_\pi))&\sigma-(\sigma-\delta_x)(\omega^{x,ext}_t(1+\alpha_x))\\
 \end{bmatrix}
$ 
$ \bm{B}_t =
  \begin{bmatrix}
  \beta(\omega^{\pi, sta}_t -\alpha_\pi \omega^{\pi, ext}_t) & 0 \\
 (\omega^{\pi, sta}_t  - \alpha_\pi \omega^{\pi, ext}_t) & \sigma(\omega^{\pi, sta}_t - \alpha_x \omega^{\pi, ext}_t) \\
$$\end{bmatrix}
$ \end{equation}
\newline
\newline
\newline
Multiplying with $A^{-1}$ we derive the solution:
\newline
\begin{equation}   \label{eq:SolutionBRD}
   \begin{bmatrix}  
       \pi_t\\
         x_t \\
         \end{bmatrix}
         = \bm{A}_t^{-1} \bm{B}_t  \begin{bmatrix} 
   \pi_{t-1}\\
         x_{t-1} \\      
   \end{bmatrix}
   + \bm{A}_t^{-1} 
    \begin{bmatrix} 
      \upsilon_t\\
         \sigma u_t -k_t
       \end{bmatrix}
\end{equation}
\newline
\end{document}

Gast

Beitrag von Gast »

F.S 89 hat geschrieben:[Da, ich jetzt feststellen musste, das die Vorlage nicht mehr up to date ist, weiss ich leider nicht, welche packages rausmüssen und welche ich ersetzen muss.
Genau dafür gibt es die Minimalbeispiel-Anleitung. Es ist wirklich nicht unsere Aufgabe, das ganze erst einmal lauffähig zu machen. Auch wenn es vielleicht schwer zu glauben ist, wir haben auch noch ein Leben neben LaTeX.

Antworten