goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 95742
Top-Poster: Johannes_B (5030)

Wir begrüßen unseren neuesten Benutzer Librr.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

LuaLaTeX pgfplots externalisieren .md5 Datei zu klein Bug?

 

davidgrill's
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 22.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.01.2019, 22:49     Titel: LuaLaTeX pgfplots externalisieren .md5 Datei zu klein Bug?
  Antworten mit Zitat      
Guten Tag,

ich bin auf ein seltsames Verhalten gestoßen, was ich mir nur durch einen Bug erklären kann, oder vlt. hat ja jemand eine Idee, woran es liegen könnte.

Ich plotte eine Kurve aus matlab2tikz mit pgfplots.
Dies klappt alles ganz normal mit LuaLaTeX.
Nur wenn ich es externalisiere, bekomme ich: "mit Rückgabewert 1 beendet".

Die Log-Datei des Hauptdokumts endet dann mit:
Code • Öffne in Overleaf

! Package tikz Warning: The key 'up to date check=md5' is impossible, there is
no macro to compute MD5. Falling back to 'up to date check=diff'.
 

Lustigerweise klappt es auch wieder mit LuaLaTeX, wenn ich nur einen Messpunkt von meinen 8656 entferne.

Die .md5 -Datei wechselt auch in diesem Schritt von 200,0 kB auf 199,9 kB.


Für pdfLaTeX ist die Datei zu groß. Lösche ich ein paar Punkte gehts dann irgendwann. Die md5-Datei sieht aber auch ganz anders aus als bei LuaLaTeX.
Dies ist alles, was pdfLaTeX reinschreibt:
Code • Öffne in Overleaf

"\def \tikzexternallastkey {CDC8385E1C4D64BFE5AFFF34034A55D2}%"
 


LuaLaTeX beginnt so:
Code • Öffne in Overleaf

\begingroup \toks 0={macro:-> \begin {axis} \addplot table[row sep=crcr]{0.00158079699940572 0\\ 142.183864004999 0\\
 


und endet so:

Code • Öffne in Overleaf

... 162.871961252 2518.5\\ 162.876961059999 2515.5\\ }; \end {axis} }\xdef \tikzexternallastkey {\the \toks 0 }\endgroup %
 


Dazwischen sind einfach alle Punkte.

Kann es also daran liegen, dass die md5-Datei nur bis 200kB groß sein kann?

Aber das kann ja so nicht gedacht sein...

Weiß da jemand weiter?

Grüße

David




Code • Öffne in Overleaf

\documentclass{scrbook}
\usepackage{pgfplots}
\usetikzlibrary{external}
\tikzexternalize[mode=list and make]
\begin{document}
  \input{plot.tex}
\end{document}
 


Datei plot.tex:

Code • Öffne in Overleaf

\begin{tikzpicture}
\begin{axis}
\addplot
  table[row sep=crcr]{%
0.00158079699940572   0\\
142.183864004999   0\\
....
162.871961252   2518.5\\
162.876961059999   2515.5\\
};
\end{axis}
\end{tikzpicture}%
 


plot.tex
 Beschreibung:

Download
 Dateiname:  plot.tex
 Dateigröße:  203.68 KB
 Heruntergeladen:  14 mal
minimalbeispiel.tex
 Beschreibung:

Download
 Dateiname:  minimalbeispiel.tex
 Dateigröße:  160 Bytes
 Heruntergeladen:  11 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 07:42     Titel:
  Antworten mit Zitat      
Bei mir funktioniert das einwandfrei. Die md5-Datei hat den Inhalt:
Code • Öffne in Overleaf
\def \tikzexternallastkey {AFEB80F4EE2787ED9C9A439253FBF241}%
und das Ergebnis sieht auch gut aus. Fehlermeldung gibt es keine, Warnung nur:
Code • Öffne in Overleaf
Package pgfplots Warning: running in backwards compatibility mode (unsuitable tick labels; missing features). Consider writing \pgfplotsset{compat=1.16} into your preamble.
 on input line 6.
Und die war wegen der fehlenden compat-Angabe zu erwarten.

Natürlich muss man wegen der Option zwischen den beiden lualatex-Aufrufen einmal make -f minimalbeispie.makefile aufrufen.

Verwendet wird bei mir:
Code • Öffne in Overleaf
 *File List*
 scrbook.cls    2018/12/30 v3.26a KOMA-Script document class (book)
scrkbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-dependent bas
ics and keyval usage)
 scrbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-independent b
asics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2018/12/30 v3.26a KOMA-Script package (loading files)
tocbasic.sty    2018/12/30 v3.26a KOMA-Script package (handling toc-files)
scrsize11pt.clo    2018/12/30 v3.26a KOMA-Script font size class option (11pt)
typearea.sty    2018/12/30 v3.26a KOMA-Script package (type area)
pgfplots.sty    2018/03/28 v1.16 Data Visualization (1.16)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  luatex.def    2018/01/08 v1.0l Graphics/color driver for luatex
    tikz.sty    2019/01/05 v3.1 (3.1)
     pgf.sty    2019/01/05 v3.1 (3.1)
  pgfrcs.sty    2019/01/05 v3.1 (3.1)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
 pgfcore.sty    2019/01/05 v3.1 (3.1)
  pgfsys.sty    2019/01/05 v3.1 (3.1)
  pgfsys.code.tex
pgfsyssoftpath.code.tex    2019/01/05 v3.1 (3.1)
pgfsysprotocol.code.tex    2019/01/05 v3.1 (3.1)
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
 pgfcore.code.tex
pgfcomp-version-0-65.sty    2019/01/05 v3.1 (3.1)
pgfcomp-version-1-18.sty    2019/01/05 v3.1 (3.1)
  pgffor.sty    2019/01/05 v3.1 (3.1)
 pgfkeys.sty    
 pgfkeys.code.tex
 pgfmath.sty    
 pgfmath.code.tex
  pgffor.code.tex
    tikz.code.tex
pdftexcmds.sty    2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
   ifpdf.sty    2018/09/07 v3.3 Provides the ifpdf switch
atveryend.sty    2016/05/16 v1.9 Hooks at the very end of document (HO)
supp-pdf.mkii
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
epstopdf-sys.cfg    2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Live
plot.tex
 ***********

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3817
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 10:59     Titel:
  Antworten mit Zitat      
Man bekommt eine derartige md5-Datei, wenn man den diff-Modus erzwingt:

\tikzexternalize[up to date check = diff]

Und da das Dateien mit sehr langen Zeilen erzeugt, kann es sicher irgendwann explodieren.

Der diff-Modus sollte aber normalerweise bei lualatex nicht aktiviert werden. Du solltest daher die log-Datei und die Dateiversionen überprüfen.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 11:28     Titel:
  Antworten mit Zitat      
Die md5-Datei sieht bei mir mit pdfLaTeX, LuaLaTeX und XeLaTeX gleich aus, immer enthält sich wirklich nur einen MD5-Hash. Ich würde auch auf ein Versionproblem tippen. Möglicherweise hast Du eine recht alte LuaLaTeX- oder TikZ-Version, bei der TikZ in LuaTeX nicht auf die Hash-Funktion zugreifen kann.

Bei mir läuft laut \listfiles zu Beginn des Dokuments
Code • Öffne in Overleaf
 *File List*
 scrbook.cls    2018/12/30 v3.26a KOMA-Script document class (book)
scrkbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-dependent ba
sics and keyval usage)
 scrbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-independent
basics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2018/12/30 v3.26a KOMA-Script package (loading files)
tocbasic.sty    2018/12/30 v3.26a KOMA-Script package (handling toc-files)
scrsize11pt.clo    2018/12/30 v3.26a KOMA-Script font size class option (11pt)
typearea.sty    2018/12/30 v3.26a KOMA-Script package (type area)
pgfplots.sty    2018/03/28 v1.16 Data Visualization (1.16)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  luatex.def    2018/01/08 v1.0l Graphics/color driver for luatex
    tikz.sty    2019/01/05 v3.1 (3.1)
     pgf.sty    2019/01/05 v3.1 (3.1)
  pgfrcs.sty    2019/01/05 v3.1 (3.1)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
 pgfcore.sty    2019/01/05 v3.1 (3.1)
  pgfsys.sty    2019/01/05 v3.1 (3.1)
  pgfsys.code.tex
pgfsyssoftpath.code.tex    2019/01/05 v3.1 (3.1)
pgfsysprotocol.code.tex    2019/01/05 v3.1 (3.1)
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
 pgfcore.code.tex
pgfcomp-version-0-65.sty    2019/01/05 v3.1 (3.1)
pgfcomp-version-1-18.sty    2019/01/05 v3.1 (3.1)
  pgffor.sty    2019/01/05 v3.1 (3.1)
 pgfkeys.sty    
 pgfkeys.code.tex
 pgfmath.sty    
 pgfmath.code.tex
  pgffor.code.tex
    tikz.code.tex
pdftexcmds.sty    2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
   ifpdf.sty    2018/09/07 v3.3 Provides the ifpdf switch
atveryend.sty    2016/05/16 v1.9 Hooks at the very end of document (HO)
supp-pdf.mkii
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
    plot.tex
 ***********

auf lualatex --credits
Code • Öffne in Overleaf
This is LuaTeX, Version 1.09.0 (MiKTeX 2.9.6930 64-bit)

The LuaTeX team is Hans Hagen, Hartmut Henkel, Taco Hoekwater, Luigi Scarso.

LuaTeX merges and builds upon (parts of) the code from these projects:

tex       : Donald Knuth
etex      : Peter Breitenlohner, Phil Taylor and friends
omega     : John Plaice and Yannis Haralambous
aleph     : Giuseppe Bilotta
pdftex    : Han The Thanh and friends
kpathsea  : Karl Berry, Olaf Weber and others
lua       : Roberto Ierusalimschy, Waldemar Celes and Luiz Henrique de Figueiredo
metapost  : John Hobby, Taco Hoekwater, Luigi Scarso, Hans Hagen and friends
pplib     : Paweł Jackowski
fontforge : George Williams (partial)
luajit    : Mike Pall (used in LuajitTeX)

Compiled with libpng 1.6.35; using 1.6.35
Compiled with lua version 5.2.4
Compiled with mplib version 2.00
Compiled with zlib 1.2.11; using 1.2.11

Development id: 6980

using bzip2 version 1.0.6, 6-Sept-2010
compiled with curl version 7.61.1; using libcurl/7.61.1 WinSSL
compiled with expat version 2.2.6; using expat_2.2.6
compiled with liblzma version 50020042; using 50020042
compiled with libressl version LibreSSL 2.8.2; using LibreSSL 2.8.2
compiled with MiKTeX Application Framework version 4.6930; using 4.6930
compiled with MiKTeX Core version 10.6944; using 10.6944
compiled with MiKTeX Archive Extractor version 1.6882; using 1.6882
compiled with MiKTeX Package Manager version 5.6938; using 5.6938
compiled with uriparser version 0.8.6
compiled with zlib version 1.2.11; using 1.2.11


Ich finde es überraschend, dass gerade LuaLaTeX bei einem zu großen String in die Knie gehen sollte. Aber irgendwann ist halt Sense. Schließlich versucht LuaLaTeX bei Dir ja, den gesamten Inhalt von plot.tex in ein Makro zu propfen.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 11:44     Titel:
  Antworten mit Zitat      
Aha! Ich habe bei mir mal folgendes ausprobiert: In einem neuen Ordner habe ich eine leere Datei namens pdftexmcds.sty erstellt. Damit findet LaTeX dann nicht mehr das echte Paket pdftexcmds sondern nur noch einen leeren Fake.

Da das Paket pdftexcmds unter LuaLaTeX unter anderem die Funktion für MD5-Hashes zur Verfügung stellt, kann LuaLaTeX up to date check=md5 dann nicht mehr durchführen. Und in der Tat, prompt kommt vom Minimalbeispiel die zitierte Meldung
Code • Öffne in Overleaf
Package tikz Warning: The key 'up to date check=md5' is impossible,
there is no macro to compute MD5. Falling back to 'up to date check=diff'.

Für den Fall, dass LuaLaTeX bereits eine .md5 mit dem langen Inhalt
Code • Öffne in Overleaf
\begingroup \toks 0={macro:-> \begin {axis} \addplot table[row sep=crcr]{0.00158079699940572 0\\ 142.183864004999 0\\

erstellt hat, erhalte ich dann die Meldung
Code • Öffne in Overleaf
Unable to read an entire line---bufsize=200000.
Please increase buf_size in texmf.cnf.

der Speicher zum Lesen der Datei ist in der Tat zu klein und liegt bei den 200kB, die Du als Grenze experimentell herausgefunden hast. Das Problem tritt übrigens nur auf, weil die ganzen 200kB in der ".md5"-Datei in einer Zeile stehen, wenn man da ein paar Zeilenumbrüche einfügt, kann die Datei wieder gelesen werden.

Mann kann den bufsize erhöhen: https://tex.stackexchange.com/q/43430/35864

Da aber auch LuaLaTeX mit pdftexmcds die wesentlich komfortablere Methode mit MD5 kann, solltest Du Dein Augenmerk eher darauf richten, warum das bei Dir nicht geht. Und da würde ich wie in meinem vorherigen Beitrag auf alte Versionen tippen.

davidgrill's
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 22.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 12:59     Titel:
  Antworten mit Zitat      
Vielen Dank für die vielen Ratschläge, echt klasse! Smile

Immer diese Paketversionenmist...

ich hatte tatsächlich einige alte Paket in Verwendung:

Code • Öffne in Overleaf

 *File List*
 scrbook.cls    2018/12/30 v3.26a KOMA-Script document class (book)
scrkbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-dependent bas
ics and keyval usage)
 scrbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-independent b
asics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2018/12/30 v3.26a KOMA-Script package (loading files)
tocbasic.sty    2018/12/30 v3.26a KOMA-Script package (handling toc-files)
scrsize11pt.clo    2018/12/30 v3.26a KOMA-Script font size class option (11pt)
typearea.sty    2018/12/30 v3.26a KOMA-Script package (type area)
pgfplots.sty    2018/03/28 v1.16 Data Visualization (1.16)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  luatex.def    2018/01/08 v1.0l Graphics/color driver for luatex
    tikz.sty    2015/08/07 v3.0.1a (rcs-revision 1.151)
     pgf.sty    2008/01/15 v3.0.1a (rcs-revision 1.12)
  pgfrcs.sty    2015/08/07 v3.0.1a (rcs-revision 1.31)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
 pgfcore.sty    2010/04/11 v3.0.1a (rcs-revision 1.7)
  pgfsys.sty    2014/07/09 v3.0.1a (rcs-revision 1.4Cool
  pgfsys.code.tex
pgfsyssoftpath.code.tex    2013/09/09  (rcs-revision 1.9)
pgfsysprotocol.code.tex    2006/10/16  (rcs-revision 1.4)
  xcolor.sty    2007/01/21 v2.11 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
 pgfcore.code.tex
pgfcomp-version-0-65.sty    2007/07/03 v3.0.1a (rcs-revision 1.7)
pgfcomp-version-1-18.sty    2007/07/23 v3.0.1a (rcs-revision 1.1)
  pgffor.sty    2013/12/13 v3.0.1a (rcs-revision 1.25)
 pgfkeys.sty    
 pgfkeys.code.tex
  pgffor.code.tex
    tikz.code.tex
supp-pdf.mkii
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
pdftexcmds.sty    2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2018/09/07 v3.3 Provides the ifpdf switch
epstopdf-sys.cfg    2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Live
    plot.tex
 ***********

)
 


Ich habe diese aktuallisiert:

Code • Öffne in Overleaf


 *File List*
 scrbook.cls    2018/12/30 v3.26a KOMA-Script document class (book)
scrkbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-dependent bas
ics and keyval usage)
 scrbase.sty    2018/12/30 v3.26a KOMA-Script package (KOMA-Script-independent b
asics and keyval usage)
  keyval.sty    2014/10/28 v1.15 key=value parser (DPC)
scrlfile.sty    2018/12/30 v3.26a KOMA-Script package (loading files)
tocbasic.sty    2018/12/30 v3.26a KOMA-Script package (handling toc-files)
scrsize11pt.clo    2018/12/30 v3.26a KOMA-Script font size class option (11pt)
typearea.sty    2018/12/30 v3.26a KOMA-Script package (type area)
pgfplots.sty    2018/03/28 v1.16 Data Visualization (1.16)
graphicx.sty    2017/06/01 v1.1a Enhanced LaTeX Graphics (DPC,SPQR)
graphics.sty    2017/06/25 v1.2c Standard LaTeX Graphics (DPC,SPQR)
    trig.sty    2016/01/03 v1.10 sin cos tan (DPC)
graphics.cfg    2016/06/04 v1.11 sample graphics configuration
  luatex.def    2018/01/08 v1.0l Graphics/color driver for luatex
    tikz.sty    2019/01/05 v3.1 (3.1)
     pgf.sty    2019/01/05 v3.1 (3.1)
  pgfrcs.sty    2019/01/05 v3.1 (3.1)
everyshi.sty    2001/05/15 v3.00 EveryShipout Package (MS)
  pgfrcs.code.tex
 pgfcore.sty    2019/01/05 v3.1 (3.1)
  pgfsys.sty    2019/01/05 v3.1 (3.1)
  pgfsys.code.tex
pgfsyssoftpath.code.tex    2019/01/05 v3.1 (3.1)
pgfsysprotocol.code.tex    2019/01/05 v3.1 (3.1)
  xcolor.sty    2016/05/11 v2.12 LaTeX color extensions (UK)
   color.cfg    2016/01/02 v1.6 sample color configuration
 pgfcore.code.tex
pgfcomp-version-0-65.sty    2019/01/05 v3.1 (3.1)
pgfcomp-version-1-18.sty    2019/01/05 v3.1 (3.1)
  pgffor.sty    2019/01/05 v3.1 (3.1)
 pgfkeys.sty    
 pgfkeys.code.tex
  pgffor.code.tex
    tikz.code.tex
supp-pdf.mkii
epstopdf-base.sty    2016/05/15 v2.6 Base part for package epstopdf
infwarerr.sty    2016/05/16 v1.4 Providing info/warning/error messages (HO)
  grfext.sty    2016/05/16 v1.2 Manage graphics extensions (HO)
kvdefinekeys.sty    2016/05/16 v1.4 Define keys (HO)
 ltxcmds.sty    2016/05/16 v1.23 LaTeX kernel commands for general use (HO)
kvoptions.sty    2016/05/16 v3.12 Key value format for package options (HO)
kvsetkeys.sty    2016/05/16 v1.17 Key value parser (HO)
etexcmds.sty    2016/05/16 v1.6 Avoid name clashes with e-TeX commands (HO)
ifluatex.sty    2016/05/16 v1.4 Provides the ifluatex switch (HO)
pdftexcmds.sty    2018/09/10 v0.29 Utility functions of pdfTeX for LuaTeX (HO)
   ifpdf.sty    2018/09/07 v3.3 Provides the ifpdf switch
epstopdf-sys.cfg    2010/07/13 v1.3 Configuration of (r)epstopdf for TeX Live
    plot.tex
 ***********

)
 


Jedoch Fliegt mir jetzt die pgf.sty um die Ohren.

Code • Öffne in Overleaf

(/usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/pgf/compatibility/pgfcom
p-version-0-65.sty

LaTeX Warning: You have requested package `pgfcomp-version-0-65',
               but the package provides `['.

Package: [ 2019/01/05 v3.1 (3.1)

! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                 
l.12 \ProvidesPackageRCS[v
                        \pgfversion
] $Header: /cvsroot/pgf/pgf/latex/pgf/com...
You're in trouble here.  Try typing  <return>  to proceed.
If that doesn't work, type  X <return>  to quit.

\pgf@nodesepstart=\dimen140
\pgf@nodesepend=\dimen141
)
(/usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/pgf/compatibility/pgfcom
p-version-1-18.sty

LaTeX Warning: You have requested package `pgfcomp-version-1-18',
               but the package provides `['.

Package: [ 2019/01/05 v3.1 (3.1)

! LaTeX Error: Missing \begin{document}.

See the LaTeX manual or LaTeX Companion for explanation.
Type  H <return>  for immediate help.
 ...                                              
                                                 
l.12 \ProvidesPackageRCS[v
                        \pgfversion
] $
Header: /cvsroot/pgf/pgf/latex/pgf/com...
You're in trouble here.  Try typing  <return>  to proceed.
If that doesn't work, type  X <return>  to quit.

))
 


minimalbeispiel.log
 Beschreibung:

Download
 Dateiname:  minimalbeispiel.log
 Dateigröße:  35.25 KB
 Heruntergeladen:  9 mal
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3817
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 14:07     Titel:
  Antworten mit Zitat      
Du hast offensichtlich veraltete lokale pgf-Dateien in usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/pgf (und vielleicht an anderen Orten, checke die log-Datei). Entferne die alle.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 14:13     Titel:
  Antworten mit Zitat      
Die neuen Paketversionen sehen besser aus. Auch pdftexcmds wird in einer aktuellen Version geladen. Damit solltest Du MD5-Hashes bekommen.

Wie hast Du denn das Update gemacht? In der .log-Datei ist zu sehen, dass die meisten Pakete aus /usr/local/texlive/2018/texmf-dist/tex/latex/ kommen, wie ich es von TeX live 2018 erwarten würde. Ein paar Dateien darunter auch pgf.sty aber nicht alle Bestandteile von PGF/TikZ, liegen aber in /usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/. Wenn da unterschiedliche Versionen liegen, könnte das Scherben geben. Die Frage ist auch, wie die Dateien da hingekommen sind. Ich habe gerade auf meinem Vanilla TeX live 2018 auf Ubuntu 18.04 nachgesehen: Da gibt es /usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/ nicht.

davidgrill's
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 22.12.18
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2019, 14:57     Titel:
  Antworten mit Zitat      
Ah, spitze!
Danke Leute.

Ich habe ein tlmgr update --all durchgeführt.

Aber scheinbar hab ich noch Reste von einer Ubuntu Paketinstallation auf dem Rechner.

Nachdem ich den Ordner /usr/local/texlive/texmf-local/tex/UbuntuTexDir/latex/ entfernt habe, klappt alles wie gewünscht.

Besten Dank.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de