goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 101733
Top-Poster: Johannes_B (5072)

Wir begrüßen unseren neuesten Benutzer DoDo1896.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Literaturverzeichnis will nicht

 

mato37
Forum-Anfänger
Forum-Anfänger

Beiträge: 11
Anmeldedatum: 27.02.20
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.02.2020, 19:20     Titel: Literaturverzeichnis will nicht
  Antworten mit Zitat      
Moin liebes Forum,

ich habe ein kleines Problem mit meinem Literaturverzeichnis und zwar wird es mir nicht angezeigt, obwohl ich keine Fehler sehe ...
Vielleicht seht ihr ja welche?

Den Bibstyle usw habe ich in der Main folgender Maßen definiert

Code


%bibstyle
\usepackage[style=authoryear-comp, maxbibnames=9, maxcitenames=2, backend=biber]{biblatex}
\DefineBibliographyStrings{ngerman}{andothers = {{et\al\adddot}},} %macht aus u.a. et al.
\addbibresource{lit.bib}
\renewcommand*{\nameyeardelim}{\addcoma\space}

 


Hier ein kleiner Auszug aus meiner lit.bib

Code
% QUELLE 4

%Infos zur Panke

@ONLINE {Panke,
    author = {M. Wielinski
},
    title  = {Panke 2015},
    year   = {2009},
    url    = {https://berlin.nabu.de/stadt-und-natur/naturschutz-berlin/gewaesserschutz/wasserrahmenrichtlinie/index.html}
}

%Quelle 5

%Gewässertyp Panke

@ONLINE {UBA_ZUST,
    author = Umweltbundesamt Abteilung II 2, J. Arle, K. Blondzik, U. Claussen, A. Duffek, S. Grimm, F. Hilliges, B. Kirschbaum, I. Kirst, D. Koch, J. Koschorreck, P. Lepom, W. Leujak, V. Mohaupt, S. Naumann, U. Pirntke, J. Rechenberg, P. Schilling, A. Ullrich, J. Wellmitz, S. Werner, R. Wolter,
    title  = Gewässer in Deutschland: Zustand und Bewertung,
    month  = aug,
    year   = 2017",
    url    = "https://isis.tu-berlin.de/pluginfile.php/1423882/mod_resource/content/1/UBA_upload.pdf"
}


Zitiert habe ich mit \cite{MDPI} und eingefügt habe ich das Literaturverzeichnis mit \printbibliography, wobei er mir in der Zeile sagt, dass er keine Bibliography hat (empty).

Vielen Dank schonmal für eure Hilfe!

ps: im Anhang habe ich noch meine Main und die lit.bib eingebunden

VG Malte

main.txt
 Beschreibung:

Download
 Dateiname:  main.txt
 Dateigröße:  2.23 KB
 Heruntergeladen:  10 mal
lit.txt
 Beschreibung:

Download
 Dateiname:  lit.txt
 Dateigröße:  4.08 KB
 Heruntergeladen:  8 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.02.2020, 19:39     Titel:
  Antworten mit Zitat      
Die gezeigte Quelle 4 dürfte in Ordnung sein, bei der gezeigten Quelle 5 fehlt aber die komplette Klammerung der Werte. Wenn das in der echten Datei genauso ist, ist es kein Wunder, wenn es nicht funktioniert. In der blg-Datei dürften dann auch durchaus Fehler dazu gemeldet werden.

Bartman
Forum-Meister
Forum-Meister


Beiträge: 2084
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 27.02.2020, 19:47     Titel:
  Antworten mit Zitat      
Die Autorennamen werden nicht durch and getrennt. Bei \addcoma und \al gibt es Tippfehler.
Private Nachricht senden Benutzer-Profile anzeigen

mato37
Forum-Anfänger
Forum-Anfänger

Beiträge: 11
Anmeldedatum: 27.02.20
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.02.2020, 19:49     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:
Die gezeigte Quelle 4 dürfte in Ordnung sein, bei der gezeigten Quelle 5 fehlt aber die komplette Klammerung der Werte. Wenn das in der echten Datei genauso ist, ist es kein Wunder, wenn es nicht funktioniert. In der blg-Datei dürften dann auch durchaus Fehler dazu gemeldet werden.


Hey,
danke für deine Antwort! Das war tatsächlich die einzige Quelle, bei der ich das vergessen hatte zu korrigieren.
Habe es jetzt berichtigt und schwupps hat es geklappt.

Kann ich irgendwie noch ein Leerzeichen zwischen die Quellenangaben bekommen?

Danke für deine Hilfe Smile
Private Nachricht senden Benutzer-Profile anzeigen

mato37
Forum-Anfänger
Forum-Anfänger

Beiträge: 11
Anmeldedatum: 27.02.20
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.02.2020, 20:02     Titel:
  Antworten mit Zitat      
Bartman hat Folgendes geschrieben:
Die Autorennamen werden nicht durch and getrennt. Bei \addcoma und \al gibt es Tippfehler.


Wo genau sind die Tippfehler?
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 2084
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: ---
     Beitrag Verfasst am: 27.02.2020, 20:09     Titel:
  Antworten mit Zitat      
Den ersten Befehl kannst Du mithilfe der Paketdokumentation selbst berichtigen. Außerdem darfst Du bei einer aktuellen Version des Pakets biblatex für diese Einstellung den Befehl \DeclareDelimFormat nutzen.

Im zweiten Fall meinst du wahrscheinlich et\ al\adddot. Für die Zuweisung an die Option andothers gibt es nicht nur in diesem Forum reichlich Beispiele.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2020 goLaTeX.de