goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 97281
Top-Poster: Johannes_B (5048)

Wir begrüßen unseren neuesten Benutzer Bigga.

Links:


Mit Unterstützung von DANTE e.V.: Deutschsprachige Anwendervereinigung TeX. Danke den Mitgliedern!





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Fehler trotz Eintragsänderung

 

Librr
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 18.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.02.2019, 13:27     Titel: Fehler trotz Eintragsänderung
  Antworten mit Zitat      
Die .bib file wurde mit JabRef erstellt und eingebunden, durch:

\bibliographystyle{plaindin}
\bibliography{bibliography}
\nocite{*}

Allerdings erhalte ich folgende Fehlermeldung:

Package inputenc Error: Unicode char ̈ (U+308)(inputenc) not set up for use with LaTeX. ...emph{Solarwärme : Heizen mit der Sonne}

Nun habe ich den Umlaut im Eintrag zu ae statt ä geändert, allerdings ändert sich die Fehlermeldung nicht. Sogar wenn ich die gesamte .bib Datei einfach lösche ändert sich die Fehlermeldung nicht ... Woran kann das liegen?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.02.2019, 13:33     Titel:
  Antworten mit Zitat      
Nun, irgendwo wird noch ein Codierungsfehler zu finden sein. Aber wir können leider nicht hellsehen. Wenn ich raten sollte, würde ich darauf tippen, dass du nach dem Ändern der bib-Datei nicht erneut hast BibTeX laufen lassen und sich daher seither die bbl-Datei nicht geändert hat.

BTW: Ich würde empfehlen zu biblatex und biber zu wechseln. Dann darf (und sollte) die bib-Datei genau wie alle anderen Dateien des Dokuments UTF8-kodiert werden. Siehe dazu auch die wichtigen Hinweise in diesem Forum.

Librr
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 18.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.02.2019, 13:57     Titel:
  Antworten mit Zitat      
Vielen Dank für die zügige Antwort!

Wenn ich die .bib Datei mit einem Text Editor öffne, dann steht in der ersten Zeile: "% Encoding: UTF-8".

Zwar bin ich mir nicht sicher, was mit "BibTeX laufen lassen" gemeint ist, aber die JabRef Datei scheint auf dem neuesten Stand zu sein: Neue Einträge werden mit im TexStudio angeboten, wenn ich \cite{ eingebe.

Allerdings, wenn ich in JabRef die Funktion "Push entries to external application (TexStudio)" anklicke, kommt die Meldung "Could not call executable 'texstudio' ".
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.02.2019, 15:26     Titel:
  Antworten mit Zitat      
Für die alte BibTeX-Methode sollte die bib-Datei US-ASCII codiert sein. Siehe dazu die bibtex-Anleitung. Für biblatex + biber wäre hingegen UTF8 richtig. Wie bereits erwähnt, solltest Du zu diesem Thema dann auch noch die wichtigen Hinweise (TOP-Thema in diesem Forum) sehr lesen oder besser durcharbeiten!

Wie man genau BibTeX (oder biber) im Editor aufruft, hängt natürlich vom Editor ab. Für biber findest Du dazu ebenfalls einen Link mit Detailinformationen in besagten wichtigen Hinweisen. Mehr kann ich dazu nicht sagen, da ich noch nicht einmal weiß, welchen LaTeX-Editor Du verwendest. Siehe daher auch noch einmal gründlich den vorherigen Kommentar. Außerdem sei empfohlen, eine ausführliche LaTeX-Einführung durchzuarbeiten. Darin sollte das Thema Literaturverzeichnis ebenfalls erklärt sein.

u_fischer
Forum-Meister
Forum-Meister


Beiträge: 3869
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.02.2019, 16:19     Titel:
  Antworten mit Zitat      
Lösche nicht die bib-Datei sondern die bbl-Datei.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Librr
Forum-Newbie
Forum-Newbie

Beiträge: 7
Anmeldedatum: 18.01.19
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.02.2019, 16:20     Titel:
  Antworten mit Zitat      
Das Löschen der bbl Datei hat das Problem behoben. Vielen Dank für eure Hilfe!
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de


  Datenschutzerklärung | Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2019 goLaTeX.de