goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Zitat - wie Umlaut in Fußnote korrekt darstellen?

 

JoLo
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 12:25     Titel: Zitat - wie Umlaut in Fußnote korrekt darstellen?
  Antworten mit Zitat      
Hallo zusammen,

ich schreibe momentan meine Masterarbeit mit LaTex unb verzweifel daran Umlaute beim Zitieren in der Fußnote zu verwenden.

Im gesamten Dokument funktionieren Umlaute problemlos, auch in der Bibliographie. Allerdings nicht in der Fußnote selbst.

Auszug aus dem .bib file:
Code • Öffne in Overleaf

@BOOK{Sch{\"u}rmann2007,
   AUTHOR = {Schürmann, Helmut},
   YEAR = {2007},
   TITLE = {Konstruieren mit Faser-Kunststoff-Verbunden},
   EDITION = {},
   ISBN = {978-3-540-72190-1
},
   PUBLISHER = {Springer-Verlag},
   ADDRESS = {Berlin, Heidelberg, New York},
}
 


Auszug aus dem .tex file:
Code • Öffne in Overleaf

\documentclass[
   12pt,
   oneside,
   toc=bibliography,
   toc=index,
   toc=listof,
   captions=nooneline,
   footsepline,
   plainfootsepline,
   
]{scrbook}
   
\usepackage[
   authordate,
   backend=biber,
   bibencoding=inputenc,
   
]{biblatex-chicago}
\addbibresource{bibliography.bib}
   
\usepackage{pdfpages}
\usepackage{setspace}  
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{lmodern}
\usepackage[scaled]{uarial}
\usepackage[english ]{babel}
\usepackage[section]{placeins}
\usepackage{geometry}
\usepackage{subfigure}
\usepackage{wrapfig}
\usepackage{graphicx}
\usepackage{xcolor}
\usepackage{transparent}
\usepackage{csquotes}

\usepackage[automark]{scrlayer-scrpage}
\pagestyle{scrheadings}
\ohead[\headmark]{\headmark}
\chead[]{}
\ofoot[\pagemark
]{\pagemark
}
\cfoot[]{}

\geometry{
   paper=a4paper,
   inner=2.5cm,
   outer=2cm,
   bindingoffset=1cm,
   top=2cm,
   bottom=2cm,
   
}

\begin{document}

\includepdf{Titlepage}

\begin{spacing}{1.05}
   \frontmatter
   \maketitle
   \includepdf{Documents/Sperrvermerk}
   \tableofcontents
   \addtocontents{toc}{\protect\thispagestyle{empty}}
   \clearpage

   \pagenumbering{roman}
   \setcounter{page}{1}
   \listoffigures
   \listoftables
   \include{./Chapters/task}
   \include{./Chapters/abstract}
   \edef\temppagenumber{\arabic{page}}

   \mainmatter
   \setcounter{page}{\temppagenumber}
   \include{./Chapters/chapter01}
   \include{./Chapters/chapter02}
   \include{./Chapters/chapter03}
   \include{./Chapters/chapter04}
   \include{./Chapters/chapter05}
   \include{./Chapters/chapter06}
\end{spacing}

\backmatter
\nocite{*}
\printbibliography

\end{document}
 


Das geschilderte Problem taucht bei mir im Kapitel 2 auf.
Auszug aus dem .tex file von Kapitel 2:
Code • Öffne in Overleaf

\chapter{2}
\section{2.1}
\subsection{2.1.1}

\footcite{Sch\"{u}rmann2007}\\
\footcite{Schürmann2007}

Schürmann \\
Sch\"{u}rmann
 


Beide Versionen im laufenden Text den Umlaut ü darzustellen funktionieren. Im der Fußnote funktionieren beide nicht: siehe Bild

Hat jemand einen Tipp woran das liegt?

bibliographie.jpg
 Beschreibung:

Download
 Dateiname:  bibliographie.jpg
 Dateigröße:  13.7 KB
 Heruntergeladen:  25 mal
pdf.jpg
 Beschreibung:

Download
 Dateiname:  pdf.jpg
 Dateigröße:  7.55 KB
 Heruntergeladen:  23 mal
Private Nachricht senden Benutzer-Profile anzeigen

Beinschuss
Forum-Meister
Forum-Meister

Beiträge: 776
Anmeldedatum: 02.10.12
Wohnort: NRW
Version: MiKTeX, Windows 10, TeXstudio
     Beitrag Verfasst am: 10.10.2017, 12:52     Titel:
  Antworten mit Zitat      
Das Kürzel @BOOK{Sch{\"u}rmann2007, ist ja nur dazu da, dass Biber den Titel eindeutig identifizieren kann. Gesetzt wird später das, was bei "Author" steht. Benutze im Kürzel keine Umlaute, egal wie. Schuermann2007 (oder auch nur schuer07 oder alles andere, eindeutige ohne Umlaute) sollte das Gewünschte liefern. Ungetestet, da zwar viele Angaben, aber kein InfoMinimalbeispiel (zu viele Include-Dateien, die wir hier nicht haben) mitgeliefert wurden.
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Guru
Forum-Guru

Beiträge: 412
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 10.10.2017, 13:00     Titel:
  Antworten mit Zitat      
Bitte liefere nach Möglichkeit immer ein InfoMinimalbeispiel. Wie Beinschuss bereits geschrieben hat, ist es unerheblich, wie der Eintrag genau beschrieben wird. Nutze am besten keine Umlaute und schon gar keine Befehle.

Code • Öffne in Overleaf
\begin{filecontents}{bibliography.bib}
@BOOK{wasauchimmer,
    AUTHOR = {Schürmann, Helmut
},
    YEAR = {2007},
    TITLE = {Konstruieren mit Faser-Kunststoff-Verbunden},
    EDITION = {},
    ISBN = {978-3-540-72190-1
},
    PUBLISHER = {Springer-Verlag},
    ADDRESS = {Berlin, Heidelberg, New York},
}
\end{filecontents}
\documentclass{scrbook}
 
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}  

\usepackage[
   authordate,
   backend=biber,
   bibencoding=inputenc,
   
]{biblatex-chicago}
\addbibresource{bibliography.bib}
\usepackage{csquotes}

\begin{document}
\footcite{wasauchimmer}
\printbibliography
\end{document}

_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

JoLo
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 13:51     Titel:
  Antworten mit Zitat      
Vielen Dank, dass ihr euch so schnell meinem Problem angenommen habt!

Hier das Minimalbeispiel:
Code • Öffne in Overleaf

\begin{filecontents}{bibliography.bib}
@BOOK{Sch{\"u}rmann2007,
   AUTHOR = {Schürmann, Helmut},
   YEAR = {2007},
   TITLE = {Konstruieren mit Faser-Kunststoff-Verbunden},
   EDITION = {},
   ISBN = {978-3-540-72190-1
},
   PUBLISHER = {Springer-Verlag},
   ADDRESS = {Berlin, Heidelberg, New York},
}
\end{filecontents}
\documentclass{scrbook}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}  

\usepackage[
authordate,
backend=biber,
bibencoding=inputenc,
]{biblatex-chicago}
\addbibresource{bibliography.bib}
\usepackage{csquotes}

\begin{document}
   Text \footcite{Sch{\"u}rmann2007}
   
   \nocite{*}
   \printbibliography
\end{document}
 


Das ü in der Fußnote sollte so geschrieben werden wenn möglich, da es gewünscht ist, in der Fußnote den Autor zu nennen. Nur für den Fall dass es so wirklich nicht mgl. ist würde ich auf Kürzel ausweichen wollen.

Gibt es vielleicht eine Möglichkeit in der Fußnote einen anderen Text erscheinen zu lassen?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 14:10     Titel:
  Antworten mit Zitat      
Wenn Du einfach glauben würdest, was man Dir oben erklärt hat, dann würde es auch funktionieren:
Code • Öffne in Overleaf
\begin{filecontents}{\jobname.bib}
@BOOK{Schuermann2007,
   AUTHOR = {Schürmann, Helmut
},
   YEAR = {2007},
   TITLE = {Konstruieren mit Faser-Kunststoff-Verbunden},
   EDITION = {},
   ISBN = {978-3-540-72190-1
},
   PUBLISHER = {Springer-Verlag},
   ADDRESS = {Berlin, Heidelberg, New York},
}
\end{filecontents}
\documentclass{scrbook}

\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}  

\usepackage[
authordate,
backend=biber,
bibencoding=inputenc,
]{biblatex-chicago}
\addbibresource{\jobname.bib}
\usepackage{csquotes}

\begin{document}
   Text \footcite{Schuermann2007}
   
   \nocite{*}
   \printbibliography
\end{document}

Ergibt tatsächlich korrekt "Schürmann 2007" in der Fußnote. Kannst Du gerne via Overleaf-Link überprüfen. Wenn das bei Dir anders sein sollte, hast Du entweder Paket auf CTANbiber nicht aufgerufen oder es gab einen Fehler. Den findest Du ggf. in der .blg-Datei oder eventuell auch in der .log-Datei.

JoLo
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 14:14     Titel:
  Antworten mit Zitat      
Stimmt, in Overelaf passt es. Leider nicht bei mir auf dem PC. Da erscheint wirklich Schuermann. Also mit ue.

Hier der Inhalt des .blg files:
Code • Öffne in Overleaf

[0] Config.pm:354> INFO - This is Biber 2.7
[0] Config.pm:357> INFO - Logfile is 'main.blg'
[42] biber-MSWIN64:303> INFO - ===
[147] Biber.pm:359> INFO - Reading 'main.bcf'
[310] Biber.pm:832> INFO - Using all citekeys in bib section 0
[331] Biber.pm:3670> INFO - Processing section 0
[355] Biber.pm:3840> INFO - Looking for bibtex format file 'bibliography.bib' for section 0
[359] bibtex.pm:1435> INFO - Decoding LaTeX character macros into UTF-8
[365] bibtex.pm:1292> INFO - Found BibTeX data source 'bibliography.bib'
[429] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'normalization = NFD' with 'normalization = prenormalized'
[429] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'variable = shifted' with 'variable = non-ignorable'
[429] UCollate.pm:68> INFO - Overriding locale 'en-US' defaults 'level = 4' with 'level = 2'
[430] Biber.pm:3499> INFO - Sorting list 'cms/global/' of type 'entry' with scheme 'cms' and locale 'en-US'
[430] Biber.pm:3505> INFO - No sort tailoring available for locale 'en-US'
[438] bbl.pm:608> INFO - Writing 'main.bbl' with encoding 'UTF-8'
[439] bbl.pm:712> INFO - Output to main.bbl
 


Hilft das weiter?
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Guru
Forum-Guru

Beiträge: 412
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 10.10.2017, 14:14     Titel:
  Antworten mit Zitat      
Kompilierst du dein Dokument richtig: pdflatex -> biber -> pdflatex -> pdflatex? Dann sollte der Fehler nicht auftreten.
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

JoLo
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 14:20     Titel:
  Antworten mit Zitat      
Ich meine schon, dass das passen müsste. Siehe angehängtes Bild.

Konfiguration.PNG
 Beschreibung:

Download
 Dateiname:  Konfiguration.PNG
 Dateigröße:  38.9 KB
 Heruntergeladen:  26 mal
Private Nachricht senden Benutzer-Profile anzeigen

JoLo
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.10.2017, 14:42     Titel:
  Antworten mit Zitat      
Problem ist gelöst! Vielen Dank an alle, die geholfen haben!!!

Das Problem war letztendlich noch, dass ich in meinem .bib file vergessen hatte auch auf 'ue' anstatt 'ü' umzustellen.
Das Minimalbeispiel im Beitrag von Gast ist so genau das was ich gesucht hab.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.10.2017, 10:45     Titel:
  Antworten mit Zitat      
Demnach ist die Frage also beantwortet

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de