goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Probleme beim Literaturverzeichnis (bibtex)

 

Alexermselber
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.01.2018, 22:47     Titel: Probleme beim Literaturverzeichnis (bibtex)
  Antworten mit Zitat      
Hallo zusammen!
Ich bin aktuell kurz vor der Fertigstellung meiner Masterarbeit und habe ein Problem mit dem Literaturverzeichnis. Ich nutze TeXstudio.

Ich muss die Zitate im Fließtext (zum Beispiel [Nov04]) und die Anordnung im Literaturverzeichnis im Sinne des Zitier-Stils "alphabetic" umsetzen. Die einzelnen Referenzen sollen hingegen im Literaturverzeichnis im Sinne des Zitier-Stils "nature" folgendermaßen dargestellt sein:

Autor1, Autor2, Titel, Journal Volume, pages (year).

Ich nutze aktuell den Zitier-Stil "alphabetic" und habe diesen soweit umdefiniert, dass es jetzt nur noch an der Position der Jahreszahl scheitert. Dazu ein Minimalbeispiel:
Code • Öffne in Overleaf
 
\documentclass[11pt, captions=topbeside]{scrbook}

\usepackage[ngerman]{babel}
\usepackage[backend=bibtex, style=alphabetic, firstinits=true, maxnames=99]{biblatex}

\ExecuteBibliographyOptions{maxbibnames=99, maxcitenames=1}
\renewcommand*{\labelalphaothers}{}
\bibliography{test-bib
}
\DeclareFieldFormat[article]{title}{\textit{#1}}
\DeclareFieldFormat*{volume}{\textbf{#1}}
\DeclareFieldFormat*{pages}{#1}
\DeclareFieldFormat{journaltitle}{#1}


\renewcommand*{\newunitpunct}{\addcomma\space}


\renewbibmacro{in:}{%
 \ifentrytype{article}{}{%
  \printtext{\bibstring{in}\intitlepunct}}}

\DefineBibliographyStrings{ngerman}{
 bibliography={Literaturverzeichnis
}
}

\begin{document}
 Test \cite{nov04}
 
 \printbibliography[maxnames=99]
\end{document}



Bibliothek:
Code • Öffne in Overleaf

@article {nov04,
   author = {Novoselov, K. S. and Geim, A. K. and Morozov, S. V. and Jiang, D. and Zhang, Y. and Dubonos, S. V. and Grigorieva, I. V. and Firsov, A. A.
},
   title = {Electric Field Effect in Atomically Thin Carbon Films},
   volume = {306},
   pages = {666--669},
   year = {2004},
   publisher = {American Association for the Advancement of Science},
   journal = {Science}
}



Hat jemand eine Idee, wie man die Jahreszahl ganz nach hinten schieben kann, um so die gewünschte Form zu erreichen? Danke schon mal im Voraus!

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 16.01.2018, 23:40     Titel:
  Antworten mit Zitat      
Wenn Du wirklich in der Bibliography exakt den Nature-Stil brauchst und Zitate in alphabetic, könnte
Code • Öffne in Overleaf
\documentclass[11pt, captions=topbeside]{scrbook}

\usepackage[ngerman]{babel}
\usepackage[backend=bibtex, citestyle=alphabetic, bibstyle=nature, firstinits=true, maxbibnames=99, maxcitenames=1]{biblatex}

\renewcommand*{\labelalphaothers}{}
\DeclareFieldFormat[article]{title
}{\textit{#1}}% entspricht NICHT Nature-Stil
\DeclareFieldFormat{journaltitle}{#1}% entspricht NICHT Nature-Stil

\renewcommand*{\newunitpunct}{\addcomma\space}% entspricht NICHT Nature-Stil

\DefineBibliographyStrings{german}{
 bibliography={Literaturverzeichnis
}
}

\DeclareFieldFormat{bibentrysetcount}{\mkbibparens{\mknumalph{#1}}}
\DeclareFieldFormat{labelalphawidth}{\mkbibbrackets{#1}}
\DeclareFieldFormat{shorthandwidth}{\mkbibbrackets{#1}}

\defbibenvironment{bibliography}
  {\list
     {\printtext[labelalphawidth]{%
        \printfield{labelprefix}%
        \printfield{labelalpha}%
        \printfield{extraalpha}}}
     {\setlength{\labelwidth}{\labelalphawidth}%
      \setlength{\leftmargin}{\labelwidth}%
      \setlength{\labelsep}{\biblabelsep}%
      \addtolength{\leftmargin}{\labelsep}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}%
      \renewcommand*{\makelabel}[1]{##1\hss}}
  {\endlist}
  {\item}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article {nov04,
   author = {Novoselov, K. S. and Geim, A. K. and Morozov, S. V. and Jiang, D. and Zhang, Y. and Dubonos, S. V. and Grigorieva, I. V. and Firsov, A. A.
},
   title = {Electric Field Effect in Atomically Thin Carbon Films},
   volume = {306},
   pages = {666--669},
   year = {2004},
   publisher = {American Association for the Advancement of Science},
   journal = {Science}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
 Test \cite{nov04}
 
 \printbibliography
\end{document}

etwas für Dich sein.

\printbibliography[maxnames=99] sollte nur noch in total veralteten Versionen von biblatex funktionieren, daher habe das [maxnames=99] entfernt, es war eh durch andere Optionen abgedeckt.

Wenn möglich solltest Du statt BibTeX Biber verwenden. Also backend=biber und http://www.texwelt.de/wissen/fragen.....ch-biber-in-meinem-editor
Verschoben: 17.01.2018, 06:54 Uhr von Johannes_B
Von Verzeichnisse nach Literaturverzeichnis

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.01.2018, 10:06     Titel:
  Antworten mit Zitat      
Klasse! Danke für deine schnelle Antwort. Hat genauso funktioniert wie ich es wollte. Die Wahl von bibtex statt biber fiel eher zufällig. Wenn ich stattdessen biber nehme, funktioniert dein Code nicht mehr

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.01.2018, 10:12     Titel:
  Antworten mit Zitat      
Der Code funktioniert natürlich auch mit Biber
Code • Öffne in Overleaf
\documentclass[11pt, captions=topbeside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage{csquotes}
\usepackage[backend=biber, citestyle=alphabetic, bibstyle=nature, giveninits=true, maxbibnames=99, maxcitenames=1]{biblatex}

\renewcommand*{\labelalphaothers}{}
\DeclareFieldFormat[article]{title
}{\textit{#1}}% entspricht NICHT Nature-Stil
\DeclareFieldFormat{journaltitle}{#1}% entspricht NICHT Nature-Stil

\renewcommand*{\newunitpunct}{\addcomma\space}% entspricht NICHT Nature-Stil

\DefineBibliographyStrings{german}{
 bibliography={Literaturverzeichnis
}
}

\DeclareFieldFormat{bibentrysetcount}{\mkbibparens{\mknumalph{#1}}}
\DeclareFieldFormat{labelalphawidth}{\mkbibbrackets{#1}}
\DeclareFieldFormat{shorthandwidth}{\mkbibbrackets{#1}}

\defbibenvironment{bibliography}
  {\list
     {\printtext[labelalphawidth]{%
        \printfield{labelprefix}%
        \printfield{labelalpha}%
        \printfield{extraalpha}}}
     {\setlength{\labelwidth}{\labelalphawidth}%
      \setlength{\leftmargin}{\labelwidth}%
      \setlength{\labelsep}{\biblabelsep}%
      \addtolength{\leftmargin}{\labelsep}%
      \setlength{\itemsep}{\bibitemsep}%
      \setlength{\parsep}{\bibparsep}}%
      \renewcommand*{\makelabel}[1]{##1\hss}}
  {\endlist}
  {\item}

%\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@article {nov04,
   author = {Novoselov, K. S. and Geim, A. K. and Morozov, S. V. and Jiang, D. and Zhang, Y. and Dubonos, S. V. and Grigorieva, I. V. and Firsov, A. A.
},
   title = {Electric Field Effect in Atomically Thin Carbon Films},
   volume = {306},
   pages = {666--669},
   year = {2004},
   publisher = {American Association for the Advancement of Science},
   journal = {Science}
}
\end{filecontents}
\addbibresource{\jobname.bib}

\begin{document}
 Test \cite{nov04}
 
 \printbibliography
\end{document}


Du musst dann allerdings auch Biber zum Kompilieren nutzen und nicht BibTeX. Siehe den letzten Link in meiner Antwort.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2018 goLaTeX.de