goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

von Deutsch auf Englisch Umstellen:

 

freak1982
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 19.09.11
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.11.2011, 13:25     Titel: von Deutsch auf Englisch Umstellen:
  Antworten mit Zitat      
Hi zusammen,

ich schreibe gerade an meiner Masterthesis auf Englisch. Leider sind auch einige Seiten auf Deutsch enthalten wie die Eidesstattliche Versicherung. Ich habe mir eine schönes Formatvorlage heruntergeladen habe jetzt aber ein Problem das statt "et al" "u.a." und statt "and" "und" steht.

Die Packages die ich u.a. benutzte sind die Folgenden:
Code • Öffne in Overleaf

\usepackage[ngerman,english]{babel}
\usepackage[square]{natbib}
 

Die Probleme wie Inhaltsverzeichnis auf Deutsch etc. habe ich nicht.
[/code]
Private Nachricht senden Benutzer-Profile anzeigen

schmendrich
Forum-Century
Forum-Century

Beiträge: 136
Anmeldedatum: 02.03.09
Wohnort: ---
Version: TexLive2011
     Beitrag Verfasst am: 19.11.2011, 13:46     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf

\selectlanguage{sprache}
 


Hättest Du aber auch über die Forensuche rausbekommen.

Grüße
schmendrich
Private Nachricht senden Benutzer-Profile anzeigen

freak1982
Forum-Anfänger
Forum-Anfänger

Beiträge: 25
Anmeldedatum: 19.09.11
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.11.2011, 14:08     Titel:
  Antworten mit Zitat      
Vielen Dank für die Hilfe.

Ich hab das mal direkt hinter das Package geschrieben, Funktioniert aber leider nicht. Habe ich den Ort für den Code falsch gewählt?
Code • Öffne in Overleaf

\selectlanguage{english}
[\code]
Private Nachricht senden Benutzer-Profile anzeigen

goemic
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.11.2017, 12:19     Titel:
  Antworten mit Zitat      
Ich weiß es ist alt, hatte gerade aber auch das gleiche Problem Very Happy

Der Befehl
Code • Öffne in Overleaf
\selectlanguage{\english}
muss nach
Code • Öffne in Overleaf
\begin{document}
aufgerufen werden, dann funktioniert alles wunderbar

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 09.11.2017, 12:51     Titel:
  Antworten mit Zitat      
Der Befehl lautet \selectlanguage{english} nicht \selectlanguage{\english}.

Die Hauptsprache kann man beim Laden von Paket auf CTANbabel übrigens einfach über main=… angeben. Dann muss man sich die korrekte Reihenfolge nicht merken, also ob die erste oder die letzte Option die Hauptsprache ergibt.

Paket auf CTANbabel bietet neben \selectlanguage übrigens auch noch andere Möglichkeiten wie Umgebung otherlanguage oder Befehl \foreignlanguage oder Umgebung hyphenrules. Letztere sind vor allem dann nützlich, wenn man nur einzelne Passagen mit den Trennregeln einer anderen Sprache setzen will, ohne dass sprachabhängige Begriffe umgeschaltet werden sollen.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de