goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Falsche Einrückung mit listings, caption in itemite-Umgebung

 

Matthias1
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.10.2017, 17:11     Titel: Falsche Einrückung mit listings, caption in itemite-Umgebung
  Antworten mit Zitat      
Hallo zusammen,

ich habe ein Problem im Zusammenspiel der Pakete listings und caption mit der itemize-Umgebung: Ich benutze innerhalb einer itemize-Umgebung Code, den ich mittels des Pakets listings darstelle. Mittels caption-Paket formatiere ich meine Captions. Leider wird die Caption meines Codes nicht an der korrekten Position dargestellt, d.h. der Einzug der itemize-Umgebung wird vergessen. Wird demonstriert mit folgendem Beispiel:

Code • Öffne in Overleaf

\documentclass{article}
\usepackage{caption}
\usepackage{listings}
\begin{document}
\begin{itemize}
  \item Dies ist ein Absatz in der itemize-Umgebung.
    Und dies ist ein zweiter Satz innerhalb dieser itemize-Umgebung,
    damit man die Breite dieses Ansatzes erkennen kann.
  \begin{lstlisting}[
    caption={Caption unterhalb des Quellcodes.
      Diese ist absichtlich lang, damit die
      Caption umgebrochen wird.
},
    frame=single,
    framesep=5pt,
    xleftmargin=5pt,
    xrightmargin=5pt,
    % caption & distances
    captionpos=b,
    abovecaptionskip=0.8\baselineskip,
    belowcaptionskip=0ex,
    aboveskip=\intextsep,
    ]
Quellcode.
  \end{lstlisting}
\end{itemize}
\end{document}
 


Hat jemand eine Idee, wie ich das Problem lösen kann?

P.S. Ich benutze die aktuellsten Version von listings und captions, d.g. listings 1.6 und captions 2016-05-22.

Bartman
Forum-Meister
Forum-Meister


Beiträge: 1004
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 24.10.2017, 17:31     Titel:
  Antworten mit Zitat      
Steck Deine lstlisting-Umgebung in eine minipage-Umgebung und füge eine Leerzeile zwischen dem Text und der minipage-Umgebung ein.
Private Nachricht senden Benutzer-Profile anzeigen

Matthias1
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.10.2017, 09:53     Titel:
  Antworten mit Zitat      
Vielen Dank, das löst einen Teil des Problems.

Der Haken: Listings werden jetzt auf einer Seite gehalten; ich benötige es dummerweise an einer Stelle, wo die listings-Umgebung auf zwei Seiten umgebrochen wird (was die minipage verhindert...).

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de