goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

MacOS: TeXstudio findet Pakete nicht

 

FelixGraf
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 12.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 12.10.2017, 21:49     Titel: MacOS: TeXstudio findet Pakete nicht
  Antworten mit Zitat      
Ich bin noch Neuling im Umgang mit LaTeX und habe bisher immer nur sharelatex als Editor verwendet. Da ich nun mehr mit mathematischen Symbolen arbeiten möchte, habe ich mir den TeXstudio-Editor heruntergeladen und installiert.
Leider hatte ich vor der Installation von TeXstudio die MacTeX-Distribution noch nicht installiert, daher weiß ich nicht ob das eventuell die Ursache meines Fehlers ist.

Der Fehler ist, dass kein Paket gefunden wird, d.h. wenn ich auf den Paketname bei \usepackage zeige, steht dort "nicht gefunden".

Ich habe schon probiert, TeXstudio zu deinstallieren, aber das hat nicht so richtig geklappt, da die Einstellungen etc. nach der Neuinstallation noch vorhanden sind.
Private Nachricht senden Benutzer-Profile anzeigen

iTob
Forum-Meister
Forum-Meister


Beiträge: 1201
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 13.10.2017, 22:21     Titel:
  Antworten mit Zitat      
Ne konkrete Lösung hab ich nicht, aber nen Tipp und ne Frage Wink

Tipp: Wenn du TeXstudio komplett deinstallieren willst, lösche die App aus dem Programmordner. Dann im Finder Gehe zu > Gehe zum Ordner; dort ~/Library/Preferences/ eingeben und in diesem Ordner die Datei texstudio.plist löschen; nun zum Ordner ~/.config/ gehen und daraus den Ordner texstudio entfernen. Damit müsste TeXstudio komplett weg sein. Du kannst dann neu installieren und schauen, ob das hilft.

Frage: Kannst du denn kompilieren? Also heißt „Pakete nicht gefunden“ nur, dass du aus TaXstudio nicht die Pakethilfe aufrufen kannst oder auch dass du beim Kompilieren den Fehler zu fehlenden Paketen bekommst?

Viele Grüße
Tobi
_________________

Ich biete Hilfe, Beratung und Schulung für alle Fragen rund um TeX, Buchgestaltung und Textsatz, sowie Grafik- und Kommunikationsdesign.
Mehr Infos und Kontakt unter tobiw.de.

Hier schreibe ich über TeX: Mein Blog „TeX-Beispiel des Monats“ (Deutsch) und TeX.tips (Englisch).
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.10.2017, 08:35     Titel:
  Antworten mit Zitat      
Hast Du denn MacTeX inzwischen vollständig installiert?

Wenn Du ein minimales Dokument wie
Code • Öffne in Overleaf
\documentclass{article}
\begin{document}
Test
\end{document}
in Texstudio eingibst, speicherst und dann HilfeLaTeX Installation prüfen aufrufst, wird dann ein Fehler gemeldet? Kannst Du uns ggf. den dabei erzeugten Systembericht (von den Environmentvariablen brauchen wir ggf. nur PATH) zeigen?

FelixGraf
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 12.10.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.10.2017, 13:17     Titel:
  Antworten mit Zitat      
iTob hat Folgendes geschrieben:
Damit müsste TeXstudio komplett weg sein. Du kannst dann neu installieren und schauen, ob das hilft.


Neuinstallation habe ich so gemacht, hat nix verändert.

iTob hat Folgendes geschrieben:
Frage: Kannst du denn kompilieren? Also heißt „Pakete nicht gefunden“ nur, dass du aus TaXstudio nicht die Pakethilfe aufrufen kannst oder auch dass du beim Kompilieren den Fehler zu fehlenden Paketen bekommst?

Ja, das Kompilieren funktioniert ohne Probleme mit allen Paketen :/

Gast hat Folgendes geschrieben:
Kannst Du uns ggf. den dabei erzeugten Systembericht (von den Environmentvariablen brauchen wir ggf. nur PATH) zeigen?

Folgenes wird dort angezeigt, nach einem Fehler sieht es für mich nicht aus:
https://pastebin.com/bSk3UGrs
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.10.2017, 14:17     Titel:
  Antworten mit Zitat      
Die Installation ist also grundsätzlich funktionsfähig. Also zeig und mal ein InfoMinimalbeispiel (← Link beachten!), das den Fehler produziert und die log-Datei dazu.

BTW: Code oder Text-Ausgaben kannst du direkt in deinen Beitrag einfügen (siehe Code-Tag-Erklärung über dem Nachrichteneingabefeld). Längere log-Dateien können ggf. als Anhang angefügt werden. Und auch für Bilder bevorzugen wir sie direkt anzuhängen.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.10.2017, 14:18     Titel:
  Antworten mit Zitat      
FelixGraf hat Folgendes geschrieben:
Ja, das Kompilieren funktioniert ohne Probleme mit allen Paketen :/

Was ist dann das Problem?

iTob
Forum-Meister
Forum-Meister


Beiträge: 1201
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 15.10.2017, 09:49     Titel:
  Antworten mit Zitat      
Es geht wie im Eingangspost auch beschrieben darum, dass ein Edizor-Feature, dass Pakete (unabhängig vom Kompilieren) in der Distribution sucht und schon vorweg als „nicht gefunden” kennzeichnet und es z.B. auch erlaubt mit cmd+Klick auf den Namen die Doku aufzurufen (also ein Interface für texdoc).

@FelixGraf: Hm … eine Idee hätte ich noch: Versuch mal in den Optionen unter „Editor” (vorher erweiterte Optionen einschalten) unter „Befehle ($PATH)”
Code • Öffne in Overleaf

$PATH:/Library/TeX/texbin/:/usr/local/bin/:/opt/local/bin/
 

einzugeben und den Editor dann neu zu starten.

Falls das nicht hilft, könntest du dich über die Homepage (und dann das SF-Forum) auch direkt an die Entwickler wenden.
_________________

Ich biete Hilfe, Beratung und Schulung für alle Fragen rund um TeX, Buchgestaltung und Textsatz, sowie Grafik- und Kommunikationsdesign.
Mehr Infos und Kontakt unter tobiw.de.

Hier schreibe ich über TeX: Mein Blog „TeX-Beispiel des Monats“ (Deutsch) und TeX.tips (Englisch).
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 15.10.2017, 10:40     Titel:
  Antworten mit Zitat      
iTob hat Folgendes geschrieben:
Versuch mal in den Optionen unter „Editor” (vorher erweiterte Optionen einschalten) unter „Befehle ($PATH)”
Code • Öffne in Overleaf

$PATH:/Library/TeX/texbin/:/usr/local/bin/:/opt/local/bin/
 

einzugeben und den Editor dann neu zu starten.

Sowohl /Library/TeX/texbin als auch /usr/local/bin sind bereits in der vom OP gezeigten PATH-Einstellung enthalten. Das dürfte also eher nichts bringen.

Es wird übrigens immer mal wieder berichtet, dass Texstudio Pakete und Befehle oder Umgebungen von Paketen nicht kennt, siehe beispielsweise TexStudio says package not found und Why does TXS mark a package as missing?
Letztes lässt darauf schließen, dass Pakete, die in TEXMF-Bäumen ohne ls-R-Datei liegen, von Texstudio nicht gefunden werden. Entscheidend ist also auch die Frage, wo das jeweilige Paket abgelegt ist und ob es via ls-R-Datei gefunden wird. Besser wäre hier IMHO, wenn Texstudio für jedes per \usepackage geladene Paket zusätzlich per kpsewhich danach suchen würde (und per texdoc prüfen würde, ob eine Doku dazu verfügbar ist). Vielleicht kann ja mal einer der Texstudio-Anwender einen Request machen.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 15.10.2017, 10:46     Titel:
  Antworten mit Zitat      
Eventuell ist die Paketsuche in TeXstudio auch schlicht deaktiviert. Optionen/Preferences → TeXstudio konfigurieren → Editor (mit aktiviertem "Erweitere Optionen") → Suche nach installierten Paketen der Distribution

iTob
Forum-Meister
Forum-Meister


Beiträge: 1201
Anmeldedatum: 19.04.10
Wohnort: ---
Version: TeX Live auf OS X
     Beitrag Verfasst am: 15.10.2017, 10:51     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:

Sowohl /Library/TeX/texbin als auch /usr/local/bin sind bereits in der vom OP gezeigten PATH-Einstellung enthalten. Das dürfte also eher nichts bringen.


Soweit ich das sehe aber nur in den Environment Variablen der Shell (Zeile 28 ), innerhalb derer pdflatex ausgeführt wird. Die PFad-Einstellung in TeXstudio ist nicht gesetzt (Zeile 79). Ob das tatsächlich einen unterschied macht weiß ich nicht, aber ein Versuch schadet ja nicht Wink
_________________

Ich biete Hilfe, Beratung und Schulung für alle Fragen rund um TeX, Buchgestaltung und Textsatz, sowie Grafik- und Kommunikationsdesign.
Mehr Infos und Kontakt unter tobiw.de.

Hier schreibe ich über TeX: Mein Blog „TeX-Beispiel des Monats“ (Deutsch) und TeX.tips (Englisch).
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de