goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Kopfzeilen nach Umstellen auf twoside nicht immer da

 

latexneuling356
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 29.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 03.10.2017, 20:05     Titel: Kopfzeilen nach Umstellen auf twoside nicht immer da
  Antworten mit Zitat      
Hallo!

Ich hab das Problem, dass die Kopfzeilen verrückt spielen, seitdem ich mit dem Paket geometry auf twoside gestellt habe.
Davor war alles super, aber jetzt sind nicht mehr auf allen Seiten Kopfzeilen. Weiß einer, woran das liegen könnte?
Oder Ideen, wie ich ganz umbauen könnte, dass es klappt?

Es ist schwierig, ein gutes Minimalbeispiel zu geben, da ich ja dann das gesamte Dokument hochladen müsste, aber vielleicht erkennt einer ja auch schon so den Fehler. Smile

Danke!

Code • Öffne in Overleaf

\documentclass[fontsize=12pt]{scrartcl}

\usepackage[utf8]{inputenc}
\usepackage[german]{babel}
\usepackage[a4paper, twoside, bindingoffset=0.25cm, margin=2.5cm]{geometry}

\pagestyle{scrheadings}
\clearscrheadfoot
\ohead{\headmark}
\automark[subsubsection]{subsection}

\begin{document}

\end{document}
 
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 955
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 03.10.2017, 20:34     Titel: Re: Kopfzeilen nach Umstellen auf twoside nicht immer da
  Antworten mit Zitat      
latexneuling356 hat Folgendes geschrieben:
Es ist schwierig, ein gutes Minimalbeispiel zu geben, da ich ja dann das gesamte Dokument hochladen müsste


Du könntest z. B. in Deiner document-Umgebung ausreichend Inhalt einfügen, um zu sehen, wie die Kopfzeile aussieht. Dafür kann der Befehl \blinddocument des Pakets Paket auf CTANblindtext hilfreich sein.

Irgendwie scheint Dein Ladebefehl für das Paket Paket auf CTANscrlayer-scrpage verloren gegangen zu sein.

Möchtest Du wirklich german statt ngerman beim Laden von Paket auf CTANbabel benutzen?
Private Nachricht senden Benutzer-Profile anzeigen

latexneuling356
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 29.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 03.10.2017, 21:35     Titel:
  Antworten mit Zitat      
Hi, danke für die Antwort!

Ich hab das jetzt mal mit blindtext probiert - und auch hier ist bei mir der Fehler aufgetreten, dass nur (in meinem Fall) die Seite 2 eine Kopfzeile hat.

Code • Öffne in Overleaf

\documentclass[fontsize=12pt]{scrartcl}

\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[a4paper, twoside, bindingoffset=0.25cm, margin=2.5cm]{geometry}
\usepackage{blindtext}
\usepackage{scrpage2}

\pagestyle{scrheadings}
\clearscrheadfoot
\ohead{\headmark}
\automark[subsubsection]{subsection}

\begin{document}
\blinddocument
\end{document}
 
Private Nachricht senden Benutzer-Profile anzeigen

Beinschuss
Forum-Meister
Forum-Meister

Beiträge: 769
Anmeldedatum: 02.10.12
Wohnort: NRW
Version: MiKTeX, Windows 10, TeXstudio
     Beitrag Verfasst am: 03.10.2017, 23:22     Titel:
  Antworten mit Zitat      
Erstmal: Wie heute schon in einem anderen Thread geschrieben wurde, ist scrpage2 veraltet: http://golatex.de/seitenzahlen-werd.....tig-angezeigt-t19833.html.

Und die Antwort auf Deine Frage findest Du hier:
Wo sind Kopfzeile und Fußzeile bei Kapitelstart
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2215
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 04.10.2017, 02:16     Titel:
  Antworten mit Zitat      
@Beinschuss: Der Fragesteller verwendet scrarticl - also gibt es keine Kapitel und damit auch keine Kapitelanfangsseiten Wink . Der verlinkte Thread beantwortet die Frage deshalb nicht.

Im einseitigen Modus gelten alle Seiten als rechte Seiten. Damit wird für \headmark im einseitigen Modus auf allen Seiten \rightmark verwendet und deshalb jeweils die erste auf einer Seite gesetzte rechte Marke in die Kopfzeile eingefügt. Im einseitigen Modus führt

Code • Öffne in Overleaf
\automark[subsubsection]{subsection}


dazu, dass ein neuer Unterabschnitt (subsection) die rechte und die linke Marke gleich diesem Unterabschnitt setzt. Im zweiseitigen Modus setzt ein neuer Unterabschnitt dagegen nur die linke Marke und leert die rechte. Deshalb steht im einseitigen Dokument der Unterabschnitt in der Kopfzeile während diese im zweisetigen Modus leer bleibt, wenn auf einer rechten Seite vor der ersten Unterunterabschnittsüberschrift noch eine Unterabschnittsüberschrift steht.

Das Kopfzeilenverhalten Deines einseitigen Dokuments kannst Du wie im folgenden Beispiel auf Dein zweiseitiges Dokument übertragen.

Code • Öffne in Overleaf
\documentclass[fontsize=12pt,twoside]{scrartcl}% twoside besser bei der Klasse angeben

\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[a4paper, bindingoffset=0.25cm, margin=2.5cm]{geometry}
\usepackage{blindtext}

\usepackage{scrlayer-scrpage}% aktiviert den Seitenstil scrheadings
\clearpairofpagestyles
\ohead{\rightmark}

\automark[subsection]{subsection}
\automark*[subsubsection]{subsubsection}

\begin{document}
\blinddocument
\Blindtext[10]
\end{document}


Egal, ob ein- oder zweiseitig - wenn Du einen neuen Abschnitt beginnst und der keinen Unterabschnitt enthält oder der erste Unterabschnitt erst auf späteren Seiten beginnt, tauchen in der Kopfzeile solange noch der letzte Unter- bzw. Unterunterabschnitt aus dem vorherigen Abschnitt auf.
Private Nachricht senden Benutzer-Profile anzeigen

Beinschuss
Forum-Meister
Forum-Meister

Beiträge: 769
Anmeldedatum: 02.10.12
Wohnort: NRW
Version: MiKTeX, Windows 10, TeXstudio
     Beitrag Verfasst am: 04.10.2017, 07:47     Titel:
  Antworten mit Zitat      
Zitat:
@Beinschuss: Der Fragesteller verwendet scrarticl - also gibt es keine Kapitel und damit auch keine Kapitelanfangsseiten Wink . Der verlinkte Thread beantwortet die Frage deshalb nicht.

Entschuldigung, ich sollte gründlicher lesen ...
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2215
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 04.10.2017, 20:59     Titel:
  Antworten mit Zitat      
Zusätzlicher Hinweis: Wenn scrlayer-scrpage geladen wird, dann darf das Vorgängerpaket scrpage2 nicht mehr geladen werden!

Bezogen auf Dein Bespiel heißt das, dass Du

Code • Öffne in Overleaf
\usepackage{scrpage2}

\pagestyle{scrheadings}
\clearscrheadfoot
\ohead{\headmark}
\automark[subsubsection]{subsection}


durch

Code • Öffne in Overleaf
\usepackage{scrlayer-scrpage}% aktiviert den Seitenstil scrheadings
\clearpairofpagestyles
\ohead{\rightmark}

\automark[subsection]{subsection}
\automark*[subsubsection]{subsubsection}


ersetzen musst.
Private Nachricht senden Benutzer-Profile anzeigen

latexneuling356
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 29.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 05.10.2017, 08:59     Titel:
  Antworten mit Zitat      
Vielen Dank!
Private Nachricht senden Benutzer-Profile anzeigen

latexneuling356
Forum-Newbie
Forum-Newbie

Beiträge: 9
Anmeldedatum: 29.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.10.2017, 13:24     Titel:
  Antworten mit Zitat      
Ich bin mir sicher ich nerve, aber trotzdem: ich hab jetzt ein wenig mit den Seitenzahlen rumgespielt, aber bei \pagenumbering sind sie immer mittig. Wie kann ich bewirken, dass auch diese jeweils abwechselnd links- und rechtszentriert sind?
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4833
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 07.10.2017, 13:53     Titel:
  Antworten mit Zitat      
Stelle uns doch bitte ein InfoMinimalbeispiel zur Verfügung. Das von dir geschilderte Problem kann dutzende Ursachen haben und wir können dir nicht über die Schulter schauen.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de