goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Seitenränder werden nicht eingehalten

 

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 82
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.08.2017, 14:07     Titel: Seitenränder werden nicht eingehalten
  Antworten mit Zitat      
Liebes Forum,
teilweise werden sowohl in meinem Text als auch in meinem Literaturverzeichnis die Seitenränder nicht eingehalten. Das Problem liegt daran, dass Latex wohl das Wort Regel-/Prinzipienmodell nicht richtig trennen kann. Wenn ich beispielsweise "Regel-/ Prinzipenmodell" schreibe, wird der Seitenrand wieder eingehalten. Problematischer ist es jedoch im Literaturverzeichnis, da ich dort nicht beliebig etwas ändern kann. Habt ihr eine Idee? Kann das am geometry Packet liegen? Um es übersichtlich zu gestalten, habe ich zuerst nur den Teil aus dem Text selbst hier dargestellt und nicht das Literaturverzeichnis. Anbei mein Minimalbeispiel:

Code • Öffne in Overleaf

\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage{alnumsec}
\surroundarabic[(][)]{}{.}
\usepackage{geometry}
\geometry{a4paper,includehead, includefoot, left=20mm,right=20mm,top=20mm,bottom=10mm}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[]{biblatex}
 
\begin{document}

\section{Fazit}
Um die Eigenschaften und den Gehalt von Grundsätzen zu bestimmen, eignet sich das Regel-/Prinzipienmodell von \textit{Alexy}. Es gibt eine Vielzahl von Ansatzpunkten, um eine Regel von einem Prinzip zu unterscheiden. Das entscheidende Kriterium ist letztlich jedoch die qualitative Unterscheidung zwischen einer Regel und einem Prinzip.
\end{document}
 
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Guru
Forum-Guru

Beiträge: 298
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 28.08.2017, 14:50     Titel:
  Antworten mit Zitat      
Hallo.

Mit der Angabe eines einfachen Bindestrichs verhinderst du die weitere Worttrennung durch Latex. Da du Paket auf CTANbabel lädst, kannst du mittels "= einen Trennstrich einfügen und die weitere Worttrennung erlauben:

Code • Öffne in Overleaf
\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage{alnumsec}
\surroundarabic[(][)]{}{.}
\usepackage{geometry}
\geometry{a4paper,includehead, includefoot, left=20mm,right=20mm,top=20mm,bottom=10mm}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[]{biblatex}
 
\begin{document}

\section{Fazit}
Um die Eigenschaften und den Gehalt von Grundsätzen zu bestimmen, eignet sich das Regel"=/Prinzipienmodell von \textit{Alexy}. Es gibt eine Vielzahl von Ansatzpunkten, um eine Regel von einem Prinzip zu unterscheiden. Das entscheidende Kriterium ist letztlich jedoch die qualitative Unterscheidung zwischen einer Regel und einem Prinzip.
\end{document}

_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Books heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.08.2017, 15:18     Titel:
  Antworten mit Zitat      
Ich würde eher Regel"~"/Prinzipienmodell verwenden, denn vor dem Slash will man ja normalerweise keinen Umbruch erlauben, sondern nur danach (und an allen normalen Trennstellen).

Bartman
Forum-Meister
Forum-Meister


Beiträge: 937
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 28.08.2017, 15:38     Titel:
  Antworten mit Zitat      
Ich bin eher für Regel"~/""Prinzipienmodell.

@KJung

Lesetipp: http://texwelt.de/wissen/fragen/31
Private Nachricht senden Benutzer-Profile anzeigen

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 82
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 29.08.2017, 09:41     Titel:
  Antworten mit Zitat      
Danke, im Text funktioniert das super. In meinem Literaturverzeichnis funktioniert der Seitenumbruch jedoch nicht korrekt. Bzw. der Rand wird dort auch nicht eingehalten, obwohl die Quelle kein Bindestrich oder ähnliches beinhaltet. Insgesamt tritt der Fehler bei mir in zwei Quellen auf (Enders und Pietsch) Eine dritte Quelle habe ich beigefügt um zu zeigen, wie der Umbruch aussehen sollte.



Code • Öffne in Overleaf


\begin{filecontents}{quellen.bib}
 
@book{Enders,
   Address = {Tübingen
},
   Author = {Enders, Christoph},
   Date-Added = {2017-01-13 08:15:58 +0000},
   Date-Modified = {2017-08-29 07:20:34 +0000},
   Number = {Die Menschenwürde in der Verfassungsordnung},
   Publisher = {Mohr Siebeck},
   Title = {Die Menschenwürde in der Verfassungsordnung},
   Year = {1997}}

@book{Pietsch,
   Address = {Baden-Baden
},
   Author = {Pietsch, Jörg},
   Date-Added = {2017-01-18 11:31:32 +0000},
   Date-Modified = {2017-08-29 07:29:10 +0000},
   Number = {Das Schrankenregime der EU-Grundrechtecharta},
   Publisher = {Nomos},
   Title = {Das Schrankenregime der EU-Grundrechtecharta},
   Year = {2005}}

@book{HobeHabil,
   Address = {Berlin
},
   Author = {Hobe, Stephan},
   Date-Added = {2016-12-06 13:55:04 +0000},
   Date-Modified = {2016-12-06 13:56:32 +0000},
   Publisher = {Duncker & Humblot},
   Title = {Der offene Verfassungsstaat zwischen Souveränität und Interdependenz},
   Year = {1996}}

\end{filecontents}

\begin{filecontents}{Literaturvorlage1.bbx}
 \ProvidesFile{Literaturvorlage1}[2016/12/14 v0.1f biblatex bibliography style]

\RequireBibliographyStyle{authortitle-dw}%

\ExecuteBibliographyOptions{editorstring=parens}% Hrsg. oder Begr. in runde Klammern (biblatex-dw)

% Zusätzlicher Abstand zwischen den LitVerz-Einträgen
\setlength{\bibitemsep}{3pt}%

% Trennzeichen hinter dem Namen im LitVerz
\renewcommand*{\labelnamepunct}{\addcomma\space}

%Namen der Autoren werden kursiv geschrieben
\renewcommand*{\mkbibnamefirst}[1]{\textit{#1}}
\renewcommand*{\mkbibnamelast}[1]{\textit{#1}}

% LitVerz-Format von Büchern  
% Ein 'zitiert als:' bei Büchern, wenn vom gleichen Autor mehrere Werke zitiert werden
\DeclareBibliographyDriver{book}{%
  \usebibmacro{bibindex}%
  \usebibmacro{author/editor}%
  \newunit
 % \usebibmacro{namex}%            <-- Begr. uä als Autoren      !!!
  %\usebibmacro{editorx}%         <-- Begr. uä als Hrsg.         !!!
  \setunit{\labelnamepunct}\newblock
  \usebibmacro{maintitle+title}%
  \newunit
  \printlist{language}%
  \newunit\newblock
  \printfield{edition}%
  \newunit
  \usebibmacro{volumes+volume+part}%
  \setunit{\addspace}%
  \usebibmacro{series+number}%
  \newunit\newblock
  \usebibmacro{publisher+location+date}%
  \newunit\newblock
  \usebibmacro{chapter+pages}%
  \printfield{addendum}%
  \newunit\newblock%
   \addcomma\addspace%            <-- 'zitiert als:' eingefügt und danach die Zitation
    \textit{zitiert}%              <-- mit shorttitle/title ausgegeben
    \addnbspace%                   <--
    \textit{als}%                  <--
    \addcolon%                     <--
    \addnbspace%                  <--
      \printnames{labelname}%         <--
    \addcomma%                  <--
    \addnbspace%               <--
   \printfield{author/editor}
   \addcomma
   \addnbspace
   \printfield{title}
  \usebibmacro{finentry}}%

\end{filecontents}

\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage{alnumsec}
\surroundarabic[(][)]{}{.}
\usepackage{geometry}
\geometry{a4paper,includehead, includefoot, left=20mm,right=20mm,top=20mm,bottom=10mm}
\usepackage[babel, german=quotes]{csquotes}
\usepackage[bibstyle=Literaturvorlage1]{biblatex}
\bibliography{quellen}
\begin{document}

Hallo Welt\footcite{Pietsch}
Hallo Mond\footcite{Enders}
Hallo Pluto\footcite{HobeHabil}

\printbibliography
\end{document}

 
Private Nachricht senden Benutzer-Profile anzeigen

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 82
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 30.08.2017, 14:06     Titel:
  Antworten mit Zitat      
Liebes Forum,
ich habe das Problem im Literaturverzeichnis mit dem Befehl:
Code • Öffne in Overleaf
\usepackage{microtype}


beheben können.
Danke für Eure Hilfe.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 30.08.2017, 23:26     Titel:
  Antworten mit Zitat      
Ich würde ja darauf tippen, dass die vielen \addnbspaces in Deinem Code dafür sorgen, dass nicht umbrechbare Leerzeichen gesetzt werden, das kann natürlich die Zeilen etwas durcheinanderbringen. (Ein Indiz dafür ist, dass das Problem genau an der 'zitert als'-Stelle Auftritt) Setze vielleicht lieber normale, umbrechbare Leerzeichen (\addspace) - oder wähle die nicht umbrechbaren Stellen mit Bedacht, streue sie nicht so sorglos umher, wie Du es jetzt tust.

Idealerweise würdest Du auch den 'punctuation tracker' voll ausnutzen, indem Du \setunit und \printtext verwendest. Näheres dazu in der Dokumentationbiblatex-Dokumentation im Abschnitt 4.11.7 Using the Punctuation Tracker. Ansonsten kann es mit Deinem jetzigen Code zu ungewollter Doppelung von Zeichensetzung kommen. Ebenso birgt das Vermischen von Code, in dem der punctuation tracker genutzt wird, und solchen, bei dem das nicht der Fall ist, Gefahr, dass man den tracker verwirrt.

Die meisten Stil-Autoren würden den von Dir eingefügten 'zitiert als'-Teil wohl der Übersicht halber als Makro auslagern. \printfield{author/editor} tut übrigens gar nichts, da es ein Feld mit dem Namen author/editor nicht gibt.

Dein InfoMinimalbeispiel funktioniert bei mir in einem leeren Ordner ohne weitere Änderungen wieder nicht (Boolean '\ifcbx:omiteditor' undefined., wahrscheinlich, weil Dein Beispiel keinen Code für die .cbx mitbringt), daher sehe ich auch davon ab, meine Vorschläge direkt implementiert in Codeform zu präsentieren.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 31.08.2017, 08:25     Titel:
  Antworten mit Zitat      
Sollten die nicht umbrechbaren Leerzeichen tatsächlich zwingend sein, sollte man sich überlegen, ob man das Literaturverzeichnis nicht eher im Flattersatz statt im Blocksatz setzt. Übrigens ist \bibliography bei Paket auf CTANbiblatex deprecated. Verwende besser \addbibresource{quellen.bib} (darauf achten, dass die Endung hier nicht optional ist).

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de