goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Kopfzeile im Anhang ändern

 

einspluseins
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 07.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.08.2017, 02:35     Titel: Kopfzeile im Anhang ändern
  Antworten mit Zitat      
Hi,

bei mir sieht die Kopfzeile im Anhang meiner Arbeit bisschen seltsam aus.
Ein Bild davon hab ich hier im Anhang hochgeladen.
Es steht halt Anhang A. Anhang da.
Kann man das irgendwie ändern, sodass nur einmal Anhang dort steht?

Hier ist noch mein Code:
Code • Öffne in Overleaf

\appendix
\newpage
%\pagenumbering{roman}
\newpage
\addcontentsline{toc}{chapter}{Literaturverzeichni}
\renewcommand{\refname}{Literaturverzeichni}
\bibliography{lib}

\newpage
\chapter{Anhang}
\newpage
\section{Technische Zeichnungen}



Danke und viele Grüße

einspluseins
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.08.2017, 08:26     Titel:
  Antworten mit Zitat      
Das liegt am generell falschen Vorgehen: → Wie setzt man korrekt einen Anhang?

Stamm-
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.08.2017, 09:44     Titel: Code-Fragmente gehen gar nicht
  Antworten mit Zitat      
Da gibt es auch noch eine andere wichtige Sache.

einspluseins
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 07.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.08.2017, 15:15     Titel:
  Antworten mit Zitat      
Ich würde gerne die Nummerierung beibehalten. Also A1, A2, usw.
Nur dass in der Kopfzeile 2x Anhang steht, schaut ein wenig seltsam aus.

Hier ist mein VM. Ich kann leider immer noch nicht alle Befehle so gut, deswegen sind vermutlich noch viele drin, die nichts mit dem Anhang zu tun haben. Sorry dafür.
Code • Öffne in Overleaf
\documentclass[a4paper,12pt]{scrreprt}
\usepackage[left= 4cm,right = 4cm,top = 3 cm,bottom = 3 cm]{geometry}
\usepackage[onehalfspacing]{setspace}

\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{graphicx, subfig}
\graphicspath{{img/}}
\usepackage{fancyhdr}
\usepackage{lmodern}
\usepackage{acronym}
\usepackage{pdfpages}
\usepackage{mwe}

\setlength{\parindent}{0pt}


\pagestyle{fancy}

\lhead{}
\chead{
}
\rhead{\slshape \leftmark
}

\lfoot{}
\cfoot{\thepage
}
\rfoot{}

\renewcommand{\headrulewidth
}{0.4pt}
\renewcommand{\footrulewidth}{0pt}


\begin{document}


\pagestyle{fancy}
\pagenumbering{Roman}


\bibliographystyle{alpha}


\appendix
\newpage
\addcontentsline{toc}{chapter}{Literaturverzeichnis}
\renewcommand{\refname}{Literaturverzeichnis}
\bibliography{lib}

\newpage
\chapter{Anhang}
\newpage
\section{Technische Zeichnungen 1}
\includepdf[landscape=true, pages=-]{example-image}

\section{Technische Zeichnungen 2}
\includepdf[landscape=true, pages=-]{example-image}


\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.08.2017, 16:11     Titel:
  Antworten mit Zitat      
Die Verwendung von Paket auf CTANfancyhdr mit einer KOMA-Script-Klasse wird ausdrücklich nicht empfohlen. Es gibt hier im Forum dazu sicher Dutzende Hinweise und teilweise auch Gründe. Das Beispiel zeigt quasi einen weiteren. Ohne das Paket, nur mit \pagestyle{headings} tritt das Problem gar nicht erst auf. Ebenso tritt es nicht mit Paket auf CTANscrlayer-scrpage auf. Mit Paket auf CTANfancyhdr muss man stattdessen \chaptermark umdefinieren, um dort das von Paket auf CTANfancyhdr fest voreingestellte \@chapapp los zu werden.

Das Abschalten der Absatzauszeichnung mit \setlength{\parindent}{0pt} wird ausdrücklich nicht empfohlen. Wer keinen Absatzeinzug mag solle zumindest Absatzabstand verwenden. Siehe dazu Option parskip in der KOMA-Script-Anleitung oder im KOMA-Script-Buch. Derzeit ist die Absatzauszeichnung einfach nur abgeschaltet. Man könnte also (etwas überspitzt gesagt) auch einfach auf Absätze verzichten.

Bei KOMA-Script sollte man eigentlich nie \addcontentsline verwenden. Unterste Ebene sollte \addxcontentsline sein. Statt \addcontentsline{toc}{chapter}{…} wäre eigentlich \addchaptertocentry{…}zu verwenden. Korrekt macht man aber den Inhaltsverzeichniseintrag für das Literaturverzeichnis einfach mit Option bibliography=totoc oder wahlweise toc=bibliography.

Die ganzen \newpage sollten eher \clearpage oder \cleardoublepage sein.

Ein \newpage o.ä. nach \chapter erscheint wenig sinnvoll. Das sieht sehr danach aus, dass eigentlich \part oder \addpart zu verwenden wäre.

Eine Überschrift "Anhang" ist insgesamt fragwürdig. Näheres dazu ist unter dem oben bereits erwähnten Link ausführlich dargelegt.

esdd
Forum-Meister
Forum-Meister

Beiträge: 2219
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 20.08.2017, 10:31     Titel:
  Antworten mit Zitat      
Wenn Du scrlayer-scrpage mit einer KOMA-Script Klasse verwendest, kannst Du beispielsweise mit Option chapterprefix ganz einfach entscheiden ob ein Präfix für Kapitel verwendet werden soll. Das gilt dann einheitlich für die Überschrift und den Kopfzeileneintrag. Möchte man im Anhang ein anderes Verhalten als im Hauptdokument kann man zusätzlich die Option appendixprefix nutzen und diese in dem Fall gleich false setzen. Trotzdem, A. Anhang sieht für mich auch komisch aus.


Code • Öffne in Overleaf
\documentclass[a4paper,12pt,
  bibliography=totoc,
  parskip=half,% verwende Absatzabstand statt -einzug
  %chapterprefix, % verwende Präfix für Kapitel
  %appendixprefix=false % aber nicht im Anhang
]{scrreprt}
\usepackage[left= 4cm,right = 4cm,top = 3 cm,bottom = 3 cm]{geometry}
\usepackage[onehalfspacing]{setspace}

\usepackage[utf8]{inputenc}
\usepackage[ngerman]{babel}
\usepackage[T1]{fontenc}
\usepackage{graphicx}
\usepackage{subfig}
\graphicspath{{img/}}
\usepackage[
  headsepline,
  automark,
  %markcase=upper% falls wirklich gewünscht
]{scrlayer-scrpage}% aktiviert Seitenstil scrheadings automatisch
\usepackage{lmodern}
\usepackage{acronym}
\usepackage{pdfpages}
\usepackage{mwe}

\clearpairofpagestyles
\ohead{\headmark}
\cfoot*{\pagemark}

\renewcaptionname{ngerman}{\bibname}{Literaturverzeichnis}
\bibliographystyle{alpha}
\begin{document}
\blinddocument

\cleardoubleoddpage
\pagenumbering{Roman}
\appendix
\bibliography{lib}
\chapter{Anhang}
\section{Technische Zeichnungen 1}
\includepdf[landscape=true, pages=-]{example-image}
\section{Technische Zeichnungen 2}
\includepdf[landscape=true, pages=-]{example-image}
\end{document}
 


Edit: \bibname statt \refname nach Hinweis von Gast

Zuletzt bearbeitet von esdd am 20.08.2017, 11:09, insgesamt einmal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.08.2017, 10:55     Titel:
  Antworten mit Zitat      
Paket auf CTANscrreprt verwendet nicht \refname sondern \bibname.

Die bis auf Überschriften leere Seiten vor den eingebundenen PDFs sehen seltsam aus. Da sollte man zumindest noch eine Erklärung unterbringen, was auf den Folgeseiten kommt. Je nach PDF bestünde eventuell auch die Möglichkeiten Überschrift und erste Seite des PDFs auf eine Seite zu bekommen.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de