goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Harvardstyle funktioniert nicht

 

zuckerguss9
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.08.2017, 12:11     Titel: Harvardstyle funktioniert nicht
  Antworten mit Zitat      
Hallöchen,

ich schreibe gerade an meiner Bachelorarbeit und konnte mich bisher ganz gut durchwurschteln. Jetzt bin ich allerdings auf das Problem gestoßen, dass \bibliography{agsm} weder mit dem package "harvard" noch mit dem package "natbib" funktioniert. Wenn ich z.B. den Style {alpha} nehme und das "harvard" package lade funktioniert auch das zitieren nicht mehr (da stehen dann anstatt der Zitate nur noch "?" in der Klammer).

Eigentlich würde mir der Harvard-Stil im beim zitieren reichen, es müsste nicht unbedingt im Literaturverzeichnis auftauchen. Könnte mir da vielleicht jemand weiterhelfen?

Code • Öffne in Overleaf

\documentclass[a4paper,listof=totoc, index=totoc, bibliography=totoc]{scrreprt}      
\usepackage[T1]{fontenc}            
\usepackage[utf8]{inputenc}        
\usepackage[english]{babel}        
\usepackage{lmodern}            
\usepackage{natbib}
%\usepackage{harvard}


\begin{filecontents}{literatur.bib}
@Book{book,
author = {Vorname Nachname
},
title = {Titel},
publisher = {Verlag},
year = {2222},
}
\end{filecontents}

\begin{document}

Hier steht ein Text \cite{book}
\bibliography{literatur}
\bibliographystyle{agsm}

\end {document}
 
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.08.2017, 12:34     Titel:
  Antworten mit Zitat      
Wichtige Hinweise: Erstellung von Literaturverzeichnissen gelesen?

zuckerguss9
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.08.2017, 06:27     Titel:
  Antworten mit Zitat      
Ja, allerdings habe ich meine Bibliothek nicht mit dem Package Biblatex eingebaut. Als ich es umgebaut habe, wurde mir das Verzeichnis nicht mehr angezeigt und die ganzen Verweise gingen natürlich dann auch nicht mehr. Schön wäre es, wenn es mit meiner Grundstruktur funktionieren würde...
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Guru
Forum-Guru

Beiträge: 417
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 11.08.2017, 07:21     Titel:
  Antworten mit Zitat      
zuckerguss9 hat Folgendes geschrieben:
Als ich es umgebaut habe, wurde mir das Verzeichnis nicht mehr angezeigt und die ganzen Verweise gingen natürlich dann auch nicht mehr. Schön wäre es, wenn es mit meiner Grundstruktur funktionieren würde...


Wäre es nicht schöner, eine aktuelle und sehr gut anpassbare Struktur zu haben, für die es jede Menge Support gibt, statt ein veraltetes und nicht mehr gepflegtes Paket zu nutzen?
Hast du die Anleitung genau befolgt? Dann sollte folgendes Beispiel laufen und deinen Wünschen schon einigermaßen gerecht werden. Evtl. hilft dir auch wie-verwende-ich-biber-in-meinem-editor.

Code • Öffne in Overleaf
\documentclass[
listof=totoc,
index=totoc,
bibliography=totoc
]{scrreprt}      
\usepackage[T1]{fontenc}            
\usepackage[utf8]{inputenc}        
\usepackage[english]{babel}        
\usepackage{lmodern}            

\usepackage[style=authoryear,autocite=footnote]{biblatex}
\addbibresource{literatur.bib}

\begin{filecontents}{literatur.bib}
@Book{book,
author = {Vorname Nachname
},
title = {Titel},
publisher = {Verlag},
year = {2222},
}
\end{filecontents}

\begin{document}

Hier steht ein Text \textcite{book}.
Noch etwas\autocite[12]{book}
\printbibliography

\end {document}

_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

nixversteh
Forum-Guru
Forum-Guru

Beiträge: 445
Anmeldedatum: 10.08.10
Wohnort: Wrestedt
Version: Linux Mint 18.2 Sonya MATE Edition, 64bit Texlive 2017
     Beitrag Verfasst am: 11.08.2017, 07:24     Titel: ...
  Antworten mit Zitat      
@zuckerguss9,

... beide Versionen laufen bei mir ohne Fehler und Warnungen.
_________________

Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehrt wert, als Millionen von jener.
(Gotthold Ephraim Lessing)
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

zuckerguss9
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.08.2017, 10:12     Titel:
  Antworten mit Zitat      
markusv hat Folgendes geschrieben:

Wäre es nicht schöner, eine aktuelle und sehr gut anpassbare Struktur zu haben, für die es jede Menge Support gibt, statt ein veraltetes und nicht mehr gepflegtes Paket zu nutzen?
Hast du die Anleitung genau befolgt? Dann sollte folgendes Beispiel laufen und deinen Wünschen schon einigermaßen gerecht werden. Evtl. hilft dir auch wie-verwende-ich-biber-in-meinem-editor.


Ich habe schon versucht das Verzeichnis so einzubauen, es wird damit aber weder im Inhaltsverzeichnis aufgeführt noch taucht es im Dokument auf. Außerdem sehen die Zitate dann nicht aus wie gewünscht, dort wird nur das von mir erstellte Kürzel gezeigt und dann auch noch fettgedruckt (siehe Anhang)
Den Link habe ich auch schon entdeckt. Ich verwende Miktex und Biber ist schon integriert, hat aber leider auch nichts gebracht...

Vielen Dank schon mal für eure Hilfe und die schnellen Antworten

Unbenannt.PNG
 Beschreibung:

Download
 Dateiname:  Unbenannt.PNG
 Dateigröße:  1.89 KB
 Heruntergeladen:  31 mal
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Guru
Forum-Guru

Beiträge: 417
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 11.08.2017, 10:32     Titel:
  Antworten mit Zitat      
zuckerguss9 hat Folgendes geschrieben:
dort wird nur das von mir erstellte Kürzel gezeigt und dann auch noch fettgedruckt (siehe Anhang)


Das zeigt, dass du biber überhaupt nicht oder nicht richtig aufgerufen hast. Hast du die Einstellungen in deinem Editor vorgenommen, wie bspw. im Link gezeigt?
_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Book heißen.

Unkomplizierte und schnelle LaTeX-Hilfe, bspw. Erstellung von Vorlagen und Bewerbungen:
Help-LaTeX@web.de
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.08.2017, 10:51     Titel:
  Antworten mit Zitat      
Schau dir mal den Link im allerersten Kommentar an. Die Frage hast du leider nie beantwortet. Nimm sie als rhetorische Frage und arbeite die Seite, Schritt für Schritt durch. Das kostet dich vielleicht eine Stunde. Dafür sollte die Literatur dann funktionieren und du weißt dann auch, wie die Anpassung des Stils an irgendwelche Vorgaben generell funktioniert.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 11.08.2017, 11:16     Titel:
  Antworten mit Zitat      
Also zunächst keine ich Dein erstes Problem nicht nachvollziehen. agsm.bst funktioniert super mit Paket auf CTANharvard (es ist ja auch Teil dieses Pakets)
Code • Öffne in Overleaf
\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage[english]{babel}
\usepackage{lmodern}
\usepackage{harvard}

\usepackage{filecontents}
\begin{filecontents}{\jobname.bib}
@Book{book,
author = {Vorname Nachname
},
title = {Titel},
publisher = {Verlag},
year = {2001},
}
\end{filecontents}

\begin{document}
Hier steht ein Text \cite{book}
\bibliography{\jobname}
\bibliographystyle{agsm}
\end{document}
läuft bei mir wie erwartet ohne Probleme und mit einer Autor-Jahr-Ausgabe durch.

Harvard-Stil ist übrigens keine "geschützte" oder genau definierte Angabe (im Gegensatz zu APA-Stil oder Chicago gibt es keine Autorität, die mit der Herausgabe eines Handbuchs einen offiziellen Stil etabliert hätte, es gibt natürlich Seiten im Internet, die einen Harvard-Stil vorstellen, da sind teilweise auch Unis dabei, aber die Details unterscheiden sich und keiner hat davon Jurisdiktion über die eigenen Studenten und Untergebenen hinaus, es gibt keine Referenzvorgabe https://www.ncbi.nlm.nih.gov/pmc/ar.....803/pdf/bmj00308-0078.pdf). Es bedeutet für gewöhnlich nur Autor-Jahr-Stil. Wenn man Dir also keine weiteren Vorgaben gemacht hat, hast Du also recht viel Spielraum.
Wenn Du aber unbedingt agsm.bst nutzen musst, da das von höherer Stelle verlangt ist (schreibst Du für die australische Regierung?), dann sollte Dein Dokument wie oben aussehen.

Ich kann mich den anderen Diskussionsteilnehmern hier aber anschließen, dass ich Dir biblatex mit Biber ans Herz legen möchte.

Ein "Harvard-Stil" - also eine Autor-Jahr-Stil wäre
Code • Öffne in Overleaf
\documentclass{article}
\usepackage[T1]{fontenc}
\usepackage[utf8]{inputenc}
\usepackage{lmodern}
\usepackage[english]{babel}
\usepackage{csquotes}

\usepackage[style=authoryear]{biblatex}
\addbibresource{biblatex-examples.bib}

\begin{document}
Hier steht ein Text \textcite{sigfridsson} \cite{worman} \parencite[siehe][34]{geer}.
Noch etwas \autocite[12]{companion}
\printbibliography
\end{document}


Jetzt musst Du aber statt BibTeX Biber nutzen. Dafür musst Du Deinen Editor umstellen http://www.texwelt.de/wissen/fragen.....ch-biber-in-meinem-editor (vergleiche Deine Einstellung genau mit der dort gezeigten; achte darauf, dass Du nicht einen dieser 'Nutze einen Build-Ordner' oder 'Verschiebe die Ausgabe in einen anderen Ordner', 'lösche temporäre Dateien' Optionen ausgewählt hast, die viele Editoren zwar anbieten, von denen aber auch erfahrene Nutzer explizit abraten, gesetzt hast.)
Wenn Du das getan hast und Du Biber auch aufrufst, sollte eigentlich alles funktionieren.

Solltest Du wider Erwarten nicht die erwartete Ausgabe bekommen, muss es beim Lauf von Biber Fehler gegeben haben. Biber schreibt hilfreiche Hinweise in eine Logdatei mit der Endung .blg (unter Windows werden .blg-Dateien als 'Leistungsüberwachungsdatei' erkannt, sie sind aber einfache Textdateien und Du kannst sie mit Deinem Lieblingseditor öffnen). Der Inhalt dieser Datei sollte Dir Aufschluss geben können, was verkehrt läuft. Ebenso solltest Du Dir die .log-Datei von TeX ansehen, sie ist recht lang, daher ist es eine gute Idee gezielt nach "warning" oder "error" zu suchen.

Hinweise für Problemen mit Biber gibt es bei Markus Kohm https://komascript.de/biber und TeX.SX https://tex.stackexchange.com/a/287811/

Es kann auch eine gute Idee sein, dein Testdokument aus der Kommandozeile zu kompilieren. http://texwelt.de/wissen/fragen/346.....eaufforderung-im-terminal
Unter der Annahme, dass das Testdokument test.tex heißt, musst Du dann nacheinander und in der Reihenfolge
Code • Öffne in Overleaf
pdflatex test
biber test
pdflatex test
pdflatex test

ausführen.
Erst nach dem letzten Lauf von pdfLaTeX solltest Du Dir Dein Dokument sowie die .log und blg-Datei ansehen.

Welchen Editor nutzt Du denn?

zuckerguss9
Forum-Newbie
Forum-Newbie

Beiträge: 5
Anmeldedatum: 10.08.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.08.2017, 07:36     Titel:
  Antworten mit Zitat      
Zunächst mal vielen Dank für die ganze Hilfe. Im Minimalbeispiel klappt jetzt alles wunderbar, allerdings noch nicht in meinem Dokument...

Dert wirft mir verschiedene Fehler aus, wobei ich leider ad hoc nicht sagen kann woher die kommen, da sie vorher nie aufgetaucht sind.

Code • Öffne in Overleaf

16
File ended while scanning use of \field.
<inserted text>
                \par
l.16 \begin{document}

55
Illegal parameter number in definition of \NewCount.
<to be read again>
                   1
l.55 \begin{itemize}

55
Missing \endcsname inserted.
<to be read again>
                   \global
l.55 \begin{itemize}
55
Undefined control sequence.
<argument> \blx@bbl@data
                         
l.55 \begin{itemize}
55
Missing \endcsname inserted.
<to be read again>
                   \global
l.55 \begin{itemize}
55
TeX capacity exceeded, sorry [input stack size=5000].
\font@name ->
             \T1/lmss/bx/n/14.4
l.55 \begin{itemize}

==> Fatal error occurred, no output PDF file produced!

 


Könnt ihr mir da vielleicht auch nochmal weiterhelfen?
(Und ja, überall wo \begin{itemize} steht ist auch das zugehörige \end{itemize})

Ich benutze Miktex, also Texworks.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite 1, 2  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de