goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Kopfzeile Literaturverzeichnis ohne Sectionnummer

 

alex2007
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.07.2017, 20:27     Titel: Kopfzeile Literaturverzeichnis ohne Sectionnummer
  Antworten mit Zitat      
Hallo, ich schreibe gerade meine Masterarbeit und verwende scrpage2 für das managen von Kopfzeilen. Klappt auch alles wunderbar, bis auf das Literaturverzeichnis. Normal steht auf den Seiten links der Sectionname und auf den Seiten rechts der Subsectionname, so wie gewollt. Das Literaturverzeichnis erscheint unnummeriert im TOC. Sobald das Literaturverzeichnis aber mehr als eine Seite umfasst, musste ich feststellen, dass auf der zweiten Seite (Seite rechts) in der Kopfzeile "0 Literaturverzeichnis" steht. Diese "0" soll da aber weg. Ich habe bereits \markboth und \renewcommand*{\sectionmarkformat}{} probiert, leider beides ohne Erfolg.

Anbei ein Minimalbeispiel:

Code • Öffne in Overleaf
\documentclass[
 paper=A4,pagesize=automedia,fontsize=12pt,
 BCOR=15mm,DIV=22,
 twoside,headinclude,footinclude=false,
 version=first,
 ngerman,fleqn,             % fleqn = linksbündige Ausrichtung von Formeln
 bibliography=totocnumbered,          % Literaturverz. im Inhaltsverz. eintragen
 listof=totoc,                % Abbildungsverz. im Inhaltsverz. eintragen
 listof=flat,                 % Abbildungsverz. an der längsten Nummer ausrichten
 numbers=noenddot,          % kein Punkt nach Überschriftsnummerierung
 cleardoublepage=empty      % Vakatseiten ohne Paginierung
]{scrbook}
\setlength\parindent{0em}

% Kodierung, Schrift und Sprache auswählen
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage[ngerman]{babel}
% damit man Text aus dem PDF korrekt rauskopieren kann
\usepackage{cmap}
% Layout: Kopf-/Fußzeilen, anderthalbfacher Zeilenabstand
\usepackage{scrpage2} \pagestyle{scrheadings}
                      \clearscrheadfoot
                      \ihead{\headmark}\ohead{\pagemark}
                      \automark[subsection]{section}
                      \setheadsepline{0.5pt}
\usepackage{setspace} \onehalfspacing
\deffootnote{1em}{1em}{\textsuperscript{\thefootnotemark }}
% Grafiken, Tabellen, Mathematikumgebungen
\usepackage{graphicx,xcolor,subfigure}
\usepackage{tabularx}
\usepackage{amsmath,amsfonts,amssymb}
% Darstellung von Fließumgebungen
\usepackage{flafter,afterpage}
\usepackage[section]{placeins}
\usepackage[margin=8mm,font=small,labelfont=bf,format=plain]{caption}
\usepackage{booktabs}%Tabellen wissenschaftlich

\begin{document}
\section{Punk 1}
\cite{henig2009}
\cite{Zeil2010}
\cite{maiman1960}
\cite{eichhorn2012}
\cite{bergstrand2013}
\cite{hecht2002}
\cite{haefer2013}
\cite{jaeckel2010}
\cite{saleh2008}
\cite{simulation}
\cite{f20}
\newpage
\bibliographystyle{plain}
\cleardoublepage
\bibliography{master}
\end{document}


Die Sectionnumerrierung ist im Original-Dokument natürlich anders, was ja aber jetzt keine Rolle spielt. Bei den Zitationen ist es wichtig, dass es genug sind, dass mehr als eine Seite Literaturverzeichnis angezeigt werden.

In dem Minimalbeispiel erscheint "1 Literaturverzeichnis".

Wie bekomme ich die Ziffer vor "Literaturverzeichnis" weg? Da soll dann logischerweise auch auf den anderen Seiten der Literatur so sehen und nicht nur auf der zweiten.

Danke im Voraus.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.07.2017, 22:31     Titel:
  Antworten mit Zitat      
Ich habe ehrlich gesagt Schwierigkeiten, mit Deinem Beispiel das Problem nachzuvollziehen. Dank bibliography=totocnumbered wird das Literaturverzeichnis nämlich mit Nummer versehen und auch so ins Inhaltsverzeichnis eingetragen. Damit ist auch klar, dass es im Kopf eine Nummer erhält.

Verwendet man dagegen bibliography=totoc, dann hat das Literaturverzeichnis keine Nummer – auch nicht im Kolumnentitel.

Also mach bitte ein echtes InfoMinimalbeispiel nach der verlinkten Anleitung, damit wir das Problem auch nachvollziehen können.

BTW: Du arbeitest da anscheinend auf Grundlage einer total mistigen LaTeX-Vorlage. Wirf die lieber weg. Sie taugt nichts. Das beginnt schon mit Verwendung von Option version=first mit denen Du die typographischen Verbesserungen von KOMA-Script der letzten zehn Jahre abschaltest.

Typographischer Unfug ist ebenfalls \setlength\parindent{0em}. Damit schaltest Du Absatzauszeichnungen ab, könntest also auch einfach auf Absätze verzichten. Wenn Du keinen Absatzeinzug willst, schalte auf Absatzabstand um. Das geht mit Option parskip. Die diversen Möglichkeiten der Option findest Du in der KOMA-Script-Anleitung, Dokumentationscrguide und alternativ im KOMA-Script-Buch.

Paket Paket auf CTANscrpage2 ist veraltet. Siehe dazu die Dokumentationscrpage2-Anleitung oder auch die oben verlinkte KOMA-Script-Anleitung oder das Buch.

Das Paket Paket auf CTANsubfigure ist total veraltet und soll schon seit Jahren nicht mehr verwendet werden. Alternativen findest Du unter dem Paketlink.

Für ein neue Dokument würde ich auch eher die Verwendung von Paket auf CTANbiblatex und Paket auf CTANbiber empfehlen. Der BibTeX-Stil plain ist für Dokumente in Deutsch ohnehin nicht geeignet, das er nicht multilingual ist und daher Englische Begriffe verwendet. Die Paket auf CTANbiblatex Standard-Stile (und die meisten Zusatzstile) sind dagegen alle multilingual. Näheres zur Verwendung von Paket auf CTANbiblatex und Paket auf CTANbiber findest Du in den wichtigen Hinweisen zur Erstellung eines Literaturverzeichnisses

alex2007
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.07.2017, 09:06     Titel:
  Antworten mit Zitat      
Ja, das ist eine Univorlage, die eher mau ist. Hab da schon einiges verändert.
Welche Ändrungen an der Präambel würdest du vornehmen?

Zu den Nummern, als auch mit 'bibtotocnumbered' erscheint bei mir im toc "Literaturverzeichnis" ohne Nummer. Ergo ändert 'bibtotoc' nichts am Ergebnis. Habe ich auch schon probiert. Kannst also das Beipsiel mit Änderung bibtotoc verwenden.

Die Kopfzeile zeigt auf den Seiten links die Seitennummer nebst Name der Section (ohne Nummer) und auf den Seiten rechts entsprechend Sietenzahl und Name der Subsection (ohne Nummer).
Das Literaturverzeichnis beginnt auf einer Seite links mit "Literaturverzeichnis als Titel und entsprechend ohne Kopfzeile (wie das bei Kapiteln eben so ist). Auf der zweiten Seite des Literaturverzeichnisses (eine rechte Seite) steht in der Kopfzeile "0 Literaturverzeichnis" (in dem Minimalbeispiel ist es "1 Literaturverzeichnis".

Soweit zur Erklärung. Woran liegt das denn?

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.07.2017, 09:44     Titel:
  Antworten mit Zitat      
alex2007 hat Folgendes geschrieben:
Ja, das ist eine Univorlage, die eher mau ist. Hab da schon einiges verändert.
Welche Ändrungen an der Präambel würdest du vornehmen?

Ich würde sie wegwerfen und auf Basis des bereits angegebenen Link auf »Minimale Vorlage vs. maximale Probleme« beginnen.

alex2007 hat Folgendes geschrieben:
Zu den Nummern, als auch mit 'bibtotocnumbered' erscheint bei mir im toc "Literaturverzeichnis" ohne Nummer. Ergo ändert 'bibtotoc' nichts am Ergebnis. Habe ich auch schon probiert. Kannst also das Beipsiel mit Änderung bibtotoc verwenden.

Von den veralteten Optionen bibtotocnumbered und bibtotoc war weder die Rede noch ist in Deinem Code etwas zu sehen. Man sollte sie auch nicht verwenden. Aber selbst wenn ich sie verwende, kann ich Deine Behauptung nicht nachvollziehen. Daher erneut: Mach ein InfoMinimalbeispiel.

alex2007 hat Folgendes geschrieben:
Woran liegt das denn?

Solange wir kein InfoMinimalbeispiel haben, das diese Verhalten zeigt, ist das nicht zu beantworten.

Ohne InfoMinimalbeispiel weiter zu diskutieren halte ich ansonsten für sinnlos. Wenn Du Hilfe willst, wirst Du um ein InfoMinimalbeispiel nicht herum kommen.

esdd
Forum-Meister
Forum-Meister

Beiträge: 2215
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 25.07.2017, 09:57     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:

Ohne InfoMinimalbeispiel weiter zu diskutieren halte ich ansonsten für sinnlos. Wenn Du Hilfe willst, wirst Du um ein InfoMinimalbeispiel nicht herum kommen.


@alex2007 Wenn Du wissen möchtest, was Leser/Helfer mit Deinem Beispiel anfangen können bzw. was ihnen fehlt, klicke einfach auf den Link "Öffne in Overleaf" oberhalb Deines Codes.
Private Nachricht senden Benutzer-Profile anzeigen

alex2007
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.07.2017, 15:23     Titel:
  Antworten mit Zitat      
Danke an euch für die Anregungen.

Problem ist gelöst. "bibliography=totoc" statt "=totocnumbered" hat die Uahl entfernt. Seltsam, dass es im toc ohnehin Nummernlos war, aber gut.

LG Alex

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de