goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

\cite{} Zahlen nicht Bibtexkey

 

Franz
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 16:00     Titel: \cite{} Zahlen nicht Bibtexkey
  Antworten mit Zitat      
Hallo,
warum verwendet Latex bei mir im Dokument den Bibtexkey und gibt dort nicht einfach eine Nummer an?
Das Literaturverzeichnis wurde mit Jabref angelegt.

Code • Öffne in Overleaf

\usepackage[autostyle]{csquotes}

\usepackage[
    backend=biber,
    style=authoryear-icomp,
    sortlocale=de_DE,
    natbib=true,
    url=false,
    doi=true,
    eprint=false
]{biblatex}
\addbibresource{Literatur.bib}
 


zum zitieren habe ich \cite{bibtexkey} im Dokument stehen.

Falls der bibtexkey hallo heißen würde:
Es soll also beim ersten \cite eine [1] stehen und nicht [Hallo]

Vielen Dank im Voraus.
Franz [/code]

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3536
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 16:03     Titel:
  Antworten mit Zitat      
Du rufst biber nicht auf, oder biber läuft nicht ohne Fehler.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Franz
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 16:13     Titel:
  Antworten mit Zitat      
Sind da 2 Einträge falsch angelegt?

INFO - This is Biber 2.7 INFO - Logfile is 'IPA_V3.blg' INFO - Reading 'IPA_V3.bcf' INFO - Found 13 citekeys in bib section 0 INFO - Processing section 0 INFO - Looking for bibtex format file 'Literatur.bib' for section 0 INFO - Decoding LaTeX character macros into UTF-8 INFO - Found BibTeX data source 'Literatur.bib' WARN - month field 'mar' in entry 'Aveston1973' is not an integer - this will probably not sort properly. WARN - I didn't find a database entry for 'Clau\IeC {\ss }' (section 0) INFO - Overriding locale 'de_DE' defaults 'normalization = NFD' with 'normalization = prenormalized' INFO - Overriding locale 'de_DE' defaults 'variable = shifted' with 'variable = non-ignorable' INFO - Sorting list 'nyt/global/' of type 'entry' with scheme 'nyt' and locale 'de_DE' INFO - No sort tailoring available for locale 'de_DE' INFO - Writing 'IPA_V3.bbl' with encoding 'UTF-8' INFO - Output to IPA_V3.bbl INFO - WARNINGS: 2

Bartman
Forum-Meister
Forum-Meister


Beiträge: 937
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 06.07.2017, 16:13     Titel: Re: \cite{} Zahlen nicht Bibtexkey
  Antworten mit Zitat      
Für einen Literaturverweis mit einer Nummer in eckigen Klammern benötigst Du außerdem einen numeric-Stil.
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3536
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 16:15     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
WARN - I didn't find a database entry for 'Clau\IeC {\ss }' (section 0)


Verwende keine nicht-ASCII-Zeichen in bibtex-keys. "Clauß" ist keine gute Idee.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Franz
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 16:25     Titel:
  Antworten mit Zitat      
u_fischer hat Folgendes geschrieben:
Code • Öffne in Overleaf
WARN - I didn't find a database entry for 'Clau\IeC {\ss }' (section 0)


Verwende keine nicht-ASCII-Zeichen in bibtex-keys. "Clauß" ist keine gute Idee.


Ist geändert. Jetzt klappt es auch.

Gibt es bei dem style numeric auch eine Variante oder Möglichkeit die nummerierung so vorzunehmen, dass das erste Zitat in der Arbeit die [1] bekommt, das zweite dann die [2] ?

Vielen Dank schonmal für eure Hilfen. Smile

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.07.2017, 17:39     Titel:
  Antworten mit Zitat      
Du suchst wohl die Option sorting=none.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de