goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Texmaker findet .bib file nicht

 

mcmellster
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 02.06.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.06.2017, 16:57     Titel: Texmaker findet .bib file nicht
  Antworten mit Zitat      
Hallo,

ich habe bisher noch nicht viel mit LaTex gearbeitet und bin jetzt auf ein Problem bei Quellenangaben gestoßen:

Ich arbeite mit Texmaker. Mein tex-File und mein bib-file liegen im selben Ordner auf der selben Ebene.

Wenn ich mein tex-file kompilieren lasse, bekomme ich die Warnung, dass meine Referenz undefiniert ist. Außerdem ist die Bibliographie leer. Er scheint offensichtlich das File nicht zu finden bzw. als bib.-file zu erkennen.

Übersehe ich was offensichtliches? Muss ich vor der Verwendung noch bei Texmaker etwas einstellen? Ich habe in der Konfigurationsdatei für den Pfad biblatex "biber %" eingestellt.

Danke im Voraus!

test.tex
 Beschreibung:

Download
 Dateiname:  test.tex
 Dateigröße:  659 Bytes
 Heruntergeladen:  26 mal
literature.bib
 Beschreibung:

Download
 Dateiname:  literature.bib
 Dateigröße:  71 Bytes
 Heruntergeladen:  17 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.06.2017, 18:06     Titel:
  Antworten mit Zitat      
Kannst Du uns die .blg-Datei zeigen? Unter Windows versteckt sie sich manchmal als 'Lesitungsüberwachungsdatei', sie ist aber eine einfache Text-Datei, die Du mit jedem Editor öffnen kannst und deren Inhalt Du einfach hier posten kannst.

Normalerweise sollte es absolut kein Problem sein, eine .bib-Datei im selben Ordner zu finden. Hast Du eine dieser unsäglichen 'nutze einen Build-Ordner' oder 'verschiebe/lösche alle temporären Dateien'-Optionen angeschaltet? Vergleiche zur Sicherheit Deine Einstellungen von Biber mit Biblatex with Biber: Configuring my.....avoid undefined citations/Wie verwende ich biber in meinem Editor?

Siehe auch Troubleshooting for biber.

mcmellster
Forum-Newbie
Forum-Newbie

Beiträge: 2
Anmeldedatum: 02.06.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.06.2017, 18:11     Titel:
  Antworten mit Zitat      
Danke für die Antwort. Das folgende ist der inhalt der Leistungsüberwachungsdatei:

This is BibTeX, Version 0.99dThe top-level auxiliary file: test.aux
I found no \citation commands---while reading file test.aux
I found no \bibdata command---while reading file test.aux
I found no \bibstyle command---while reading file test.aux
(There were 3 error messages)

Ich habe die Einstellungen von Texmaker auch noch mal zurückgesetzt um sicherzustellen, dass ich nichts falsches eingestellt habe.

Danke für die Links, die werde ich mal durchforsten.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 02.06.2017, 18:28     Titel:
  Antworten mit Zitat      
Diese .blg zeigt eindeutig, dass BibTeX aufgerufen wird und nicht Biber. Du musst also Deinen Editor so einstellen, dass er wirklich Biber aufruft. Das sollte in den Links beschrieben sein.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de