goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

fontspec Fehler obwohl kein fontspec benutzt

 

guest
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.05.2017, 10:19     Titel: fontspec Fehler obwohl kein fontspec benutzt
  Antworten mit Zitat      
Hallo,
seitdem ich mein TeX Live 2016 mit tlmgr geupdated habe, erhalte ich beim Versuch zu bauen folgenden Fehler:

! Fatal fontspec error: "cannot-use-pdftex"
!
! The fontspec package requires either XeTeX or LuaTeX.
!
! You must change your typesetting engine to, e.g., "xelatex" or
! "lualatex"instead of plain "latex" or "pdflatex".
!
! See the fontspec documentation for further information.
!
! For immediate help type H <return>.
!...............................................
l.28 \msg_fatal:nn {fontspec} {cannot-use-pdftex}
|'''''''''''''''''''''''''''''''''''''''''''''''
| This is a fatal error: LaTeX will abort.
|...............................................


Ich benutze aber gar kein fontspec Paket. Wird dieses durch ein anderes Paket referenziert?
Ein MWE mit allen von mir verwendeten Paketen, das den Fehler reproduziert:



Code • Öffne in Overleaf

\documentclass[                          
%DIV=14,
BCOR=3mm,                              
headsepline=1.9pt,                        
11pt,                                
oneside,                              
toc=listofnumbered,                        
bibliography=totoc,                        
toc=index,                              
numbers=noenddot,                        
headings=optiontotocandhead              
]{scrreprt}                        

\usepackage[
utf8                                
]{inputenc}                                    
 
\usepackage[
main=ngerman,                          
english                                
]{babel}                              

\usepackage[
german=quotes                          
]{csquotes}                              

\usepackage[                          
usenames,                              
dvipsnames,                              
svgnames,                              
table                                
]{xcolor}                                                  

\usepackage{tabularx}                    
\usepackage{tcolorbox}                    
\tcbuselibrary{skins}
\usepackage{hologo}                        
\usepackage{setspace}                    
\usepackage{varioref}                      
\usepackage[]{blindtext}                  
\usepackage{listings}                    
\usepackage{tkz-kiviat}                    
\usepackage{numprint}                    
\usepackage{enumitem}
%\usepackage{fullpage}                      
\usepackage{pgfplotstable}                  
%\usepackage{packages/pgf-pie}              
%\pgfplotsset{compat=1.7}                  
\usetikzlibrary{arrows}                    
\usepackage{hologo}                        
\usepackage{verbatim}
\usepackage{showframe}                    
\usepackage{caption}                      
\usepackage{etoolbox}
\usepackage{wrapfig}                    
\usepackage{bashful}
\usepackage{makeidx}
\makeindex                              
\usepackage[hyphens]{url}
\usepackage{smartdiagram}
\usepackage{metalogo}
\usepackage{dtk-logos}
\usepackage{amssymb}
\usepackage{fontawesome}
\usepackage{xr}                          

\usepackage{hyperref}                      
\hypersetup{
    bookmarks=true,                        
    unicode=false,                        
    pdftoolbar=true,                      
    pdfmenubar=true,                      
    pdffitwindow=true,                      
    pdfstartview={FitH
},                  
    pdftitle={My title},                  
    %pdfauthor={},              
    %pdfsubject={Subject},              
    %pdfcreator={},        
    %pdfproducer={Producer},                
    %pdfkeywords={keyword1, key2, key3},      
    pdfnewwindow=true,                    
    colorlinks=true,                        
    linkcolor=red,
    citecolor=green,                      
    filecolor=magenta,                    
    urlcolor=cyan                          
}

\usepackage[all]{hypcap}

\usepackage[
automark
]{scrlayer-scrpage}                  
\pagestyle{scrheadings}                    
\automark{section}                        
\ihead{\headmark}                        
\chead{}                              
%\cfoot{\pagemark}%                        

\usepackage[
backend=biber,                          
style=authoryear,                            
isbn=false,                                  
doi=false,                                
pagetracker=true,                            
maxbibnames=50,                              
maxcitenames=3,                              
autocite=inline,                            
block=space,                                
backref=true,                                
backrefstyle=three+,                        
date=short,                                  
]{biblatex}                              
\setlength{\bibitemsep}{1em}                
\setlength{\bibhang}{2em}                    

\usepackage{geometry}                      
\geometry{a4paper,                        
%head=13.6pt;                          
top=25mm,                              
left=30mm,                              
right=25mm,                            
bottom=30mm,                            
headsep=10mm,                            
footskip=12mm}                            

\setlength{\parindent}{0em}            

\begin{document}
lol
\end{document}
 

cgnieder
Forum-Meister
Forum-Meister


Beiträge: 676
Anmeldedatum: 22.10.10
Wohnort: Herrenberg
Version: TeX Live 2016
     Beitrag Verfasst am: 19.05.2017, 11:04     Titel:
  Antworten mit Zitat      
Indirekt lädst Du fontspec durchaus. Dieses MWE reicht, um die Fehlermeldung zu reproduzieren:

Code • Öffne in Overleaf
\documentclass{article}
\usepackage{dtk-logos}
\begin{document}
\end{document}


Fast die erste Zeile in dtk-logos ist
Code • Öffne in Overleaf
\RequirePackage{hologo,dantelogo,fontspec}


Grüße
_________________

Clemens
------------------------------
Paket auf CTANchemmacros · Paket auf CTANchemformula · Paket auf CTANleadsheets · Paket auf CTANtranslations · Paket auf CTANxsim.
Private Nachricht senden Benutzer-Profile anzeigen

guest
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.05.2017, 12:43     Titel:
  Antworten mit Zitat      
Vielen Dank!

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de