goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

nach makebst geht nichts mehr

 

PrinzeFlo
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.04.2017, 21:03     Titel: nach makebst geht nichts mehr
  Antworten mit Zitat      
Guten Abend,

ich wollte meine Zitate/Quellen etwas anders gestalten und habe dafür diese Anleitung befolgt: https://de.wikibooks.org/wiki/LaTeX-W%C3%B6rterbuch:_makebst

Zitat:
Mit Hilfe des LaTex-Programmes makebst ist es möglich, eigene Zitierstile zu erstellen.

Das Programm wird mit folgendem Befehl aufgerufen:

latex makebst
Danach läuft eine Art von Interview, an dessen Ende eine .bst-Datei ausgegeben wird. Diese wird dann über den Befehl \bibliographystyle eingebunden. Hierbei kann es passieren, dass LaTex mit der Fehlermeldung "File babelbst.tex not found" abbricht. Dieser Fehler wird wie folgt behoben:

man gehe in die Kommandozeile (am Apple z.B. mit dem Programm "Terminal")
dort gebe man ein: tex docstrip
die dann folgenden Fragen müssen wie folgt beantwortet werden:
\infileext=mbs
\outfileext=tex
\Options=bblbst
\filelist=merlin
\answer=n
Hierdurch wurde eine Datei merlin.tex erstellt, die man in babelbst.tex umbenennt. Die Datei kann nun noch editiert (also die Werte für "and", "editor" etc. in die gewünschte Sprache übertragen) werden. Anschließend muss sie in das selbe Verzeichnis wie die zu setzende LaTeX-Datei gelegt werden.


Jetzt geht, wie schon gesagt, nichts mehr. Teilweise wird nicht mal mehr Deckblatt etc als PDF ausgegeben.

Die .aux-Datei:
Code • Öffne in Overleaf
\relax
\providecommand\hyper@newdestlabel[2]{}
\catcode `"\active
\providecommand\HyperFirstAtBeginDocument{\AtBeginDocument
}
\HyperFirstAtBeginDocument{\ifx\hyper@anchor\@undefined
\global\let\oldcontentsline\contentsline
\gdef\contentsline#1#2#3#4{\oldcontentsline{#1
}{#2}{#3}}
\global\let\oldnewlabel\newlabel
\gdef\newlabel#1#2{\newlabelxx{#1}#2}
\gdef\newlabelxx#1#2#3#4#5#6{\oldnewlabel{#1}{{#2}{#3}}}
\AtEndDocument{\ifx\hyper@anchor\@undefined
\let\contentsline\oldcontentsline
\let\newlabel\oldnewlabel
\fi
}
\fi}
\global\let\hyper@last\relax
\gdef\HyperFirstAtBeginDocument#1{#1}
\providecommand\HyField@AuxAddToFields[1]{}
\providecommand\HyField@AuxAddToCoFields[2]{
}
\select@language{german
}
\@writefile{toc}{\select@language{german}}
\@writefile{lof}{\select@language{german}}
\@writefile{lot}{\select@language{german}}
\@writefile{toc}{\contentsline {chapter}{\numberline {1}Kapitel 1}{2}{chapter.1}}
\@writefile{lof}{\addvspace {10\p@ }}
\@writefile{lot}{\addvspace {10\p@ }}
\@writefile{toc}{\contentsline {section}{\numberline {1.1}Anfang}{2}{section.1.1}}


Und die .blg-Datei:
Code • Öffne in Overleaf
This is BibTeX, Version 0.99d (TeX Live 2016/Debian)
Capacity: max_strings=100000, hash_size=100000, hash_prime=85009
The top-level auxiliary file: Traubenwickler-Antagonisten.aux
I found no \citation commands---while reading file Traubenwickler-Antagonisten.aux
I found no \bibdata command---while reading file Traubenwickler-Antagonisten.aux
I found no \bibstyle command---while reading file Traubenwickler-Antagonisten.aux
You've used 0 entries,
            0 wiz_defined-function locations,
            83 strings with 528 characters,
and the built_in function-call counts, 0 in all, are:
= -- 0
> -- 0
< -- 0
+ -- 0
- -- 0
* -- 0
:= -- 0
add.period$ -- 0
call.type$
-- 0
change.case$ -- 0
chr.to.int$
-- 0
cite$ -- 0
duplicate$
-- 0
empty$ -- 0
format.name$
-- 0
if$ -- 0
int.to.chr$
-- 0
int.to.str$ -- 0
missing$
-- 0
newline$ -- 0
num.names$
-- 0
pop$ -- 0
preamble$
-- 0
purify$ -- 0
quote$
-- 0
skip$ -- 0
stack$
-- 0
substring$ -- 0
swap$
-- 0
text.length$ -- 0
text.prefix$
-- 0
top$ -- 0
type$
-- 0
warning$ -- 0
while$
-- 0
width$ -- 0
write$
-- 0
(There were 3 error messages)


Und hier nochmal mein eigentlicher LaTeX-Code:
Code • Öffne in Overleaf
\documentclass[10pt,a4paper]{report}
\usepackage[left=3cm, right=3cm, top=3cm, bottom=3cm]{geometry}
\usepackage[utf8]{inputenc}
\usepackage[german]{babel}
\usepackage[T1]{fontenc}
\usepackage{amsmath}
\usepackage{amsfonts}
\usepackage{amssymb}
\usepackage{graphicx}
\usepackage{booktabs}
\usepackage{verbatim}
\usepackage{gensymb}
\usepackage[colorlinks, pdfpagelabels, pdfstartview = FitH,
bookmarksopen = true,
bookmarksnumbered = true,
linkcolor = black,
citecolor = black
]{hyperref}
\linespread{1.5}
\usepackage{scrpage2}
\pagestyle{scrheadings}
\clearscrheadfoot
\cfoot{-~\pagemark ~-}
\ofoot{}
\ifoot{\author
}

\author{Florian Prinz}
\title{Räuberische Leistung und Diversität von traubenwickler-Antagonisten in integriert, biologisch-organisch und biologisch-dynamisch bewirtschafteten Rebflächen}


\begin{document}
\maketitle
\tableofcontents
\pagebreak

\chapter{Kapitel 1}
\section{Anfang}
blablablablablablablablablablablablablablablablablablablablablabla
blablablablablablablablablablablablablablablablablablablablablabla
blablablablablablabla

blablablablablablablablablablablablablablablablablablablablablabla
blablablablablablablablablablablablablablablablablablablablablabla
blablablablablablablablablablablablablablablablablablablablablablab
lablablablablablablablablablablablablablablablablablablablablablabl
ablablablablablablablablablablablablablablablablablablabla

blablablablablablablablablablablablablablabla

\listoffigures
\listoftables



\end{document}



Wenn mir hier jemand bei meinem Problem helfen kann, wäre ich sehr dankbar!

Nutze übrigens Texmaker als Editor, JabRef für die Bibliografie und als OS Ubuntu. Habe auch schon sämtliche Texmaker und Texlive-Pakete gepurged und bin nun etwas ratlos... Ob/Wie ich sonst noch die Konfiguration zurücksetzen kann weiß ich nicht...

Vielen Dank im Voraus!
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4757
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.04.2017, 07:03     Titel:
  Antworten mit Zitat      
Hast du einfach mal alle Hilfsdateien gelöscht? Das ist normalerweise der erste Schritt bevor man wild Software updated und panisch wird.

Weil makebst nur begrenzt kann, was viele Anwender wollen und das direkte Editieren eines Bibliographiestils eine reine Qual ist, wurde übrigens Paket auf CTANbiblatex entwickelt. Da ist das Abändern relativ einfach mit LaTeX-Grundkenntnissen möglich.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen
Verschoben: 14.04.2017, 07:04 Uhr von Johannes_B
Von LaTeX Editoren nach Literaturverzeichnis

PrinzeFlo
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.04.2017, 07:21     Titel:
  Antworten mit Zitat      
Ich habe komplett alle Dateien gelöscht und nochmal von vorne angefangen - ohne Erfolg :/
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4757
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.04.2017, 08:01     Titel:
  Antworten mit Zitat      
Klicke bei deinem Beispiel auf Öffne in online-editor und du wirst sehen, es geht. Dass BibTeX bei diesem Beispiel die gezeigten Fehler meldet ist allerdings nicht verwunderlich, da BibTeX für das gezeigte Beispiel keinen Sinn macht.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.04.2017, 09:24     Titel:
  Antworten mit Zitat      
makebst ist bei dem gezeigten Dokument an irgendwelchen Problemen vollkommen unschuldig. Da das Dokument weder Literaturverzeichnis noch Literaturverweise enthält, hat ein eventuell mit makebst erzeugter Literaturstil auch keinen Einfluss darauf. Wie Johannes schon angedeutet hat, ist der eigentliche Fehler, für ein Dokument ohne \bibliography, \bibliographystyle oder \cite überhaupt bibtex aufzurufen.

Davon abgesehen kann ich Johannes auch nur darin zustimmen, dass du makebst etc. besser vergessen und dich stattdessen an Paket auf CTANbiblatex halten solltest. Arbeite dazu unbedingt die wichtigen Hinweise, die Johannes für dieses Forum verfasst hat, durch.

Es sei weiter darauf hingewiesen, dass Dokumentationscrpage2 veraltet ist und man dieses besser durch dessen Nachfolger Paket auf CTANscrlayer-scrpage ersetzen sollte. Auch ist die Verwendung von \pagebreak im Beispiel falsch und überflüssig. Option german für Paket auf CTANbabel ist nur dann richtig, wenn du wirklich ein Werk in alter Rechtschreibung verfassen willst. Für die aktuelle Rechtschreibung wäre ngerman anzugeben. Pakete, die du nicht verwendest, solltest du auch nicht laden.

PrinzeFlo
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 13.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 14.04.2017, 12:51     Titel:
  Antworten mit Zitat      
Vielen Dank!

Nachdem ich die Bibliografie von .tex in .bib umbenannt habe, hat es dann auch funktioniert - aber ich werde euren Rat beherzigen und jetzt auf Biblatex umsteigen.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de