goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Römische Zählung für das Literaturverzeichnis

 

Beate
Forum-Newbie
Forum-Newbie

Beiträge: 1
Anmeldedatum: 23.02.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2017, 00:02     Titel: Römische Zählung für das Literaturverzeichnis
  Antworten mit Zitat      
Hallo ihr Lieben!

Ich schreibe gerade an einer Hausarbeit und meine Dozentin hat genaue Vorstellungen für die Nummerierung der Seiten. Deckblatt frei, Inhaltsverzeichnis römisch, Hauptteil arabisch und Literaturverzeichnis wieder römisch. So weit so gut, hab ich nach viel Arbeit alles hinbekommen. Problematisch ist jetzt nur, dass die Seitenzahl vom Literaturverzeichnis nicht "II" lautet, sondern "ii". Ich weiß beim besten Willen nicht wie ich das ändern kann.
Ich benutze die article Dokumentenklasse.

Das hilft leider nicht:

Code • Öffne in Overleaf
\setcounter{page}{2}
 


hier das Beispiel: (ich fürchte da sind Fehler drin. Sorry, ich mache das hier zum ersten Mal)

Code • Öffne in Overleaf
\begin{document}

\title{}
\maketitle
\begin{lyxcode
}
\thispagestyle{empty}
\end{lyxcode}
\newpage{}

\pagenumbering{Roman
}

\tableofcontents{}

\newpage{
}

\pagenumbering{arabic
}

\section

\noindent \bibliographystyle{elsarticle-harv}
\addcontentsline{toc}{section}{\refname}\nocite{*}
\bibliography{}
\noindent \pagenumbering{roman
}
\setcounter{page}{1}
\end{document}


Vielen Dank! Ich verzweifel gerade etwas...
Liebe Grüße Andrea
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2017, 07:40     Titel:
  Antworten mit Zitat      
Mit \pagenumbering{roman} bekommst Du kleine römische Zahlen (i, ii, iii, ...) mit \pagenumbering{Roman} gibt es die großen (I, II, III, ...).

Der leere \section-Befehl ohne Argument sieht mir übrigens etwas fishy aus. Genauso wie das ganze Rumgeholze mit
Code • Öffne in Overleaf
\noindent \bibliographystyle{elsarticle-harv}
\addcontentsline{toc}{section}{\refname}\nocite{*}
\bibliography{}
\noindent \pagenumbering{roman
}
\setcounter{page}{1}

Je nach Dokumentenklasse gibt es da klügere Konstruktionen.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.02.2017, 07:41     Titel:
  Antworten mit Zitat      
Das gezeigte Beispiel dürfte ungetestet sein, anders ist die falsche Verwendung des \section-Befehls nicht zu erklären. Außerdem ist es unvollständig und taugt daher nicht wirklich, um das Problem zu reproduzieren.

So kann ich nur vermuten, dass das Problem mit großen und kleinen römischen Seitenzahlen daran liegt, dass du auch bei \pagenumbering das Roman mal groß und mal klein schreibst. Bei TeX spielt die Groß-/Kleinschreibung eine Rolle und ist im Gegensatz zum Windows-Betriebssystem nicht beliebig.

Als jemand, der seit über zwanzig Jahren Bücher setzt, davon rund zehn Jahre professionell, muss ich allerdings noch darauf hinweisen, dass das Vorhaben unsinnig ist. Siehe dazu: Römische Seitenzahlen im Vorderteil (und im Endteil)? In englischen Buchreihen ist zwar die römische Nummerierung (mit kleinen römischen Zahlen!) noch weit verbreitet, aber selbstverständlich nur im Vorderteil. Da die Dozentin hoffentlich nicht über Typografie doziert, darf man sie ruhig einmal darauf hinweisen.

Wenn dir dir Auskunft nicht reicht, dann erweitere dein Beispiel bitte zu einem vollständigen InfoMinimalbeispiel (Link beachten!). Dann können wir substantiell Hilfe leisten.

Es sei nebenbei auch noch erwähnt, dass die Umschaltung des Seitenstils für das Literaturverzeichnis bei dir erst nach dem Literaturverzeichnis erfolgt. Wenn das Verzeichnis mehr als eine Seite hat, wird es also zu spät. Vor einer Umschaltung mit \pagenumbering sollte ein \cleardoublepage stehen. Es wird dann auch schnell klar, dass der gesamte Befehlskomplex vor \bibliography gehört.

nixversteh
Forum-Guru
Forum-Guru

Beiträge: 445
Anmeldedatum: 10.08.10
Wohnort: Wrestedt
Version: Linux Mint 18.2 Sonya MATE Edition, 64bit Texlive 2017
     Beitrag Verfasst am: 24.02.2017, 08:08     Titel: ...
  Antworten mit Zitat      
Hallo Andrea,

willkommen im Forum, schön, dass du dich für LaTex entschieden hast Smile
Dein Code läuft so nicht, die gesamte Präambel fehlt. Versuche mal ein Minimalbeispiel einzustellen. Schaust bitte hier: http://www.golatex.de/wiki/Minimalbeispiel
Viel Erfolg
Gruß
Martin

EDIT: too late
_________________

Der aus Büchern erworbene Reichtum fremder Erfahrung heißt Gelehrsamkeit. Eigene Erfahrung ist Weisheit. Das kleinste Kapital von dieser ist mehrt wert, als Millionen von jener.
(Gotthold Ephraim Lessing)
Private Nachricht senden Benutzer-Profile anzeigen E-Mail senden

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de