goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Alles in math-mode in Fett

 

icecoldkilla
Forum-Anfänger
Forum-Anfänger

Beiträge: 26
Anmeldedatum: 27.12.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2017, 02:14     Titel: Alles in math-mode in Fett
  Antworten mit Zitat      
Hallo zusammen,

wie bekomme ich denn alles im math-mode in Fett?
Brauche das für die Spaltenbezeichnungen, aber mit \textbf geht da leider gar nichts.

Irgendwelche Ideen?


mfg
icecoldkilla
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2017, 08:38     Titel:
  Antworten mit Zitat      
Kommt darauf an, was alles ist. Jedenfalls gibt es als Pedant zu \textbf auch \mathbf, wobei allerdings Schriftattribute in der Mathematik nicht unbedingt kombinierbar sind. Siehe dazu eine LaTeX-Einführung, den Dokumentationusrguide oder den Dokumentationfntguide. Allerdings haben Fonts in der Mathematik meist auch eine semantische Bedeutung. Fette Buchstaben werden in der Mathematik beispielsweise gerne für Vektoren oder Mengen verwendet.

Welche mathematischen Zeichen überhaupt fett vorliegen, hängt u. a. von den verwendeten Schriftpaketen ab.

icecoldkilla
Forum-Anfänger
Forum-Anfänger

Beiträge: 26
Anmeldedatum: 27.12.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2017, 09:47     Titel:
  Antworten mit Zitat      
Ein Beispiel wär hier einfach die erste Zeile der Tabelle

Code • Öffne in Overleaf

\documentclass{scrreprt}
\usepackage{amsmath}


\begin{document}

\begin{table}
   \begin{tabular}{ccccl}
         $n_{soll}\, [min^{-1}]$ & $n_{min}\, [min^{-1}]$\\
         \hline
         60 & 57\\  
   \end{tabular}
\end{table}  

\end{document}
 


Habs nun bei jedem Eintrag der Tabelle mit
Code • Öffne in Overleaf
\bf{}
gemacht, was aber wirklich nicht gerade intuitiv ist...
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2017, 10:11     Titel:
  Antworten mit Zitat      
Deine LaTeX-Distribution ist in einem veralteten Zustand.

\bf ist ein veralteter Befehl, der bei LaTeX2e, also seit 1994 nicht mehr verwendet werden sollte und bei Paket auf CTANscrreprt seit einiger Zeit nicht mehr nur zu einer Warnung, sondern einer Fehlermeldung führt, wie du im Online-Editor selbst prüfen kannst. Verwende, wie von mir empfohlen, korrekter Weise \mathbf analog zu dem von dir erwähnten \textbf und lies die von mir empfohlene Literatur bezüglich Fonts im Mathemodus.

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3419
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 10.01.2017, 17:55     Titel:
  Antworten mit Zitat      
"alles in math-mode in Fett" macht man mit \mathversion{bold} (oder dem Äquivalenten \boldmath). \mathbf (oder \symbf mit unicode-math) ist für Buchstaben -- es funktioniert zwar auch oft für andere Symbole, aber das ist dann meist nur ein Seiteneffekt und man sollte sich nicht darauf verlassen.
Die Einheit würde ich aber eher im Textmodus und mit siunitx setzen.

Code • Öffne in Overleaf
\documentclass{scrreprt}
\usepackage{amsmath}
\usepackage{siunitx}

\begin{document}

\begin{table}
   \begin{tabular}{ccccl}
        \mathversion{bold}\bfseries $n_{\mathrm{soll}}$\,[\si[detect-weight]{\per\minute}] & $n_{min}\, [min^{-1}]$\\
         \hline
         60 & 57\\
   \end{tabular}
\end{table}

\end{document}
 

_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 799
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 13.01.2017, 16:36     Titel:
  Antworten mit Zitat      
Meiner Meinung nach sollte die Klammerhöhe wegen des Exponenten angepasst werden.

Code • Öffne in Overleaf
\documentclass[border=3pt]{standalone}
\usepackage{amsmath}
\usepackage{siunitx}
\usepackage{booktabs}

\begin{document}
\sisetup{detect-weight}
\begin{tabular}{cc}
   \toprule
   \mathversion{bold}\bfseries $n_{\mathrm{soll}}\,\left[\si{\per\minute}\right]$ &
   \mathversion{bold}\bfseries $n_{\min}\,\left[\si{\per\minute}\right]$\\
   \midrule
   60 & 57\\
   \bottomrule
\end{tabular}
\end{document}


Leider werden die Klammern dann nicht mehr fett gedruckt.

Code • Öffne in Overleaf
\documentclass[border=1pt]{standalone}
\usepackage{siunitx}

\begin{document}
\sisetup{detect-weight}
\mathversion{bold}\bfseries
$\left[\si{\per\minute}\right] [\si{\per\minute}]$
\end{document}
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3419
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.01.2017, 17:25     Titel:
  Antworten mit Zitat      
Erstens bin ich (wie egreg z.B. hier http://tex.stackexchange.com/a/274012/2388) der Meinung, dass man \left/\right eher vermeiden soll, und zweitens finde ich nicht, dass die Klammern größer sein sollten (http://tex.stackexchange.com/a/237795/2388) und drittens ist die Einheit meines Erachtens keine Mathematik, sondern Text.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de