goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 81596
Top-Poster: Johannes_B (4557)

Wir begrüßen unseren neuesten Benutzer ElForni.

Partner:


goLaTeX.de wird gefördert durch DANTE e.V.: Deutschsprachige Anwendervereinigung TeX





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Texmaker findet keine \citation commands

 

AlWeis
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 20.08.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.02.2016, 17:52     Titel: Texmaker findet keine \citation commands
  Antworten mit Zitat      
Hallo!

Ich versuche seit Stunden meine Citavi-Literatur in meine latex-Datei einzubinden (Texmaker, Windows). Ich bekomme beim Ausführen von BibTex folgende Fehlermeldung:
The top-level auxiliary file: main.aux I found no \citation commands---while reading file main.aux I found no \bibdata command---while reading file main.aux I found no \bibstyle command---while reading file main.aux

Und beim Ausführen von PDFLatex dann u.a. folgende Fehler:
Empty bibliography
There were undefined references

Hier mein Code:

Code • Öffne in Overleaf

\documentclass
[paper=a4,
 pagesize, % passt die Seitengröße für PDFs korrekt an
 fontsize=11pt,
 parskip=half]
{scrreprt}

% Eine etwas schönere Schriftart wählen
\usepackage[T1]{fontenc}
\usepackage{lmodern}

% Biblatex für die Literaturverwaltung
\usepackage[backend=biber,style=authortitle]{biblatex}
%\usepackage{cite}

\bibliography{Diss}

% Verbessert die Körnung
\usepackage{microtype}

% Eingabe von Umlauten
\usepackage[utf8]{inputenc}

% Sprachanpassungen auf Deutsch
\usepackage[ngerman]{babel}

% Sprachspezifische Anführungszeichen durch den \enquote{Text} Befehl
\usepackage{csquotes}

...

\usepackage{blindtext}

% Keine "Schusterjungen"
\clubpenalty = 10000
% Keine "Hurenkinder"
\widowpenalty = 10000
\displaywidowpenalty = 10000

...

\begin{document}

...

\begin{abstract}
 \blindtext \cite{Aaronson.1976}
\end{abstract}

...

\printbibliography

\end{document}
 

Ich bin schon lange in den Foren unterwegs, um Lösungen zu finden, aber nichts hat funktioneirt. Ich hoffe, ihr könnt mit helfen!

[/code][/i]
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.02.2016, 18:11     Titel:
  Antworten mit Zitat      
Wenn Du mit backend=biber Biber als Bibliographieprozessor anmeldest, dann musst Du auch Biber aufrufen und nicht BibTeX.

Die Fehlermeldung deutet darauf hin, dass Du BibTeX laufen lässt.

Siehe Wie verwende ich biber in meinem Editor? und Biblatex with Biber: Configuring my.....avoid undefined citations.

AlWeis
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 20.08.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 26.02.2016, 14:02     Titel: Herzlichen Dank!
  Antworten mit Zitat      
Hat super geklappt! Vielen, vielen Dank für den Tipp!
Private Nachricht senden Benutzer-Profile anzeigen

ladybird_858
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 08.01.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2017, 16:13     Titel:
  Antworten mit Zitat      
Hallo,

ich habe ein ähnliches Problem. Habe jetzt bei den Einstellungen Biber statt Biblatex eingegeben. Muss ich dann anders kompilieren? Beim 3. Kompilieren erhalte ich dann sehr viele Fehlermeldungen und im PDF steht auf der 1. Seite nytnyt, danach der normale Text aber ohne richtige Zitate. Wo liegt der Fehler?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2017, 16:30     Titel:
  Antworten mit Zitat      
Schon einmal darin, dass du die wichtigen Hinweise nicht gründlich durchgearbeitet und deshalb auch kein InfoMinimalbeispiel und keine Fehlermeldung angegeben hast und auch keine neue Frage gestellt, sondern dich faul an eine beantwortete alte angehängt hast. Hellsehen können wir leider nicht.

ladybird_858
Forum-Newbie
Forum-Newbie

Beiträge: 4
Anmeldedatum: 08.01.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2017, 16:38     Titel:
  Antworten mit Zitat      
Hier ist ein Beispiel, bei dem es nicht klappt. Ich bin über jede Hilfe dankbar.

Code • Öffne in Overleaf
\documentclass[a4paper,12pt]{article}
%\usepackage{german}
\usepackage[ngerman]{babel}
% deutsche Umlaute
\usepackage[utf8]{inputenc}
%\usepackage[numbers,round]{natbib}
%1.5 facher Zeilenabstand
\usepackage{setspace}
\makeatletter
\setstretch {1.433}
\usepackage{graphicx}
\usepackage{url}
\usepackage[top=3cm,right=3cm,bottom=3cm,left=3cm]{geometry}
\usepackage[german=quotes]{csquotes}
\usepackage{amsmath,amsfonts,mathtools,amsthm}
\usepackage{tabularx}
\usepackage[backend=biber,style=authoryear]{biblatex}
\usepackage{eurosym}
\usepackage{pdfpages}
\usepackage{mwe}

\addbibresource{test.bib}

\newenvironment{lz}{\par\singlespacing\begin{quote}}{\end{quote}} % Umgebung für Literaturzitate
\renewenvironment{quote}{\ifhmode\par\fi\singlespacing\list{}{\rightmargin\leftmargin\small}\item\relax}{\endlist
}
\newtheorem{defi}{Definition}
\newtheorem{bsp}{Beispiel}
\newtheorem{bem}{Bemerkung}
\newtheorem{satz}{Satz}

\begin{document}

\printbibliography
blablabla nach \cite[15]{nie}
\end{document}

Code • Öffne in Overleaf

@book{Nie,
title = {Mathematik Neue Wege 11/12 Niedersachsen
},
year = {2012},
editor = {Körner, Henning and Lergenmüller, Arno and Schmidt, Günter and Zacharias, Martin},
publisher = {Schroedel},
location = {Braunschweig},
}


test.bib
 Beschreibung:

Download
 Dateiname:  test.bib
 Dateigröße:  227 Bytes
 Heruntergeladen:  8 mal
test.tex
 Beschreibung:

Download
 Dateiname:  test.tex
 Dateigröße:  1007 Bytes
 Heruntergeladen:  8 mal
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 08.01.2017, 17:29     Titel:
  Antworten mit Zitat      
TeX ist case-sensitiv. Wenn die Literatur den Schlüssel Nie trägt, sollte natürlich auch \cite nicht nie verwenden:
Code • Öffne in Overleaf
\begin{filecontents*}{\jobname.bib}
@book{Nie,
title = {Mathematik Neue Wege 11/12 Niedersachsen
},
year = {2012},
editor = {Körner, Henning and Lergenmüller, Arno and Schmidt, Günter and Zacharias, Martin},
publisher = {Schroedel},
location = {Braunschweig},
}
\end{filecontents*}
\documentclass[a4paper,12pt]{article}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[backend=biber,style=authoryear]{biblatex}

\addbibresource{\jobname.bib}
\begin{document}
\printbibliography
\cite[15]{nie} geht natürlich nicht.
\cite[15]{Nie} dagegen sehr wohl.
\end{document}

Und das mit dem Befolgen der InfoMinimalbeispiel-Anleitung übst du bitte noch einmal.

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de