goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 83521
Top-Poster: Johannes_B (4674)

Wir begrüßen unseren neuesten Benutzer timroh.

Partner:


goLaTeX.de wird gefördert durch DANTE e.V.: Deutschsprachige Anwendervereinigung TeX





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Trennung der Autorennamen durch "/" und nicht "und"

 

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 68
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 19.12.2016, 16:48     Titel: Trennung der Autorennamen durch "/" und nicht "und"
  Antworten mit Zitat      
Liebes Forum,
ich versuche gerade mein Literaturverzeichnis anzupassen.
Wie kann ich einstellen, dass bei mehreren Autoren deren Namen nicht durch ein "und" sondern durch "/" getrennt werden? Anbei sende ich euch mein Minimalbeispiel.
Code • Öffne in Overleaf

\begin{filecontents*}{bediaBibliographie.bib}  

@commentary{CalliessR,
   Address = {München
},
   Author = {Calliess, Christian and Ruffert, Matthias},
   Booktitle = {EUV/AEUV Kommentar},
   Date-Added = {2015-11-16 16:40:08 +0000},
   Date-Modified = {2016-09-01 13:14:17 +0000},
   Edition = {5},
   Editor = {Calliess, Christian and Ruffert, Matthias},
   Publisher = {C.H. Beck},
   Title = {EUV/AEUV Kommentar},
   Year = {2016}}

\end{filecontents*}

\begin{filecontents}{Test.bbx}
\ProvidesFile{Test.bbx}[2016/12/14 v0.1f biblatex bibliography style]
\RequireBibliographyStyle{authoryear}
% Reihenfolge der Namen im LitVerz: Nachname, Vorname und Nachname, Vorname usw.
\DeclareNameFormat{sortname}{% Bibliographie
  \mkbibemph{%
    \iffirstinits%
      {\usebibmacro{name:last-first}{\namepartfamily}{\namepartgiveni}{\namepartprefix}{\namepartsuffix}}%
      {\usebibmacro{name:last-first}{\namepartfamily}{\namepartgiven}{\namepartprefix}{\namepartsuffix}}%
    \usebibmacro{name:andothers}%
  }
}
\endinput
\end{filecontents}

\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[babel, german=quotes]{csquotes}
\addbibresource{bediaBibliographie.bib}
\begin{document}
123\footcite[Brechmann][Art. 18 AEUV, Rn. 12]{CalliessR}
\printbibliography
\end{document}
 


Danke für Eure Hilfe!
Private Nachricht senden Benutzer-Profile anzeigen

markusv
Forum-Century
Forum-Century

Beiträge: 132
Anmeldedatum: 03.09.15
Wohnort: Leipzig
Version: ---
     Beitrag Verfasst am: 20.12.2016, 07:03     Titel:
  Antworten mit Zitat      
Versuche es mit folgendem Code in der Präambel, siehe auch Seite 115 der Doku (http://texdoc.net/texmf-dist/doc/la.....blatex-de/biblatex-de.pdf)

Code • Öffne in Overleaf

\AtBeginBibliography{%
   \renewcommand*{\multinamedelim}{\addslash\space}
   \renewcommand*{\finalnamedelim}{\addslash\space}
}


Im Beispiel:

Code • Öffne in Overleaf
\begin{filecontents*}{bediaBibliographie.bib}  

@commentary{CalliessR,
   Address = {München
},
   Author = {Calliess, Christian and Ruffert, Matthias},
   Booktitle = {EUV/AEUV Kommentar},
   Date-Added = {2015-11-16 16:40:08 +0000},
   Date-Modified = {2016-09-01 13:14:17 +0000},
   Edition = {5},
   Editor = {Calliess, Christian and Ruffert, Matthias},
   Publisher = {C.H. Beck},
   Title = {EUV/AEUV Kommentar},
   Year = {2016}}

\end{filecontents*}
\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[backend=biber]{biblatex}
\usepackage[babel, german=quotes]{csquotes}
\addbibresource{bediaBibliographie.bib}
  \AtBeginBibliography{%
   \renewcommand*{\multinamedelim}{\addslash\space}
   \renewcommand*{\finalnamedelim}{\addslash\space}
}
\begin{document}
123\footcite[Brechmann][Art. 18 AEUV, Rn. 12]{CalliessR}
\printbibliography
\end{document}

_________________

Wäre Microsoft Word für das Schreiben von Büchern entwickelt worden,
würde es Microsoft Books heißen.

Ist noch gebratenes $\lambda$?
Nein, das $\phi$ ist noch $\rho$!
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.12.2016, 09:59     Titel:
  Antworten mit Zitat      
Mir ist nicht ganz klar, ob Du das überall möchtest, nur in Zitaten oder nur in der Bibliographie.

Für überall wäre
Code • Öffne in Overleaf
\renewcommand*{\multinamedelim}{\addslash}
\renewcommand*{\finalnamedelim}{\multinamedelim}

wohl die richtige Wahl.

Für die Bibliograpie alleine dann
Code • Öffne in Overleaf
\AtBeginBibliography{%
   \renewcommand*{\multinamedelim}{\addslash}%
   \renewcommand*{\finalnamedelim}{\multinamedelim}%
}


Und nur für Zitate entweder
Code • Öffne in Overleaf
\AtEveryCite{%
   \renewcommand*{\multinamedelim}{\addslash}%
   \renewcommand*{\finalnamedelim}{\multinamedelim}%
}

oder umgekehrt
Code • Öffne in Overleaf
\renewcommand*{\multinamedelim}{\addslash}
\renewcommand*{\finalnamedelim}{\multinamedelim}

\AtBeginBibliography{%
  \renewcommand*{\multinamedelim}{\addcomma\space}%
  \renewcommand*{\finalnamedelim}{%
    \ifnumgreater{\value{liststop}}{2}{\finalandcomma}{}%
    \addspace\bibstring{and}\space}%
}
 

bzw. etwas flexibler aber mit neuen Makros
Code • Öffne in Overleaf

\let\oldmultinamedelim\multinamedelim
\let\oldfinalnamedelim\finalnamedelim
\renewcommand*{\multinamedelim}{\addslash}
\renewcommand*{\finalnamedelim}{\multinamedelim}

\AtBeginBibliography{%
  \renewcommand*{\multinamedelim}{\oldmultinamedelim}%
  \renewcommand*{\finalnamedelim}{\oldfinalnamedelim}%
}
 


Siehe auch http://tex.stackexchange.com/q/54644/35864

Das \DeclareNameFormat{sortname} in Deinem Beispiel sollte man übrigens auch eleganter lösen können. Mal sehen, ob ich nachher dazu komme.

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 68
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.12.2016, 14:47     Titel:
  Antworten mit Zitat      
Danke für die schnelle und umfangreiche Hilfe. Das hat funktioniert.
In den Fußnoten hatte ich das auch bereits schon drin.
Ich versuche in den Fußnoten noch die Darstellung von Artikeln aus Zeitschriften anzupassen, Ich möchte, dass folgendes angezeigt wird:
"Nachname Autor kursiv, Name der Zeitschrift Jahr, Anfangsseite (konkrete Seite)" Die beiden Seitenzahlen sollen jedoch ohne den Zusatz "S" angezeigt werden.

Bisher bekomme ich jedoch nur folgendes hin:
Nachname Autor kursiv, Name der Zeitschrift Jahr, (konkrete Seite) Die Seite wird mir aber auch noch mit dem Zusatz "S" angezeigt.

Da ich im Literaturverzeichnis immer die Seitenbereiche angeben muss, brauche ich auch unbedingt den letzten Befehl in der cbx-datei.
Anbei mein Minimalbeispiel:
Code • Öffne in Overleaf

\begin{filecontents*}{bediaBibliographie.bib}

@article{HobeStaat,
   Author = {Hobe, Stephan
},
   Date-Added = {2016-11-28 13:28:05 +0000},
   Date-Modified = {2016-11-28 13:28:58 +0000},
   Journal = {Der Staat},
   Pages = {245-268},
   Title = {Die Unionsbürgerschaft nach dem Vertrag von Maastricht},
   Year = {1993}}

\end{filecontents*}
\begin{filecontents}{Test.cbx}
\ProvidesFile{Test.cbx}[2016/12/14 v0.1f biblatex citation style]
% Kein S. für die konkrete Fundstelle, dafür in Klammern:
\DeclareFieldFormat[article]{postnote}{\printfield{pages} \mkbibparens{\#1}}  
\DeclareFieldFormat[article]{postnote}{\mkbibparens{\mkpageprefix[pagination]{#1}}}
%Das Feld, in dem sich die Anfangsseite befindet, ohne führendes S.~
% Falls bei pages mit Seitenbereichen gearbeitet wird, also
% z.B. pages = {797-900}, dann wird beim zitieren nur die Anfangsseite
% ausgegeben.
\AtEveryCite{%
  \DeclareFieldFormat[article]{pages}{\mkfirstpage{#1}}%
}%
\DeclareFieldFormat[article]{pages}{#1}
\end{filecontents}
\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[citestyle=Test]{biblatex}
\begin{document}
123\footcite[Vgl.][246]{HobeStaat}
\end{document}
 
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.12.2016, 18:56     Titel:
  Antworten mit Zitat      
Bitte sorg dafür, dass Deine Beispiele ohne Probleme laufen. Am besten testest Du Deinen Code immer vor dem Abschicken in einem leeren Ordern, um zu verhindern, dass alte Dateien dafür sorgen, dass bei Dir Dinge laufen, die es bei uns nicht tun.

Ich gehe mal davon aus, dass Du noch den Code aus http://golatex.de/anpassung-article-in-fussnote-t18484.html verwendest

Dort habe ich bereits ein paar Änderung vorgeschlagen. Wenn Du die Seiten immer sehen möchtest, brauchen wir
Code • Öffne in Overleaf
\DeclareBibliographyDriver{cite:article}{%
  \printfield{journaltitle}%
  \setunit{\addspace}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield{pages}}

(Wir können also die Abfragen wegwerfen. Beachte auch die Nutzung von \setunit.)

Für die Seitenzahl der konkreten Fundstelle im Zitat brauchst Du dann
Code • Öffne in Overleaf
\renewcommand*{\postnotedelim}{\addspace}
\DeclareFieldFormat[article]{postnote}{\mkbibparens{#1}}

für die andere Seitenzahl würde ich
Code • Öffne in Overleaf
\DeclareFieldFormat[article]{pages}{\ifcitation{\mkfirstpage{#1}}{#1}}%

vorschlagen.

Im Ganzen
Code • Öffne in Overleaf
\ProvidesFile{test.cbx}[2016/12/20 v0.1 KJung Jura]

\RequireCitationStyle{authortitle-dw}

\renewbibmacro*{cite:title}{%
  \iffieldundef{entrysubtype}%
    {\usedriver{}{cite:\thefield{entrytype}}}%
    {\usedriver{}{cite:\thefield{entrytype}:\thefield{entrysubtype}}}}

\renewcommand*{\postnotedelim}{\addspace}
\DeclareFieldFormat[article]{postnote}{\mkbibparens{#1}}

\DeclareFieldFormat[article]{pages}{\ifcitation{\mkfirstpage{#1}}{#1}}%

\DeclareBibliographyDriver{cite:article}{%
  \printfield{journaltitle}%
  \setunit{\addspace}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield{pages}}

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 68
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.12.2016, 10:52     Titel:
  Antworten mit Zitat      
Danke für Eure Hilfe!
Wünsche einen guten Rutsch!
Private Nachricht senden Benutzer-Profile anzeigen

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 68
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 28.12.2016, 13:27     Titel:
  Antworten mit Zitat      
Ich habe bezüglich der Darstellung der Zeitschriftenartikel im Literaturverzeichnis noch eine Frage:
Wie bekomme ich es hin, dass im zitiert als Teil nur die Anfangsseite angegeben wird und nicht der komplette Seitenbereich? Vorher soll der komplette Seitenbereich dargestellt werden.
ich möchte als, dass im LiterVerz steht: Bearbeiter Titel des Aufsatzes, Zeitschrift, Jahr, Seitenbereich, zitiert als: Bearbeiter, Zeitschrift, Jahr, Anfangsseite.
Anbei mein Minimalbeispiel:
Code • Öffne in Overleaf

\begin{filecontents*}{bediaBibliographie.bib}

@article{HobeStaat,
   Author = {Hobe, Stephan
},
   Date-Added = {2016-11-28 13:28:05 +0000},
   Date-Modified = {2016-11-28 13:28:58 +0000},
   Journal = {Der Staat},
   Pages = {245-268},
   Title = {Die Unionsbürgerschaft nach dem Vertrag von Maastricht},
   Year = {1993}}
\end{filecontents*}

\begin{filecontents}{Test.bbx}
\ProvidesFile{test.bbx}[2016/12/20 v0.1 biblatex bibliography style]
\RequireBibliographyStyle{authortitle-dw}%
% LitVerz-Format von Zeitschriftenartikeln
\DeclareBibliographyDriver{article}{% default
  \usebibmacro{bibindex}%
  \usebibmacro{author/editor}%
  \setunit{\labelnamepunct}\newblock
  \usebibmacro{title}%
  \newunit\newblock
  \printfield{journaltitle}%
  \addcomma
  \addspace
  \printfield{year}
  \addcomma
  \addspace
  \printfield{pages}
  \addspace%
    \addcomma\addspace%            <-- 'zitiert als:' eingefügt und danach die Zitation
    \textit{zitiert}%              <-- mit shorttitle/title ausgegeben
    \addnbspace%                   <--
    \textit{als}%                  <--
    \addcolon%                     <--
    \addnbspace%                  <--
      \printnames{labelname}%         <--
    \addcomma%                  <--
    \addnbspace%
    \printfield{author/editor}
    \addcomma
    \addnbspace
    \printfield{journaltitle}
    \addcomma
    \addnbspace
    \printfield{year}
    \addcomma
    \addnbspace
     \printfield{pages}
  \usebibmacro{finentry}}
\end{filecontents}

\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[citestyle=Test]{biblatex}
\begin{document}
123\footcite[Vgl.][246]{HobeStaat}
\end{document}
 


Danke vorab schon einmal für Eure Hilfe!
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 29.12.2016, 12:14     Titel:
  Antworten mit Zitat      
Auch dieses Beispiel funktioniert leider nicht einwandfrei (mit \usepackage[citestyle=authortitle-dw,bibstyle=Test]{biblatex} und \addbibresource{bediaBibliographie.bib} geht es), und selbst wenn es funktioniert, zeigt es das Problem nicht, da es kein \printbibliography beinhaltet.

Du kannst
Code • Öffne in Overleaf
\DeclareFieldFormat{citepages}{\mkfirstpage{#1}}
definieren und dann bei der 'zitiert als' Seitenzahl
Code • Öffne in Overleaf
\printfield[citepages]{pages}

nutzen.
Also
Code • Öffne in Overleaf
\DeclareBibliographyDriver{article}{% default
  \usebibmacro{bibindex}%
  \usebibmacro{author/editor}%
  \setunit{\labelnamepunct}\newblock
  \usebibmacro{title}%
  \newunit\newblock
  \printfield{journaltitle}%
  \setunit{\addcomma\space}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield{pages}%
  \setunit{\addcomma\space}%
  \printtext[emph]{zitiert als}%  
  \setunit{\addcolon\space}%
  \printnames{labelname}%    
  \setunit{\addcomma\space}%
  \printfield{author/editor}%
  \setunit{\addcomma\space}%
  \printfield{journaltitle}%
  \setunit{\addcomma\space}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield[citepages]{pages}%
  \usebibmacro{finentry}}

beachte bitte meine Änderungen: (1) die Nutzung von \setunit statt der einfachen Punctuation-Befehle, (2) % an Zeilenenden, (3) keine nichtumbrechbaren Leerzeichen, (4) \printtext für 'zitiert als' (wobei das besser noch als bibstring implementiert würde).

MWE (Achtung! Wegen des Dokumentationfilecontents-Paketes werden die involvierten Dateien ohne weitere Warnung überschrieben. Am besten führst Du das Beispiel in einem eigenen, leeren Ordner aus.)
Code • Öffne in Overleaf
\RequirePackage{filecontents}
\begin{filecontents*}{bediaBibliographie.bib}

@article{HobeStaat,
   Author = {Hobe, Stephan
},
   Date-Added = {2016-11-28 13:28:05 +0000},
   Date-Modified = {2016-11-28 13:28:58 +0000},
   Journal = {Der Staat},
   Pages = {245-268},
   Title = {Die Unionsbürgerschaft nach dem Vertrag von Maastricht},
   Year = {1993}}
\end{filecontents*}

\begin{filecontents}{Test.bbx}
\ProvidesFile{test.bbx}[2016/12/20 v0.1 biblatex bibliography style]

\DeclareFieldFormat{citepages}{\mkfirstpage{#1}}

\RequireBibliographyStyle{authortitle-dw}%
% LitVerz-Format von Zeitschriftenartikeln
\DeclareBibliographyDriver{article}{% default
  \usebibmacro{bibindex}%
  \usebibmacro{author/editor}%
  \setunit{\labelnamepunct}\newblock
  \usebibmacro{title}%
  \newunit\newblock
  \printfield{journaltitle}%
  \setunit{\addcomma\space}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield{pages}%
  \setunit{\addcomma\space}%
  \printtext[emph]{zitiert als}%  
  \setunit{\addcolon\space}%
  \printnames{labelname}%    
  \setunit{\addcomma\space}%
  \printfield{author/editor}%
  \setunit{\addcomma\space}%
  \printfield{journaltitle}%
  \setunit{\addcomma\space}%
  \printfield{year}%
  \setunit{\addcomma\space}%
  \printfield[citepages]{pages}%
  \usebibmacro{finentry}}
\end{filecontents}

\documentclass[oneside]{scrbook}
\usepackage[ngerman]{babel}
\usepackage[utf8]{inputenc}
\usepackage[T1]{fontenc}
\usepackage{setspace}
\usepackage[citestyle=authortitle-dw,bibstyle=Test]{biblatex}
\addbibresource{bediaBibliographie.bib}
\begin{document}
123\footcite[Vgl.][246]{HobeStaat}
\printbibliography
\end{document}

KJung
Forum-Fortgeschrittener
Forum-Fortgeschrittener

Beiträge: 68
Anmeldedatum: 13.07.15
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 29.12.2016, 16:26     Titel:
  Antworten mit Zitat      
Vielen Dank für deine ausführliche Antwort und die Tipps, was du alles geändert hast. Ich habe große Teile meiner Formatvorlage von biblatex-juradiss übernommen und mir wurde schon mehrfach gesagt, dass die Darstellung dort nicht mehr dem aktuellen Stand entsprechen. Ich werde auch meine anderen Formatierungen dementsprechend anpassen. Dein code sieht auf jeden Fall kompakter aus.
Danke nochmals!
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de