goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Direktlinks:
Zuletzt aktive Beiträge
Unbeantwortete Beiträge
[Erweitert]

Forenstatistik:
Beiträge: 81813
Top-Poster: Johannes_B (4566)

Wir begrüßen unseren neuesten Benutzer a.k.Boom.

Partner:


goLaTeX.de wird gefördert durch DANTE e.V.: Deutschsprachige Anwendervereinigung TeX





Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

[Gelöst] Undefined control sequence. \chapter

 

Franki
Forum-Anfänger
Forum-Anfänger

Beiträge: 12
Anmeldedatum: 23.05.16
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.05.2016, 11:15     Titel: [Gelöst] Undefined control sequence. \chapter
  Antworten mit Zitat      
Hi,

ich bin noch neu in Latex. Ich arbeite mit Texstudio an meiner Masterarbeit.
Wenn ich nun ein neues Kapitel hinzufügen will bekomme ich den Fehler

Code • Öffne in Overleaf

Undefined control sequence. \chapter
Missing \begin{document}. \chapter{F
Missing \begin{document
}. $
Emergency stop.
Overfull \hbox (20.0pt too wide) in paragraph
 


Dazu setze ich "\include{formelzeichen}" in meine Hauptdatei und dann in die daraufhin erzeugte Datei ein \chapter{Formelzeichen}

Meine Haupdatei:

Code • Öffne in Overleaf

% scrbook (KOMA script) settings
\documentclass[liststotoc,bibtotoc,a4paper,12pt,parskip,final]{scrbook}
\usepackage[paper=a4paper,left=25mm,right=25mm,top=30mm,bottom=40mm,bindingoffset=1cm]{geometry}
%\usepackage[utf8]{inputenc}
\usepackage[latin1]{inputenc}
\usepackage[T1]{fontenc} % keine bitmap fonts
\usepackage{ae,aecompl} % truetype fonts
\usepackage[ngerman]{babel}
\usepackage{amssymb,amsmath}
\usepackage{graphicx}
\usepackage{url}
\usepackage{setspace}
\hbadness = 10000 % -> disable ``underfull \hbox'' warnings
\usepackage[pdftex,bookmarks=true]{hyperref} % -> automatische ``bookmarks''
\parindent 0pt % keine einrückung nach absätzen

%C#
\usepackage{listings}
\usepackage{xcolor}
\lstdefinestyle{sharpc}{language=[Sharp]C, rulecolor=\color{blue!80!black}}
\lstset{style=sharpc}
%C#

 \usepackage{natbib}
 %\usepackage{bibtopic}

\begin{document}
%    \evensidemargin % breite seitenrand
%    \oddsidemargin % breite seitenrand
   \frontmatter % keine kapitelnummern, römische seitenzahlen
   \include{titelblatt}
   \onehalfspacing
   \include{erklaerung}
   \include{abstrakt}
   \tableofcontents
   \listoffigures
   \include{formelzeichen}
   \include{abkuerzungen}
   \mainmatter
   \include{einleitung}
   \include{grundlagen}
   \include{konzept}
   \include{realisierung}
   \include{schlussfolgerung}
   \frontmatter % keine kapitelnummern, römische seitenzahlen
   \setcounter{page}{15} % seitenzahl counter auf 15 setzen
%    \include{glossar}
   \include{anhang}
%   \include{literaturverzeichnis}
   \bibliography{bibtex}
%   \bibliographystyle{unsrt} %Zitationsstil
   \bibliographystyle{natdin} %Zitationsstil
\end{document}
 



Was mache ich falsch ?

Zuletzt bearbeitet von Franki am 24.05.2016, 08:24, insgesamt einmal bearbeitet
Private Nachricht senden Benutzer-Profile anzeigen

Johannes_B
Moderator
Moderator


Beiträge: 4566
Anmeldedatum: 01.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 23.05.2016, 17:23     Titel:
  Antworten mit Zitat      
Oberhalb deines Code-Blocks kannst du auf Öffne iin Online-Editor klicken, damit siehst du dann was wir auch sehen. Nämlich nichts ungewöhnliches.

Zeig uns mal deine Log-Datei des LaTeX-Laufs, welcher die Fehler produziert.
_________________

TeXwelt - Fragen und Antworten Schaut vorbei und stellt Fragen.
LaTeX-Vorlagen?

Der Weg zum Ziel: Ruhe bewahren und durchatmen, Beiträge und unterstützende Links aufmerksam lesen, Lösungsansätze verstehen und ggf. nachfragen.
Private Nachricht senden Benutzer-Profile anzeigen

Franki
Forum-Anfänger
Forum-Anfänger

Beiträge: 12
Anmeldedatum: 23.05.16
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.05.2016, 08:24     Titel:
  Antworten mit Zitat      
Merkwürdigerweise scheint heute wieder alles ohne Fehlermeldungen zu laufen... Rolling Eyes

Nunja...bin gespannt ob ich am ende meiner Thesis behaupten kann "Latex war besser wie word"

Thema gelöst!
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3202
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.05.2016, 08:43     Titel:
  Antworten mit Zitat      
Du hast gestern eine der \include-Dateien direkt kompiliert. Die starten ja mit \chapter, aber da dort kein \documentclass ist, ist \chapter dann undefiniert.

TeXStudio gibt sich eine Menge Mühe rauszufinden, was wohl die Hauptdatei ist, aber das kann scheitern. Du solltest besser die Hauptdatei explizit als Masterdokument setzen (rechtsklick auf die Datei im Dateibaum).

Und nimm \usepackage{ae,aecompl} raus. Das braucht man schon sein Jahrzehnten nicht mehr.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Franki
Forum-Anfänger
Forum-Anfänger

Beiträge: 12
Anmeldedatum: 23.05.16
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 24.05.2016, 09:06     Titel:
  Antworten mit Zitat      
ok danke!

Zitat:
Und nimm \usepackage{ae,aecompl} raus. Das braucht man schon sein Jahrzehnten nicht mehr.

Wenn ich das rausnehme verändert sich allerdings die Schriftart. Chapter Überschriften sind nicht mehr "Fett" z.b.
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 594
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 24.05.2016, 13:42     Titel:
  Antworten mit Zitat      
Franki hat Folgendes geschrieben:
Zitat:
Und nimm \usepackage{ae,aecompl} raus. Das braucht man schon sein Jahrzehnten nicht mehr.

Wenn ich das rausnehme verändert sich allerdings die Schriftart. Chapter Überschriften sind nicht mehr "Fett" z.b.

Ich weiß zwar nicht, was Deine beiden Pakete im Einzelnen so alles beeinflussen, aber tausche doch einmal

Code • Öffne in Overleaf
\usepackage{ae,aecompl}

durch
Code • Öffne in Overleaf
\usepackage{lmodern}

und sieh, ob Dir das Ergebnis zusagt. Interessantes dazu fand ich in einem alten Beitrag von KOMA.

Paket auf CTANurl wird übrigens von Paket auf CTANhyperref geladen.
\parindent 0pt brauchst Du wegen der Klassenoption parskip nicht.
Private Nachricht senden Benutzer-Profile anzeigen

Franki
Forum-Anfänger
Forum-Anfänger

Beiträge: 12
Anmeldedatum: 23.05.16
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 25.05.2016, 11:57     Titel:
  Antworten mit Zitat      
Jup, führt zum selben ergebnis nur ohne Warnungen!

Passt :thumsup:
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de