goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

"Gehe zu PDF" und "... zu Quelltext" feh

 

firefrog
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 17.02.13
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 27.03.2013, 00:45     Titel: "Gehe zu PDF" und "... zu Quelltext" feh
  Antworten mit Zitat      
Moinmoin,

ich habe aktuell ein recht kurioses Problem: wie der Titel schon vermuten lässt, funktionieren die Funktionen Rechtsklick -> "Gehe zu PDF" bzw. "Gehe zu Quelltext" nicht mehr so, wie sie sollen. Kurz zur Erklärung vorab: Ich verwende Texworks/Miktex 2.9. Ich habe die Hauptdatei in einem Ordner, die Kapitel jeweils als einzelne Dateien im Unterordner und mit \include{Kapitel/1_XYZ} etc. eingebunden. So.
Angefangen hat es jetzt damit, dass die Verweise bei einem einzelnen Kapitel nicht mehr funktioniert haben. "Gehe zu PDF" hatte überhaupt keinen Effekt, "Gehe zu Quelltext" hat einen Fehler produziert: "Kann die Datei "" nicht lesen. No file name specified". Exakt so geschrieben, inklusive der mittigen Anführungszeichen. Ich habe an den Dateien und -Namen eigentlich nichts geändert, aber gut. Onkel Google hat mir geraten, die .synctex-Datei im Hauptverzeichnis zu löschen und neu zu kompilieren - hab ich gemacht, allerdings ohne Erfolg bzw. mit gleichbleibendem Effekt.
Da ich das schon lange nicht mehr gemacht habe, habe ich (eigentlich von diesem Thema unabhängig) eine Sicherungskopie auf einem USB-Stick erstellt und aus einem Impuls die kopierte Version geöffnet - hier funktioniert die PDF-Quelltext-Verlinkung einwandfrei. In weiteren Versuchen habe ich eine weitere Kopie auf dem Desktop erstellt sowie die Kopie wieder in den ursprünglichen Ordner verschoben, in allen Fällen hat es funktioniert - bis ich es in dem Ursprungsordner neu kompiliert habe, dann wieder wie zu Beginn. Allerdings taucht die oben beschriebene Fehlermeldung nur manchmal auf, manchmal passiert auch einfach gar nichts.
(\edit: der Fehler tritt auf, wenn die "Zieldatei", also das entsprechende Kapitel, geöffnet ist. Wenn die Datei nicht geöffnet ist, passiert nichts.)

Soo, weiterhin hat Google gesagt, dass Miktex/Texworks wohl nicht mit Dateien zurechtkommt, die ein Leerzeichen im Namen haben oder hatten. Ist eigentlich nicht der Fall, die Datei heißt "8_XXX" und wurde exakt so wie die vorhergehenden Dateien erstellt. Zudem dürfte es dann auf dem USB-Stick auch nicht funktionieren. Leerzeichen in der Ordnerstruktur sind auch nicht vorhanden. Achja, und dann hatte ich noch einen Thread gefunden, laut dem man synctex erst noch aktivieren müsste, allerdings habe ich das Fenster, wo man das machen soll (laut Ewok aus diesem Forum: "Im Editor unter Optionen->Tex Studio konfigurieren->Befehle für das entsprechende Ausgabeprofil (hier PDFLatex):
pdflatex.exe -synctex=1 -interaction=nonstopmode %.tex"), schlicht und ergreifend nicht gefunden. So, und jetzt sitze ich hier und hoffe, dass irgendwer diesen Roman gelesen hat. Ich bin absolut ratlos und arbeite jetzt auf dem Desktop weiter, das dürfte wohl das geringste Übel sein. Trotzdem wäre es schön, wenn sich das wieder ändern würde...

Danke schonmal für jegliche Hilfe.


\edit2: es scheint am \chapter-Namen zu liegen. Sobald ich DORT Leerzeichen drin habe, bekomme ich oben beschriebenes Fehlerbild. Ich habe aber auch in vorhergehenden Kapiteln schon \chapter-Namen mit Leerzeichen verwendet, ohne dass es zu Problemen führt...!? An einem zu langen Titel kann es auch nicht liegen, der vorhergehende ist wesentlich länger, Umlaute oder Sonderzeichen sind auch nicht vorhanden, \label habe ich bei beiden Kapiteln noch nicht eingefügt. Mir fällt langsam nichts mehr ein, woran es liegen könnte.
Private Nachricht senden Benutzer-Profile anzeigen

Gast
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.03.2016, 11:20     Titel: mögliche Ursache: Package ULEM
  Antworten mit Zitat      
Ich hatte das gleiche Problem und kann alle deine Beobachtungen bestätigen. Ich habe als Ursache bei mir das Paket
Code • Öffne in Overleaf
\usepackage{ulem}
identifiziert. im Kapitel in dem die PDF-Code-Verlinkung nicht mehr funktioniert hatte ich \emph{} genutzt.

Gastarbeiter
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 04.03.2016, 14:54     Titel:
  Antworten mit Zitat      
Ich hatte auch dieses Problem. Lösen konnte ich des in dem ich die Dateinamen kürzer machte und weniger Unterordner verwendete.

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 01.09.2017, 10:52     Titel:
  Antworten mit Zitat      
Hallo, bei mir lag es an zwei "ö"s im Dateinamen. Grüße, TT
Verschoben: 01.09.2017, 11:45 Uhr von Johannes_B
Von MiKTeX nach LaTeX Editoren

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de