goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Guillemets

 

odie
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.11.08
Wohnort: Stuttgart
Version: ---
     Beitrag Verfasst am: 14.11.2008, 14:18     Titel: Guillemets
  Antworten mit Zitat      
Hallo zusammen.
Ich beschäftige mich noch nicht so lange mit Latex. Und jetzt habe ich auch schon das erste "Problem".
Ich möchte in meinem Text die Anführungszeichen ändern, weil mir die französischen (guillemets) besser gefallen. Leider will das nicht so richtig funktionieren, denn wenn ich den entsprechenden Befehl eingebe, erscheinen anstelle der Anführungszeichen nur kleine schwarze Quadrate. Was bedeutet das? Ist das jeweilige Zeichen nicht in meinem Schriftsatz?
Hier der Code:
Code • Öffne in Overleaf

\usepackage[latin1]{inputenc}
\usepackage{ae}
\usepackage[ngerman]{babel}
\usepackage[babel,german=quotes]{csquotes}
 

Theoretisch müsste ich doch jetzt nur "swiss" anstelle von "quotes" schreiben, um das gewünschte Ergebnis zu bekommen?!
Das funktioniert aber leider nicht, bzw. führt zum oben beschriebenen Problem. Sad
\frqq und \flqq funktionieren übrigens auch nicht.

Ich hoffe jemand kann mir helfen.

Grüße, odie
Private Nachricht senden Benutzer-Profile anzeigen

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 14.11.2008, 16:21     Titel:
  Antworten mit Zitat      
Dein Problem liegt an der Verwendung des Pakets »ae«. Dieses Paket wurde einmal als Notlösung erstellt, um mit der eigentlich OT1 codierten Schrift Computer Modern doch im T1-Encoding arbeiten zu können. Der Vorteil dabei ist, dass beispielsweise die Trennung von Wörtern mit Umlauten funktioniert. Dennoch kommen dadurch keine neuen Zeichen hinzu. Inzwischen ist diese Notlösung nicht mehr notwendig. Ich empfehle statt der Computer Modern die Latin Modern zu verwenden. Dies ist eine Weiterentwicklung der Computer Modern, die viele weitere Sprachen unterstützt. Darin sind auch Guillemets enthalten. Man erhält die Schrift in T1-Codierung mit:
Code • Öffne in Overleaf
\usepackage[T1]{fontenc}
\usepackage{lmodern}

Falls zusätzliche Text-Zeichen außerhalb der T1-Codierung wie das Eurozeichen verwendet werden sollen, empfiehlt sich, direkt die Verwendung von
Code • Öffne in Overleaf
\usepackage[TS1,T1]{fontenc}
\usepackage{lmodern,textcomp}

Eine Notlösung für die Erweiterung der Notlösung ae wäre die Verwendung von aeguill. Ich möchte davon abraten.
_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!
Private Nachricht senden Benutzer-Profile anzeigen

odie
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.11.08
Wohnort: Stuttgart
Version: ---
     Beitrag Verfasst am: 14.11.2008, 23:38     Titel:
  Antworten mit Zitat      
Super, ich werde das morgen gleich ausprobieren!
Vielen Dank für die nette, freundliche und ausführliche Hilfe! Very Happy
Grüße, odie
Private Nachricht senden Benutzer-Profile anzeigen

odie
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 14.11.08
Wohnort: Stuttgart
Version: ---
     Beitrag Verfasst am: 15.11.2008, 14:09     Titel:
  Antworten mit Zitat      
Hallo KOMA,
ich hab deine Lösung eben ausprobiert und sie hat prima funktioniert. Danke nochmal.
Da danach allerdings z.B. weder "ß" noch "°" aus der Eingabe korrekt übernommen wurde, habe ich den Code folgendermaßen geändert:
Code • Öffne in Overleaf

\usepackage[T1]{fontenc}
\usepackage{lmodern}

\usepackage[ansinew]{inputenc}

\usepackage[ngerman]{babel}

\usepackage[babel,german=swiss]{csquotes}
 


Spricht da was dagegen? Oder gilt: "wenn es richtig aussieht hab ich keine Probleme"`?! Wink

Grüße
Private Nachricht senden Benutzer-Profile anzeigen

Stefan Kottwitz
Admin
Admin


Beiträge: 1931
Anmeldedatum: 08.07.08
Wohnort: Hamburg
Version: TeX Live 2016
     Beitrag Verfasst am: 15.11.2008, 15:23     Titel: latin9 Codierung
  Antworten mit Zitat      
Hallo Odie,

ein kleiner Verbesserungsvorschlag: Du könntest latin9 statt ansinew verwenden, falls Du z.B. außer Umlauten auch das Euro-Symbol direkt im Text schreiben möchtest.

Stefan
Private Nachricht senden Benutzer-Profile anzeigen

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 15.11.2008, 18:30     Titel: Re: latin9 Codierung
  Antworten mit Zitat      
Stefan hat Folgendes geschrieben:
ein kleiner Verbesserungsvorschlag: Du könntest latin9 statt ansinew verwenden, falls Du z.B. außer Umlauten auch das Euro-Symbol direkt im Text schreiben möchtest.

Der Unterschied zwischen latin1 und ansinew (aka cp1252) ist, dass die Zeichen zwischen 128 und 159 ebenfalls belegt sind. Dabei ist Zeichen 128 das Euro-Zeichen. Mit ansinew sollte das Eurozeichen also ebenfalls direkt eingebbar sein.
_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!
Private Nachricht senden Benutzer-Profile anzeigen

KOMA
TeX-Entwickler
TeX-Entwickler


Beiträge: 2637
Anmeldedatum: 04.07.08
Wohnort: ---
Version: Ich bin hier nicht mehr zu erreichen!
     Beitrag Verfasst am: 15.11.2008, 18:46     Titel:
  Antworten mit Zitat      
odie hat Folgendes geschrieben:
Spricht da was dagegen? Oder gilt: "wenn es richtig aussieht hab ich keine Probleme"`?!

Natürlich spricht nichts dagegen die Verwendung eines bestimmten Fontencodings und eines bestimmten Fonts noch durch ein für den verwendeten Editor passendes Inputencoding und die Umschaltung auf die gewünschte Sprache zu ergänzen. Beides ist voneinander unabhängig.

Die einzige Querverbindung zwischen inputenc und fontenc besteht darin, dass die schönste Eingabecodierung (inputenc) nichts nützt, wenn die Ausgabecodierung (fontenc) oder der Zeichensatz Zeichen aus der Eingabecodierung nicht bereitstellt.

Dein Problem, dass keine Guillemets angezeigt wurden, resultierte daraus, dass sie im Zeichensatz nicht vorhanden waren. Probleme bei der Trennung resultieren häufig daraus, dass Zeichen im Fontencoding nicht vorhanden sind und deshalb im Inputencoding aus mehreren Zeichen zusammengesetzt werden (Beispiel: Umlaute beim Fontencoding OT1).

Dass bei Verwendung des Fontencodings T1 Umlaute häufig bereits ohne Angabe eines Inputencodings korrekt erscheinen, liegt daran, dass die Eingabe häufig latin1, latin9 oder ansinew codiert ist. Die Codierungen haben die Umlaute auf derselben Position wie T1. Bei anderen Zeichen ist das aber nicht der Fall, so dass die Übersetzungsschicht inputenc unbedingt benötigt wird. Dieses Wissen sollte man nun aber nicht dazu nützen, inputenc einfach weg zu lassen. Früher oder später wird das zu Problemen etwa bei der Weitergabe der Dateien führen.

Ich gebe zu, dass das ganze manchmal recht kompliziert erscheint. Ist es aber eigentlich gar nicht. Die Regel lautet:
  • per inputenc-Paket die Codierung angeben, die man zum Schreiben des Dokuments verwendet hat
  • per fontenc-Paket die beste Codierung auswählen, in der die Schrift vorliegt, was für lateinische Schriften in der Regel T1 ist
  • bei fontenc vor T1 ggf. noch TS1 angeben, falls man zusätzliche Textsymbole verwenden will und die Schrift diese in der Codierung TS1 bereitstellt
  • zusätzlich das Paket textcomp laden, falls man zusätzliche Textsymbole verwenden will

_________________

goLaTeX-Knigge (mit Themen Minimalbeispiel und So stellst Du Deine Frage richtig)
DE-TeX-FAQ, UK-FAQ, l2kurz, l2tabu, CTAN, The TeX Catalogue
KOMA-Script
Ich bin hier nicht mehr zu erreichen!
Private Nachricht senden Benutzer-Profile anzeigen

Stefan Kottwitz
Admin
Admin


Beiträge: 1931
Anmeldedatum: 08.07.08
Wohnort: Hamburg
Version: TeX Live 2016
     Beitrag Verfasst am: 15.11.2008, 18:57     Titel: Re: latin9 Codierung
  Antworten mit Zitat      
KOMA hat Folgendes geschrieben:

Der Unterschied zwischen latin1 und ansinew (aka cp1252) ist, dass die Zeichen zwischen 128 und 159 ebenfalls belegt sind. Dabei ist Zeichen 128 das Euro-Zeichen. Mit ansinew sollte das Eurozeichen also ebenfalls direkt eingebbar sein.

Stimmt, ist es auch, ich dachte bei ansinew zunächst an ein Synonym für latin1, doch es ist ja auch erweitert, siehe Vergleich. Ich ziehe allerdings eine ISO-Norm einer "Windows-Norm" vor. Wink

Stefan
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de