goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Viel Leerraum unter einem Bild

 

Tomm
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.02.2017, 15:34     Titel: Viel Leerraum unter einem Bild
  Antworten mit Zitat      
Hallo,

ich habe gerade ein Layout-Problem, das ich zuvor noch nie hatte. Und zwar ist bei dem unten angegebenen Minimalbeispiel auf der zweiten Seite unter dem Bild noch genug Platz, wo Abschnitt 3 schon beginnen könnte. Stattdessen wird Abschnitt 3 erst auf Seite 3 begonnen und unter dem Bild ist viel weißer Platz. Außerdem ist merkwürdigerweise das Ende vom zweiten Abschnitt ganz unten von Seite 2.
Code • Öffne in Overleaf

\documentclass[12pt,twoside]{article}
\usepackage[english]{babel}
\usepackage[latin1]{inputenc}
\usepackage{blindtext}
\usepackage[demo]{graphicx}
\begin{document}
   \section{Abschnitt 1}
   \blindtext
   \section{Abschnitt 2}
   \blindtext
   \begin{figure}[!htb]
      \includegraphics[width=\textwidth, height=14cm]{test.png}
      \caption{Bildunterschrift}
   \end{figure}
   \blindtext
   \blindtext
   \section{Abschnitt 3}
   \blindtext
\end{document}


Ich hoffe mir kann jemand helfen.

Gruß Tom

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3422
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 17.02.2017, 16:14     Titel:
  Antworten mit Zitat      
Abschnitt 3 kann da nicht beginnen. Das ist eine Überschrift und LaTeX versucht die nächsten zwei Zeile bei der Überschrift zu halten.


https://tex.stackexchange.com/quest.....ith-one-line-below-it-on/

Den Leerraum bekommst du, weil \flushbottom aktiv ist. Du kannst stattdessen \raggedbottom benutzen.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Tomm
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2017, 09:32     Titel:
  Antworten mit Zitat      
Hallo,

vielen Dank für den Hinweis. Das habe ich garnicht bedacht und ist natürlich sehr gut, dass Latex das so macht. Ich werde daher lieber mein Dokument etwas umgestalten, sodass solche Fälle garnicht vorkommen können.

Ich habe noch eine ähnliche Frage: Ich habe auch den Fall, dass eine Formel auf einer Seite ganz oben anfängt. Latex nimmt aber immer die letzte Zeile vor der Formel mit, sodass auf der vorherigen Seite vor der Überschrift wieder etwas Abstand entsteht. Ist das auch so üblich, dass Formeln nicht ganz oben auf Seiten beginnen? Falls Ja, werde ich wohl auch hier versuchen, das Layout etwas umzugestalten. Falls Nein; kann man das verhindern, dass Latex die Textzeile vor der Formel mitzieht?
Das zugehörige Minimalbeispiel (gemeint ist die Formel auf Seite 3 oben und den ungewünschten Abstand vor Abschnitt 3 auf Seite 2):

Code • Öffne in Overleaf

\documentclass[12pt,twoside]{article}
\usepackage[english]{babel}
\usepackage[latin1]{inputenc}
\usepackage{blindtext}
\usepackage[demo]{graphicx}
\usepackage{amsmath}
\begin{document}
   \section{Abschnitt 1}
   \blindtext
   \section{Abschnitt 2}
   \blindtext
   \begin{figure}[!htb]
      \includegraphics[width=\textwidth, height=9.5cm]{test.png}
      \caption{Bildunterschrift}
   \end{figure}
   \blindtext
   \blindtext
   \section{Abschnitt 3}
   \blindtext
   Mit dem Ausdruck
   \begin{align}
      a = b + c
   
\end{align}
   kann...
\end{document}
 


Danke,
Gruß Tom

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3422
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2017, 10:39     Titel:
  Antworten mit Zitat      
Du kannst \predisplaypenalty ändern (Z.B. auf 9999), aber es sollte auf keinen Fall global gemacht werden und ich halte es in diesem Fall für eine schlechte Idee: Der Text "Mit dem Ausdruck" gehört zur Formel.

https://tex.stackexchange.com/quest.....is-wrong-idea/46971#46971
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

Tomm
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2017, 11:21     Titel:
  Antworten mit Zitat      
Hallo,

vielen Dank für deine Einschätzung und wie man das Problem (zur Not) beheben kann. Ich werde nun schauen, wie es sich am besten ergibt.

Vielen Dank!
Gruß Tom

Tomm
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 20.02.2017, 11:23     Titel:
  Antworten mit Zitat      
Hallo,

sorry, ich habe vergessen den Status auf "beantworten" zu setzen, was ich nun getan habe. Ich hoffe das ist in Ordnung so.

Gruß Tom

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de