goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Vermeidung veralteter Pakete und deren Fehler

 

Philipp_Koller
Forum-Newbie
Forum-Newbie

Beiträge: 3
Anmeldedatum: 30.06.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 30.06.2017, 14:21     Titel: Vermeidung veralteter Pakete und deren Fehler
  Antworten mit Zitat      
Hallo,

Ich bin dazu gezwungen/genötigt eine bestehenede Berichtsvorlage zu verwenden. Wenn ich mein Dokument kompiliere, bekomme ich 2 Warnungen. Diese Warnungen resultieren wahrscheinlich aus der Verwendung von alten Paketen oder eventuell von mehrfachen Aufrufen dieser Pakete. Leider entzieht sich das (als Basic-LaTeX-Anwender) meinen Wissen.

Hier sind meine Pakete (Initialisierung)


Code • Öffne in Overleaf

\listfiles
\PassOptionsToPackage{table}{xcolor}
\RequirePackage{pdf14} %https://tex.stackexchange.com/questions/64585/incompatibilities-of-cmap-with-fontenc-hyperref
\documentclass[bibliography=totoc,numbers=noenddot]{scrreprt}


\usepackage{longtable} %Large tables (longtable)
\usepackage{tikz,booktabs}
\usetikzlibrary{positioning}
\usepackage{wallpaper}
\usepackage{mwe}
\usepackage{pdflscape}
\usepackage{graphicx}
\usepackage[english,ngerman]{babel}
\usepackage{mathptmx}
\usepackage{multicol}
\usepackage{multirow}
\usepackage[scaled]{uarial}
\renewcommand*\familydefault{\sfdefault}
\usepackage[T1]{fontenc}
\usepackage{mdwlist}
\usepackage{listings}
\usepackage{textcomp}
\usepackage{lastpage}
\usepackage[automark,plainheadsepline,headsepline,footsepline,plainfootsepline]{scrpage2}
\usepackage{booktabs,caption}
\usepackage{caption}
\usepackage{tabularx}
\usepackage{varwidth} % Für die Definition  eines neuen Spalten-Typs
\usepackage[numbers]{natbib}   % für Benutzung von \bibliographystyle{natdin} und \bibliographystyle{dinat} bei bibtex
\usepackage{multibib}         % ermöglicht die Verwendung mehrerer Literaturverzeichnisse
\usepackage[copy-decimal-marker]{siunitx}%Für die Komma Ausrichtung der Zahlen
\usepackage{amsmath,bm}      % Für fettgeschriebene Zeichen in der Mathematikumgebung
\usepackage{float}         % Für Positionierung von Floats (figures etc.)
\usepackage{pgfplots}      % Für Plots von Amplitudenspektren, Rainflow-Matrizen
%\pgfplotsset{compat=1.14}
\usetikzlibrary{patterns}   % Für Plots von Rainflow-Matrizen
\pgfplotsset{
compat=1.8,
colormap/bluered,   % Colorbars "bluered" als Standard-Colorbar
every axis title/.append style={font=\normalsize}, % Diagramtitel Größe
every axis/.append style={font=\scriptsize}, % Achsenbeschriftungen Größe
}
\usepgfplotslibrary{external}
\tikzexternalize[prefix=cache/]

% TabularX:
\def\tabularxcolumn#1{m{#1}}  
\newcolumntype{L}[1]{>{\raggedright\let\newline\\\arraybackslash\hspace{0pt}}m{#1}}
\newcolumntype{C}[1]{>{\centering\let\newline\\\arraybackslash\hspace{0pt}}m{#1}}
\newcolumntype{R}[1]{>{\raggedleft\let\newline\\\arraybackslash\hspace{0pt}}m{#1}}

\newcommand{\ltab}{\raggedright\arraybackslash} % Tabellenabschnitt linksbündig
\newcommand{\ctab}{\centering\arraybackslash} % Tabellenabschnitt zentriert
\newcommand{\rtab}{\raggedleft\arraybackslash} % Tabellenabschnitt rechtsbündig
\renewcommand*{\footfont}{\normalfont}
\renewcommand*{\headfont}{\normalfont}
\pagestyle{scrheadings}
\usepackage[latin1]{inputenc}
\usepackage[left=2.00cm, right=2.00cm, top=2.00cm, bottom=2.00cm,includeheadfoot]{geometry}

% Schriftart Arial einstellen:
\usepackage[scaled]{uarial}
\renewcommand*\familydefault{\sfdefault}
\usepackage[T1]{fontenc}   % Codierung für europäische Zeichen

\setlength\LTleft{0pt}
\setlength\LTright{0pt}

\usepackage[colorlinks=false, linkcolor=blue, citecolor=blue, linkbordercolor=red, citebordercolor={0 1 0}, pdfa]{hyperref}   % Für Querverweise in pdf


\renewcommand*{\footfont}{\normalfont}
\renewcommand*{\headfont}{\normalfont}
\pagestyle{scrheadings}

\newcommand\tabrotate[1]{\rotatebox{90}{#1\hspace{\tabcolsep}}}      % Für vertikale Ausrichtung von Texten in Tabellenfeldern



\setlength\parindent{0pt}   % Damit 1. Zeile eines Absatzes nicht eingerückt wird
 





meine Fehlermeldung:
Code • Öffne in Overleaf
pdflatex.exe (file W:/SF7000/DesMoor/04_Sa/TrcK/Doku/Berichte/I/cache/Sa-I_TrcK_DesMoor_SF7000-figure6.pdf): PDF inclusion: found PDF version <1.5>, but at most version <1.4> allowed===== Image 'cache/Sa-I_TrcK_DesMoor_SF7000-figure7' is up-to-date. ======


mit welcher Einstellung become ich diesen Fehler weg?
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2237
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 30.06.2017, 20:41     Titel:
  Antworten mit Zitat      
Offensichtlich möchtest Du ein Dokument erstellen, dass der pdf Version 1.4 entspricht. Mindestens eines Deiner eingebundenen pdfs ist aber pdf Version 1.5. Um die Warnung loszuwerden, müsstest Du dieses in pdf Version 1.4 umwandeln.

Deine Präambel ist ein buntes Durcheinander, in dem dann beispielsweise einige Pakete mehrmals geladen werden oder veraltet sind. Weißt Du überhaupt, ob und wofür Du die ganzen Pakete benötigst?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 01.07.2017, 08:04     Titel:
  Antworten mit Zitat      
Du hättest ja wenigstens die Kommentare zu http://texwelt.de/wissen/fragen/203.....wendung-veralteter-pakete schon einmal beachten können. Siehe außerdem http://golatex.de/vorlage-bachelor-masterarbeit-t19350.html weil dort teilweise dieselben Fehler bemängelt werden. Für ein neues Dokument würde ich für die Literatur auch eher zu Paket auf CTANbiblatex greifen. Siehe dazu das Literaturverzeichnis-Forum.

Übrigens sehe ich auch keinen Grund sich bei Paket auf CTANpgfplots auf Kompatibilität zur total veralteten Version 1.8 zu beschränken. Aktuell ist 1.15. Installationen wie Overleaf haben häufig noch 1.13 oder 1.14.

Ich würde auch eher davon abraten Arial als Grundschrift zu verwenden. Dazu ist sie einfach nicht geschaffen. Nur wenige serifenlose Fonts taugen dazu.

Paket auf CTANscrpage2 ist veraltet. Nimm Paket auf CTANscrlayer-scrpage.

Das Umdefinieren von \footfont und \headfont ist veraltet und nicht länger empfohlen. Verwende \setkomafont{pageheadfoot}{} etc.

Der Dateiname aus der Meldung klingt ein wenig nach einer mit tikz-external erzeugten Datei. Dabei ist dann aber die abweichende PDF-Version halbwegs seltsam. Eigentlich stellt sich überhaupt eher die Frage, wo bei Dir \pdfminorversion auf 4 gesetzt wird. Die Voreinstellung ist nämlich 5 und damit tritt das Problem dann gar nicht erst auf. Da solltest Du mit einem InfoMinimalbeispiel eingrenzen. Ich habe jedenfalls keine Lust, die Präambel für Dich erst zu einem Dokument zu erweitern, auszumisten und dann zu minimieren. Das kannst Du selbst.

esdd
Forum-Meister
Forum-Meister

Beiträge: 2237
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 01.07.2017, 10:31     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:
Eigentlich stellt sich überhaupt eher die Frage, wo bei Dir \pdfminorversion auf 4 gesetzt wird. Die Voreinstellung ist nämlich 5 und damit tritt das Problem dann gar nicht erst auf. Da solltest Du mit einem InfoMinimalbeispiel eingrenzen. Ich habe jedenfalls keine Lust, die Präambel für Dich erst zu einem Dokument zu erweitern, auszumisten und dann zu minimieren. Das kannst Du selbst.


Sowohl durch das Laden des Paketes Paket auf CTANpdf14 (erfolgt vor der Dokumentenklasse) als auch die pdfa Option beim Laden von Paket auf CTANhyperref wird die Version auf 4 gesetzt. Das zusätzliche Paket scheint nötig zu sein, weil sonst die Einstellung der Version zu spät erfolgt. Bleibt aber die Frage, ob das alles wirklich benötigt wird.
Private Nachricht senden Benutzer-Profile anzeigen

esdd
Forum-Meister
Forum-Meister

Beiträge: 2237
Anmeldedatum: 07.02.10
Wohnort: Stutensee
Version: MiKTeX 2.9
     Beitrag Verfasst am: 01.07.2017, 10:31     Titel:
  Antworten mit Zitat      
Anonymous hat Folgendes geschrieben:
Eigentlich stellt sich überhaupt eher die Frage, wo bei Dir \pdfminorversion auf 4 gesetzt wird. Die Voreinstellung ist nämlich 5 und damit tritt das Problem dann gar nicht erst auf. Da solltest Du mit einem InfoMinimalbeispiel eingrenzen. Ich habe jedenfalls keine Lust, die Präambel für Dich erst zu einem Dokument zu erweitern, auszumisten und dann zu minimieren. Das kannst Du selbst.


Sowohl durch das Laden des Paketes Paket auf CTANpdf14 (erfolgt vor der Dokumentenklasse) als auch die pdfa Option beim Laden von Paket auf CTANhyperref wird die Version auf 4 gesetzt. Das zusätzliche Paket scheint nötig zu sein, weil sonst die Einstellung der Version zu spät erfolgt. Bleibt aber die Frage, ob das alles wirklich benötigt wird.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de