goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Installationsprobleme

 

Knie
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.12.2016, 15:27     Titel: Installationsprobleme
  Antworten mit Zitat      
Hallo ihr Lieben,

ich habe schon eine ganze Weile nicht mehr mit dem Laptop geschrieben. Meist nutze ich den Büro PC an der Uni. Jetzt das Problem. Mein aktuelles Dokument besitzt zB das Paket "xcolor" neu in der Präambel. Beim schnellen Übersetzen kam das Pop-up Fenster von MikTex, es fehlt noch. Also, ich klickte auf Installieren, das Fenster ging zu und es kam nur ne Fehlermeldung "xcolor.sty not found". Ich dachte mir, dann hat halt der Installationsdialog den Befehl nicht weitergegeben und habe manuell über den MikTex Package Manager xcolor installiert - was erstmal problemlos klappte (in der Liste steht jetzt das heutige als Installationsdatum).
Also übersetzte ich das Dokument neu. Da kamen irgendwelche anderen MikTex Fenster, die mir sagen, dass Pakete zu installieren sind. Kann ja sein. Jedenfalls meint es momentan "! LaTeX Error: File `chemgreek.sty' not found."

Ich habe aber das Paket "chemgreek" gar nicht in der Präambel, nur mhchem und das ist laut Package Manager installiert. Was also kann da der Fehler sein? Ich hoffe, das kommt nicht noch für mehr Pakete.

Beinschuss
Forum-Meister
Forum-Meister

Beiträge: 745
Anmeldedatum: 02.10.12
Wohnort: NRW
Version: MiKTeX, Windows 10, TeXstudio
     Beitrag Verfasst am: 06.12.2016, 15:50     Titel:
  Antworten mit Zitat      
InfoMinimalbeispiel? Welche MiKTeX-Version ist installiert, d.h. wie uralt ist die Installation auf dem länger nicht genutzen Laptop? Update gemacht?
Private Nachricht senden Benutzer-Profile anzeigen

Gast


Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.12.2016, 15:58     Titel:
  Antworten mit Zitat      
Pakete können andere Pakete benötigen. So benötigt beispielsweise Paket auf CTANmhchem u. a. Paket auf CTANchemgreek wie man in der log-Datei daran erkennt, dass TeX versucht, Paket auf CTANchemgreek zu lesen, nachdem es mhchem.sty geöffnet aber bevor es das wieder geschlossen hat.

Man kann natürlich auch einfach in mchem.sty selbst schauen und findet dort:
Code • Öffne in Overleaf
\RequirePackage{chemgreek}[2016/02/10]


Statt daran zu zweifeln, dass als fehlend gemeldete Pakete wirklich benötigt werden, solltest du einfach alle als fehlend gemeldeten Pakete installieren. Man kann in MiKTeX-Settings übrigens auch einstellen, dass Pakete automatisch und ohne Nachfrage nachinstalliert werden. Das ist zumindest am Anfang ganz praktisch.

Natürlich kannst du auch im Paketmanager alle Pakete auswählen und installieren, von denen du nicht ganz sicher bist, dass du sie nicht brauchst. Oder du verwendest TeX Live. Dort wird bereits in der Voreinstellung (fast) alles installiert, so dass man später nichts mehr nachinstallieren muss. Bei den heutigen Plattenpreisen ist das meist eine gute Wahl.

Knie
Gast

Beiträge: ---
Anmeldedatum: ---
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 06.12.2016, 17:12     Titel:
  Antworten mit Zitat      
Ich werde eben updaten. Bisher steht dort, MikTex Version 2.9. Ich wollte auch zuerst einfach die Pakete nachinstallieren, die es gesagt hat, zu brauchen. Allerdings funktionierte es nicht. Die Meldung verschwand und es wurde nicht installiert. Ich weiß allerdings noch nicht, warum. Bisher ging das automatisch (wie vorgeschlagen). Daher überhaupt die Frage, ob es sein kann, dass man Pakete braucht, die man nicht direkt ausgewählt hat. Mal sehen, ob das Update dazu führt, dass eventuell das Installieren wieder klappt. Danke!

Neues Thema eröffnen Neue Antwort erstellen



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de