goLaTeX - Mein LaTeX-Forum

Mein LaTeX-Forum


Login  | Registrieren
Forum
      Option
[Erweitert]
  • Diese Seite weiterempfehlen
     


Gehe zu:  
Neues Thema eröffnen Neue Antwort erstellen

Babel-Silbentrennung

 

kasper_d
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 14.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 14:34     Titel:
  Antworten mit Zitat      
Bartman hat Folgendes geschrieben:
Das Beispiel des Gastes füllt meine log-Datei mit dieser Ausgabe:

[...]


Bei mir identisch.
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3574
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 14:46     Titel:
  Antworten mit Zitat      
Also dass british funktioniert hatte ich eigentlich erwartet.
was bekommst du, wenn du

kpsewhich --all hyphen.tex

auf einer Eingabeaufforderung eingibst? Und was sagt dein language-tab in miktex settings?

N.B. Ne-vert-he-less ist eine deutsche Trennung. Die Frage ist also, warum das der Standard ist.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

kasper_d
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 14.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 15:07     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
C:\Users\user>kpsewhich --all hyphen.tex
C:/Program Files (x86)/MiKTeX 2.9/tex/generic/knuth-lib/hyphen.tex
C:/Program Files (x86)/MiKTeX 2.9/tex/generic/knuth-lib/hyphen.tex


MikTex Options sagt:





Zudem:
Code • Öffne in Overleaf
german
german-x-2017-03-31 = german-x-latest
ngerman
ngerman-x-2017-03-31 = german-x-latest


Mir wäre da nichts aufgefallen. Danke!

miktex options languages 2.png
 Beschreibung:

Download
 Dateiname:  miktex options languages 2.png
 Dateigröße:  4.83 KB
 Heruntergeladen:  29 mal
miktex options languages 1.png
 Beschreibung:

Download
 Dateiname:  miktex options languages 1.png
 Dateigröße:  3.39 KB
 Heruntergeladen:  28 mal
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3574
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 15:22     Titel:
  Antworten mit Zitat      
Hm. Rufe mal

kpsewhich --engine=pdftex pdflatex.fmt

auf.

Je nachdem ob sich das Format (die fmt-Datei) im admin oder user-Konto befindet, erzeuge mal in miktex settings (admin oder user) die Formate neu. Wenn das Problem dann immer noch existiert (mit deinem Anfangsbeispiel), dann rufe mal in einem leeren (!), temporären (!) Ordner

pdftex --ini --enable-etex pdflatex.ini

auf und zeige die log-Datei, die dabei erzeugt wird. Vielleicht kann man dann erkennen, warum ihr die falschen Trennmuster verwendet.
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

kasper_d
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 14.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 15:41     Titel:
  Antworten mit Zitat      
u_fischer hat Folgendes geschrieben:
Hm. Rufe mal

kpsewhich --engine=pdftex pdflatex.fmt

auf.


Code • Öffne in Overleaf

C:\Users\user>kpsewhich --engine=pdftex pdflatex.fmt
C:/Users/user/AppData/Local/MiKTeX/2.9/miktex/data/le/pdftex/pdflatex.fmt
 



Zitat:

Je nachdem ob sich das Format (die fmt-Datei) im admin oder user-Konto befindet, erzeuge mal in miktex settings (admin oder user) die Formate neu.


Das hat als "user" bei mir nicht funktioniert:

Code • Öffne in Overleaf

======================================================================
starting package maintenance...
installation directory: "C:\Program Files (x86)\MiKTeX 2.9"
package repository: ftp://ftp.gwdg.de/pub/ctan/systems/win32/miktex/tm/packages/
lightweight database digest: bcd40348e77e4d0dc9165ef9c464d390
going to download 672 bytes
going to install 2 file(s) (1 package(s))
downloading ftp://ftp.gwdg.de/pub/ctan/systems/.....s/miktex-etex.tar.lzma...

Unfortunately, the package miktex-etex could not be installed.Please check the log file:
C:/Users/user/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log
======================================================================

Sorry, but miktex-makefmt did not succeed for the following reason:

  The input file could not be found.

The log file hopefully contains the information to get MiKTeX going again:

  C:/Users/user/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log

You may want to visit the MiKTeX project page, if you need help.

Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

  C:/Users/user/AppData/Local/MiKTeX/2.9/miktex/log/initexmf.log

You may want to visit the MiKTeX project page, if you need help.
 


Als "admin" hat es auch nicht funktioniert:

Code • Öffne in Overleaf


======================================================================
starting package maintenance...
installation directory: "C:\Program Files (x86)\MiKTeX 2.9"
package repository: http://ctan.space-pro.be/tex-archiv.....win32/miktex/tm/packages/
lightweight database digest: bcd40348e77e4d0dc9165ef9c464d390
going to download 4669 bytes
going to install 10 file(s) (1 package(s))
downloading http://ctan.space-pro.be/tex-archiv.....tex-ini-files.tar.lzma...
4669 bytes, 17.88 KB/Sec
extracting files from tex-ini-files.tar.lzma...
======================================================================
Creating the lualatex format file...
Running miktex-luatex.exe...
This is LuaTeX, Version 1.0.4 (MiKTeX 2.9.6300)  (INITEX)

 restricted system commands enabled.

("C:/Program Files (x86)/MiKTeX 2.9/tex/generic/tex-ini-files/lualatex.ini"

("C:/Program Files (x86)/MiKTeX 2.9/tex/generic/tex-ini-files/luatexconfig.tex"

(C:/Users/admin/AppData/Roaming/MiKTeX/2.9/tex/generic/config/pdftexconfig.tex)

) ("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/latex.ltx"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/texsys.cfg")

./texsys.aux found





\@currdir set to: ./.





Assuming \openin and \input

have the same search path.





Defining UNIX/DOS style filename parser.



catcodes, registers, parameters,

LaTeX2e <2017-04-15>

hacks, control, par, spacing, files, font encodings, lengths,

====================================



Local config file fonttext.cfg used



====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fonttext.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fonttext.ltx"

=== Don't modify this file, use a .cfg file instead ===



("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omlenc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/t1enc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1enc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omsenc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/tuenc.def")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/tulmr.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/tulmss.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/tulmtt.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/t1cmr.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmr.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmss.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ot1cmtt.fd")))

====================================



Local config file fontmath.cfg used



====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fontmath.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/fontmath.ltx"

=== Don't modify this file, use a .cfg file instead ===



("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omlcmm.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omscmsy.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/omxcmex.fd")

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/ucmr.fd")))

====================================



Local config file preload.cfg used



=====================================

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/preload.cfg"

("C:/Program Files (x86)/MiKTeX 2.9/tex/latex/base/preload.ltx")) page nos.,

x-ref, environments, center, verbatim, math definitions, boxes, title,

sectioning, contents, floats, footnotes, index, bibliography, output,

======================================================================

starting package maintenance...

installation directory: "C:\Program Files (x86)\MiKTeX 2.9"

package repository: ftp://ftp.fau.de/ctan/systems/win32/miktex/tm/packages/

lightweight database digest: bcd40348e77e4d0dc9165ef9c464d390

going to download 224429 bytes

going to install 11 file(s) (1 package(s))

downloading ftp://ftp.fau.de/ctan/systems/win32...../unicode-data.tar.lzma...



Unfortunately, the package unicode-data could not be installed.Please check the log file:

C:/Users/admin/AppData/Local/MiKTeX/2.9/miktex/log/miktex-luatex.log

======================================================================



 Unicode character data,



! LaTeX Error: File `load-unicode-data.tex' not found.



Type X to quit or <RETURN> to proceed,

or enter new name. (Default extension: tex)



Enter file name:

! Emergency stop.

<read *>

   

l.8259   \input{load-unicode-data}

                               


 241 words of node memory still in use:

   1 dir, 34 glue_spec, 1 if_stack nodes

   avail lists: 2:11,3:1,4:1

!  ==> Fatal error occurred, no output PDF file produced!

Transcript written on lualatex.log.


Sorry, but miktex-makefmt did not succeed for the following reason:

  miktex-luatex.exe failed on lualatex.ini.

The log file hopefully contains the information to get MiKTeX going again:

  C:/Users/admin/AppData/Local/MiKTeX/2.9/miktex/log/miktex-makefmt.log

You may want to visit the MiKTeX project page, if you need help.

Sorry, but "MiKTeX Configuration Utility" did not succeed.

The log file hopefully contains the information to get MiKTeX going again:

  C:/Users/admin/AppData/Local/MiKTeX/2.9/miktex/log/initexmf_admin.log

You may want to visit the MiKTeX project page, if you need help.
 


Zitat:
Wenn das Problem dann immer noch existiert (mit deinem Anfangsbeispiel), dann rufe mal in einem leeren (!), temporären (!) Ordner

pdftex --ini --enable-etex pdflatex.ini

auf und zeige die log-Datei, die dabei erzeugt wird. Vielleicht kann man dann erkennen, warum ihr die falschen Trennmuster verwendet.


Siehe anbei. Für mich ist die Lösung, einfach mal auf "british" umzustellen, aber mir scheint es, hier gibt es irgendein Problem in der ganzen Software, vor dem letzten Update hat es bei mir ziemlich sicher funktioniert. Danke!

miktex-makefmt.log
 Beschreibung:
user

Download
 Dateiname:  miktex-makefmt.log
 Dateigröße:  4.95 KB
 Heruntergeladen:  37 mal
initexmf.log
 Beschreibung:
user

Download
 Dateiname:  initexmf.log
 Dateigröße:  6.35 KB
 Heruntergeladen:  29 mal
pdflatex.log
 Beschreibung:

Download
 Dateiname:  pdflatex.log
 Dateigröße:  34.56 KB
 Heruntergeladen:  35 mal
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 993
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 13.05.2017, 16:06     Titel:
  Antworten mit Zitat      
Code • Öffne in Overleaf
kpsewhich --engine=pdftex pdflatex.fmt


Mein Installationsverzeichnis ist zwar ein anderes als bei kasper_d, aber der Rest meiner Ausgabe gleicht seiner.

In MiKTeX Options sehe ich bei english, ukenglish und usenglishmax auch das, was im Bildschirmfoto von kasper_d zu sehen ist.

Der Aufruf von

Code • Öffne in Overleaf
pdftex --ini --enable-etex pdflatex.ini


in einem zuvor leeren Ordner ergibt die log-Datei, die ich wegen ihrer Länge angehängt habe.

Ich habe MiKTeX nur noch als Benutzer-Variante installiert, nicht als Administrator.

pdflatex.log
 Beschreibung:

Download
 Dateiname:  pdflatex.log
 Dateigröße:  28.84 KB
 Heruntergeladen:  30 mal
Private Nachricht senden Benutzer-Profile anzeigen

u_fischer
Forum-Meister
Forum-Meister

Beiträge: 3574
Anmeldedatum: 22.11.12
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 16:23     Titel:
  Antworten mit Zitat      
Nun, nichts ist schwerer zu analysieren wie ein Fehler, den man nicht reproduzieren kann ;-). Ich sehe keine falsche Trennung und ich sehe auch nichts, was die erklären würde. Ne-vert-he-less kriege ich nur hin, wenn ich deutsch verwende, all englischen Sprachen trennen Nev-er-the-less
_________________

Ulrike Fischer
www.troubleshooting-tex.de
Private Nachricht senden Benutzer-Profile anzeigen

kasper_d
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 14.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 17:00     Titel:
  Antworten mit Zitat      
u_fischer hat Folgendes geschrieben:
Nun, nichts ist schwerer zu analysieren wie ein Fehler, den man nicht reproduzieren kann Wink. Ich sehe keine falsche Trennung und ich sehe auch nichts, was die erklären würde. Ne-vert-he-less kriege ich nur hin, wenn ich deutsch verwende, all englischen Sprachen trennen Nev-er-the-less


Danke trotzdem, für mich ist die Lösung ja einfach (british statt english), und zum Glück gibt es ja dieses Forum, aber irgendwie ist es manchmal frustrierend, theoretisch hätte ich das Update auch später machen und den Fehler nicht mehr bemerken können, und Zeit kostet es halt auch ...
Private Nachricht senden Benutzer-Profile anzeigen

Bartman
Forum-Meister
Forum-Meister


Beiträge: 993
Anmeldedatum: 16.07.09
Wohnort: Hessische Provinz
Version: Windows 7 64 Bit MiKTeX 2.9 32-Bit
     Beitrag Verfasst am: 13.05.2017, 18:48     Titel:
  Antworten mit Zitat      
Ich habe gerade den Update Manager gestartet und es wurden unter anderem KOMA-Script, bidi, und babel-french auf einen neueren Stand gebracht. Nach einer erneuten Ausführung meines Beispiels findet die Worttrennung auch beim amerikanischen English wieder an den richtigen Stellen statt.
Private Nachricht senden Benutzer-Profile anzeigen

kasper_d
Forum-Anfänger
Forum-Anfänger

Beiträge: 17
Anmeldedatum: 14.04.17
Wohnort: ---
Version: ---
     Beitrag Verfasst am: 13.05.2017, 20:41     Titel:
  Antworten mit Zitat      
Bartman hat Folgendes geschrieben:
Ich habe gerade den Update Manager gestartet und es wurden unter anderem KOMA-Script, bidi, und babel-french auf einen neueren Stand gebracht. Nach einer erneuten Ausführung meines Beispiels findet die Worttrennung auch beim amerikanischen English wieder an den richtigen Stellen statt.


Ja, das habe ich gerade auch gemacht, jetzt funktioniert es weder, genau diese drei Updates und der Fehler ist weg, american und british sind nun gleich.
Private Nachricht senden Benutzer-Profile anzeigen

Neues Thema eröffnen Neue Antwort erstellen Gehe zu Seite Zurück  1, 2, 3  Weiter



Options and Permissions
Beiträge der letzten Zeit anzeigen:

Du kannst Beiträge in dieses Forum schreiben.
Du kannst auf Beiträge in diesem Forum antworten.
Du kannst deine Beiträge in diesem Forum nicht bearbeiten.
Du kannst deine Beiträge in diesem Forum nicht löschen.
Du kannst an Umfragen in diesem Forum nicht mitmachen.
Du kannst Dateien in diesem Forum nicht posten
Du kannst Dateien in diesem Forum herunterladen
.

goLaTeX ist Teil der goForen
goForen.de goMATLAB.de goLaTeX.de goPCB.de


  Impressum | FAQ | goLaTeX RSS Button RSS-Feed

Copyright © 2008 - 2017 goLaTeX.de